Results 1 to 3 of 3

Thread: KDE 3.5 fonts corrupting and icons disappear

  1. #1
    Join Date
    Jun 2008
    Location
    Hereford, UK
    Posts
    45

    Default KDE 3.5 fonts corrupting and icons disappear

    Hello all,

    I have an issue with fonts corrupting after a few hours of being on and the menu icons and desktop icons disappear..

    Now my pc is:
    AMD X2 6000+ (dual 3ghz)
    1gig of ram shared with on board graphics.

    Running opensuse 11.1 default kernel.
    (KDE 3.5)
    I have 3 users the main program that seems to case it is googleearth my little brother who is mentally handicapped flies all over the world. he then logs off and my dad will log on his profile and the fonts don't show correctly. If i restart the computer all is well..

    Anyone have any ideas I have never had this issue before and dont run any kind of eye candy programs.
    The next time It happens I will try and take a screen shot and load on my server.

    Many thanks

    Dave
    Last edited by kungfu; 07-Mar-2009 at 03:19. Reason: updating info about desktop KDE 3.5
    Giz a Job
    The Raver

  2. #2
    Join Date
    Jun 2008
    Location
    Hereford, UK
    Posts
    45

    Default Re: KDE 3.5 fonts corrupting and icons disappear

    Giz a Job
    The Raver

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Re: KDE 3.5 fonts corrupting and icons disappear

    Never seen this, so I'm guessing:

    1) Try changing the desktop font, also if it is truetype try fixed and vice-versa.

    2) Is there a difference in code-page settings from one user to another (not sure if this is a system-wide setting in fstab or changeable in kde)?

    3) Try to update X from the update repo (not the X11:... repos), if an update is available.

    To isolate the cause:

    1) Is it only the desktop that corrupts or the program windows (menus, toolbars) too?

    2) If you rename /home/.kde to something else and restarts X (log out and in again) you get a brand new standard desktop. Do the fonts stay corrupted or not? Note: to get your desktop config back just delete the new .kde and rename the old one back, restart X.

    3) Does this also happen when you log into the third account or just your dad's?

    4) Did this always happen or only after a software update (KDE, for instance).

    5) Is your KDE installation OK? Are there unresolved dependencies or incompatible (different versions) KDE packages? You can check this in Yast> Software manager or with the zypper tool.

    That's all I can think of ATM. Good luck.
    Last edited by brunomcl; 09-Mar-2009 at 21:11. Reason: typos

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •