Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: YaST got signal 11at clients/online_update_select.ycp:83

  1. #1

    Default YaST got signal 11at clients/online_update_select.ycp:83

    openSUSE 11.0 with KDE4.2 Factory repositories, next to others ;-)

    Happened between yesterday and today. Can't do any updates anymore, because of error

    YaST got signal 11 at YCP file /usr/share/YaST2/clients/online_update_select.ycp:83
    /sbin/yast2: line 421: 12085 Speicherzugriffsfehler $ybindie/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    Ok, there are many questions and answers about this subject, dating back to 2007.

    I tried to get along and failed. This is what did NOT help :-(

    -delete the zypp db -> There are no files like that
    # rm /var/cache/zypp/zypp.db /var/cache/zypp/zypp.db-journal

    -reorg the pkg mgt
    # rpm --rebuilddb
    # zypper ref
    # zypper up

    - update with console yast
    -> no change

    - deactivating all repos and activating them again with console yast
    -> no change

    - just a helpless try: Throw away the repo infos by renaming /var/cache/zypp to a tmp name
    -> no change, though all repos get reread from update

    From those other ideas i take the fact, that i MUST get rid of this zypp.db, but where is it? Has it a different name?

  2. #2

    Default Re: YaST got signal 11at clients/online_update_select.ycp:83

    Don't know, if this is of interest for anybody, but i will replicate an answer from german "linux forum", where i placed the same question meanwhile.

    The buggy part comes from the corresponding QT repo. They started to roll out new versions of qt4libs (V4.4 and V4.5rc1), which create the trouble. In order to get your yast2 running again, you must downgrade all of these libs.

  3. #3
    Ogbetua NNTP User

    Default Re: YaST got signal 11at clients/online_update_select.ycp:83

    How do I downgrade without YaST?

  4. #4
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: YaST got signal 11at clients/online_update_select.ycp:83

    I had this problem too with 11.1. But about a week and a half ago I updated KDE 4.2 and Qt 4.5 and the problem was fixed.

    You can probably run YaST in ncurses mode from run level 3. If YaST won't work, add the repos you need with zypper and run zypper up.

  5. #5
    Join Date
    Feb 2009
    Location
    Rimini, Italy
    Posts
    2

    Default Re: YaST got signal 11at clients/online_update_select.ycp:83

    Same trouble...
    And now same question: how to downgrade qt4libs without Yast?
    Thanks

  6. #6
    Join Date
    Feb 2009
    Location
    Rimini, Italy
    Posts
    2

    Default Re: YaST got signal 11at clients/online_update_select.ycp:83

    Hi...
    I have downgrade qt4 at the version 4.4 via
    /sbin/yast in the administrator mode.
    Now Yast2 is working.

    Still remains some problems with the KDE desktop and plasmoid, but I don't know if they are connected with qt.

    Thanks for the help

  7. #7
    michael1maass NNTP User

    Default Re: YaST got signal 11at clients/online_update_select.ycp:83

    Quote Originally Posted by kikko_r View Post
    Same trouble...
    And now same question: how to downgrade qt4libs without Yast?
    Thanks
    Hi there,

    Obviously the same Problem since I let my Yast update itself and some other stuff..... sh...

    ...start a console, su to root, type "yast" and see a lovely oldfashioned "Textgui" like the real thing.

    the key to choose Versions is Alt-A (german version) for Anzeigen. In English it might be View (Alt-V ?)

    I rolled back to 4.3 of qt-x11 package and write these before I restart.... whish me luck.

    regards

    Michael(Mickey)Maass

  8. #8

    Default Re: YaST got signal 11at clients/online_update_select.ycp:83

    Could qt4 please be fixed? If I upgrade to it the yast2 no longer works. If I attempt to downgrade then LOTS of other utilities fail to work (KDE applications and lots more). But most of these I am unable to downgrade. I now have a failed dependency list in yast2 of over 900 packages.

  9. #9

    Default Re: YaST got signal 11at clients/online_update_select.ycp:83

    Dears,

    i have the same problem. here is my xmessage:

    Code:
    YaST got signal 11 at YCP file /usr/share/YaST2/clients/inst_packages.ycp:36
    /sbin/yast2: line 421:  4771 Segmentation fault      $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    my libqt4 version is 4.5.1 from Qt repositories from openSUSE. i am on a openSUSE 11.0 with kde 4.2.2

    any idea??

  10. #10

    Default Re: YaST got signal 11at clients/online_update_select.ycp:83

    I believe it is related to this bug :- https://bugzilla.novell.com/show_bug.cgi?id=468734

    Now a fix was released and updated in the BS under the devel:/updatestatck/Opensuse_11.0 section. The package to be updated is yast2-qt-pkg-2.16.49-1.1.i586.rpm. Apparently, this repo is now completely empty and the fix was not propagated into the Updates repo. Thankfully, one of the BS mirrors has the repo cache...and it can be downloaded from this link:-

    http://mirror.in.th/osarchive/opensu...9-1.1.i586.rpm

    I've had this problem several times in 11.0 and installing this always did the trick. You do not need to mess around with the Qt repo...it should work fine.

    -Anshul

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •