Results 1 to 10 of 10

Thread: Nautilus Scripts Not working

  1. #1

    Default Nautilus Scripts Not working

    Well, the title says it all. None of my scripts are working. Sometimes I get as far as entering my password but that's it.

  2. #2
    ab@novell.com NNTP User

    Default Re: Nautilus Scripts Not working

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    The title doesn't say that much. Errors when you try? Script contents?
    Did they ever work? Do they work on other systems? Do they work as
    other users? Do they run when executed from the command line? What
    language are they written in? Which version of (presumably) opensuse
    are you using and on which architecture? Are the scripts in a 'noexec'
    partition? Are they marked executable? Do they have the proper shebang
    line at the top (e.g. #!/bin/bash)?

    Good luck.





    NewDisciple wrote:
    > *Well, the title says it all. None of my scripts are working.
    > Sometimes I get as far as entering my password but that's it.*
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFJls7H3s42bA80+9kRAoC5AKCLIdnA8KzZoVxmEzdmm5qdXgT5IACfaE9r
    if5usnCw2VOpDAQFnUVL2/g=
    =PAuG
    -----END PGP SIGNATURE-----

  3. #3

    Default Re: Nautilus Scripts Not working

    My scripts are from gscripts: Nautilus File Manager Scripts: Welcome to G-Scriptsand gnome-look.org. And yes they all have worked on other platforms.
    I am attempting to use them on OpenSuse 11.1 Gnome version. All of the scripts are executable.
    There are no errors that I have been able to find. After entering my password the box disappears and thats it.

  4. #4
    ab@novell.com NNTP User

    Default Re: Nautilus Scripts Not working

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Looks like they just may have outdated instructions. Maybe try
    extracting them to ~/.gnome2 instead of ~/.gnome to see if that helps.

    Good luck.





    NewDisciple wrote:
    > My scripts are from gscripts: 'Nautilus File Manager Scripts: Welcome to
    > G-Scripts' (http://g-scripts.sourceforge.net/)and gnome-look.org. And
    > yes they all have worked on other platforms.
    > I am attempting to use them on OpenSuse 11.1 Gnome version. All of the
    > scripts are executable.
    > There are no errors that I have been able to find. After entering my
    > password the box disappears and thats it.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFJluWj3s42bA80+9kRAt5GAKCIJdMr/XBQtVMM3b2ok22pvO7d7QCgiphS
    lGpvk/c6Jb8z0EBs4nGqYc0=
    =YcCw
    -----END PGP SIGNATURE-----

  5. #5

    Default Re: Nautilus Scripts Not working

    They are in .gnome2. Many are from Eyecandy for your GNOME-Desktop - GNOME-Look.organd since I keep an eye out for new and updated ones I would think they would be outdated would they?

  6. #6

    Default Re: Nautilus Scripts Not working

    I'm not very adept at this, but I was just wondering if there would be a better chance of these working if they were converted to python as opposed to bash. Maybe one of you who does a little scripting would know.

  7. #7
    ab@novell.com NNTP User

    Default Re: Nautilus Scripts Not working

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    I would suspect you would have, at best, an equal chance since Linux is
    typically good about just running scripts that are setup properly. Run
    one of these from the command line to ensure it works. If it does then
    try Alt+F2 and see if you can get something there that way (you
    mentioned something about a password, but no details about how you
    managed to get there). Please be specific in all that you do. So far
    these scripts, when in my directory properly, seem to run just fine.

    Good luck.





    NewDisciple wrote:
    > I'm not very adept at this, but I was just wondering if there would be a
    > better chance of these working if they were converted to python as
    > opposed to bash. Maybe one of you who does a little scripting would
    > know.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFJlwBa3s42bA80+9kRArrVAJ99FFTXspLznmreN7+NYsYvdgwpsgCeMaVX
    fTOCxN3LDPrwj7bN68ZA3Ow=
    =HimA
    -----END PGP SIGNATURE-----

  8. #8

    Default Re: Nautilus Scripts Not working

    When I use the scripts I right-click, scroll to the script I want and select it. Since I mostly use those giving me root, a box opens up requesting my password. I enter my password and hit okay or authenticate, whichever. Then nothing happens.
    I'm not too bothered by the multimedia scripts as I can still do the same things from the terminal.
    The root scripts are important to me as I bounce back and forth in files and I like to easily drag and drop files. These really help when you are doing things in several places at the same time.
    Having said all of that I did try running several in the terminal but the result was exactly the same as right-clicking my mouse. Box pops up asking for a password, I enter it and nothing. Also tried Alt+F2 and didn't get anywhere with that either.
    Picture of me scratching my head.

  9. #9

    Default Re: Nautilus Scripts Not working

    I'm kinda thinking that the problem might be: no "gksu". I searched the repositories and couldn't find it. The reason I've reached this conclusion is because the non-root scripts do work I just hadn't checked those prior to this. I looked at one of my scripts and it used "gksu". I downloaded a "gksu-2.0.0tar.gz" file but I don't know if that's the right one or not. I also may look for a rpm. If you know something here that I might need to know, please tell me.
    From what I gathered in researching this is that, this pkg was in previous repositories, but now it's not.??? Correct me if I'm wrong about this. I even installed the gnome repositories with no luck.

  10. #10

    Thumbs up Re: Nautilus Scripts Not working SOLVED

    After numerous mis-steps and restarts I finally got this going. Running "su" in the terminal just wouldn't work and since I've really been sick while trying to all of this. My mind was functioning properly so I decided to upgrade applications for a while. I noticed that one of them was "libgnomesu", so after installing it I went back to the terminal and ran "gnomesu, then "nautilus" and that gave me root.
    I still get an error:
    linux-vqit:/home/rick # nautilus
    Initializing nautilus-open-terminal extension
    Initializing nautilus-share extension
    Initializing nautilus-dice extension
    Nautilus-Share-Message: REFRESHING SHARES
    Nautilus-Share-Message: ------------------------------------------
    Nautilus-Share-Message: spawn arg "net"
    Nautilus-Share-Message: spawn arg "usershare"
    Nautilus-Share-Message: spawn arg "info"
    Nautilus-Share-Message: end of spawn args; SPAWNING

    Nautilus-Share-Message: returned from spawn: SUCCESS:
    Nautilus-Share-Message: exit code 255
    Nautilus-Share-Message: ------------------------------------------
    Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: usershares are currently disabled


    ** (nautilus:5194): WARNING **: Unable to add monitor: Operation not supported

    ** (nautilus:5194): WARNING **: Unable to add monitor: Operation not supported
    Nautilus-Share-Message: REFRESHING SHARES
    Nautilus-Share-Message: ------------------------------------------
    Nautilus-Share-Message: spawn arg "net"
    Nautilus-Share-Message: spawn arg "usershare"
    Nautilus-Share-Message: spawn arg "info"
    Nautilus-Share-Message: end of spawn args; SPAWNING

    Nautilus-Share-Message: returned from spawn: SUCCESS:
    Nautilus-Share-Message: exit code 255
    Nautilus-Share-Message: ------------------------------------------
    Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: usershares are currently disabled

    Nautilus-Share-Message: REFRESHING SHARES
    Nautilus-Share-Message: ------------------------------------------
    Nautilus-Share-Message: spawn arg "net"
    Nautilus-Share-Message: spawn arg "usershare"
    Nautilus-Share-Message: spawn arg "info"
    Nautilus-Share-Message: end of spawn args; SPAWNING

    Nautilus-Share-Message: returned from spawn: SUCCESS:
    Nautilus-Share-Message: exit code 255
    Nautilus-Share-Message: ------------------------------------------
    Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: usershares are currently disabled

    I'll get this figured out in a little bit. At least I can get root when and where I want. When I get to feeling better I'll redo my nautilus scripts so that they point in the right direction.
    Thanks to all who helped, I really appreciate it.
    P.S. I was kinda confused over gconfig when I visited the URL's from the previous error messages. How do I mark this as solved?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •