Results 1 to 4 of 4

Thread: 11.1 - Fujitsu Stylistic ST4120 - Video Issues

  1. #1
    macbeck22 NNTP User

    Default 11.1 - Fujitsu Stylistic ST4120 - Video Issues

    I have been trying to get a working Linux installation on this tablet for a few days. I started with Ubuntu (tried numerous versions) and actually had very similar problems as described below. After reading about open suse and tablet support I decided to give it a shot.

    This is the Fujitsu website that describes the technical specs of this ST4120 tablet.

    Fujitsu Computer Systems Tablets

    The suse installation went very well and I had no problems at all when installing 11.1. When I first try to boot the splash screen comes up and loads. However, X will not start and I am kicked back to the shell after some waiting. When I type "startx" I will get the error "screens found but none have a useable configuration". It looksl ike this tablet is using intel i830m. I tried messing around with sax2 and using 0=vesa, X the screen comes up to a black screen with vertical white bars. At this point I hit CTRL - ALT F2 to switch back and for a split second I can see the X interface.

    Does anyone have any suggestions or ideas on how to resolve this? I have been searching the internet for days and haven't found anything.

    I appreciate any assistance!

  2. #2

    Default Re: 11.1 - Fujitsu Stylistic ST4120 - Video Issues

    Try to see if there's an xorg update that's fixed for your graphics chipset, or try and older version like 11.0. There were a lot of changes to the intel graphics code, so 11.1 install CD/DVD didn't have the best support for all the chipsets.

  3. #3
    macbeck22 NNTP User

    Default Re: 11.1 - Fujitsu Stylistic ST4120 - Video Issues

    I actually used the network installer for suse. Wouldn't the repositories contain the most up to date software?

    I also just ran zypper update which didn't help either.

  4. #4
    scherfler NNTP User

    Default Re: 11.1 - Fujitsu Stylistic ST4120 - Video Issues

    I have 11.0 installed on my ST4120P. It works fine as long as I don't try to activate the touchscreen through SaX. Then I Have the same problem as you discribed. You should check your xorg.conf file if the touchscreen is set up there. It is one of the input-devices. You have to delete it or change the driver to fpit.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •