Results 1 to 6 of 6

Thread: Can't copy files with non-standard characters

  1. #1

    Default Can't copy files with non-standard characters

    Hi,
    This issue was supposed to have been fixed according to some threads I have found but I'm still seeing it. Basically files/folders that have non standrad characters (I find it a lot with international itunes music) show up with a question mark. this happens on the cmdline and with dolphin/konq.

    (eg) /media/Storage/steve/VHD/Ma�

    I'm pretty sure I have all the packages that have anything to do with unicode etc etc, but if someone knows exactly which ones and can make a list I can double check...but I think it might actually be a bug.

    Thanks

    I forgot to mention that I use this at work a lot to back peoples hdd's up before reinstalling their windows and then put their data back....the big issue is that dolphin complains it can't find it and then stops copying...which means if there is 50 gig worth of stuff that I have left I have to come back, deselect the folder and start the process again...a bit of a PITA
    Last edited by solphonic; 11-Feb-2009 at 15:54. Reason: forgot to add something

  2. #2

    Default Re: Can't copy files with non-standard characters

    Have you tried using rsync as a workaround?

  3. #3

    Default Re: Can't copy files with non-standard characters

    nope, I'd heard of it being used to copy files...but I am mostly familiar with it in gentoo portage...also how does it get around the issue?

    Thanks for the quick reply by the way.

  4. #4

    Default Re: Can't copy files with non-standard characters

    Ah, I failed to realize your work use scenario implies connecting to a remote win machine (via Samba, I'm guessing?). I suggested it because in my experience, rsync doesn't really care about stuff like that (I could be wrong, though). But in your case, setting this up to work would be very annoying.

  5. #5

    Default Re: Can't copy files with non-standard characters

    no i don't hook up remotely via samba....I just pull their hdd's out and connect it via a ide/sata to usb/esata adaptor, copy the files across, put it back in their computer to install windows and then pop it back on to copy the data back. The reason I don't just use a portable hdd is (if you were wondering) is a lot of the time their systems won't boot, or are so **** riddled with viruses it's not worth the pain and effort! =)

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Can't copy files with non-standard characters

    Could it be those filesystems are, say latin-1 charset for filename encoding, and you are mounting them in utf8 or something like that?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •