Results 1 to 7 of 7

Thread: openSUSE boot doesn't show splash

  1. #1

    Default openSUSE boot doesn't show splash

    Before you ask, yes splash=silent is added as a boot option.

    Instead, I get very slowly scrolling text making the notebook boot ridiculously slow.

    I recognize that the code is the SUSE startup code...but I don't understand why it shows. I have 3D acceleration on my vid card (Nvidia 8200M G). It's also not the SUSE branded verbose either, just small white text that scrolls like the desktop did before I installed Nvidia drivers.

    Ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,445

    Default Re: openSUSE boot doesn't show splash

    >
    > Before you ask, yes splash=silent is added as a boot option.


    This turns off the bootsplash (Green screen with scrolling status bar)

    > Instead, I get very slowly scrolling text making the notebook boot
    > ridiculously slow.


    This is what you get by default when the splash is disabled using
    splash=silent. The scrolling text is not making your system slow, you are
    watching the boot process which occurs regardless of whether you see it or
    not.


  3. #3

    Default Re: openSUSE boot doesn't show splash

    I guess the documentation I was looking at was wrong.

    Thanks for clearing it up.

  4. #4

    Default Re: openSUSE boot doesn't show splash

    Bump'd


    It seems modifying the splash screen parameters (splash=verbose) didn't bring it back. I'm still stuck with it.

    I'm not sure what's wrong now.

  5. #5

    Default Re: openSUSE boot doesn't show splash

    Quote Originally Posted by JerichoKru View Post
    Bump'd


    It seems modifying the splash screen parameters (splash=verbose) didn't bring it back. I'm still stuck with it.

    I'm not sure what's wrong now.
    Did you try

    splash=silent vga=0x317

  6. #6

    Default Re: openSUSE boot doesn't show splash

    Quote Originally Posted by plasmonics View Post
    Did you try

    splash=silent vga=0x317
    has no effect

  7. #7
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: openSUSE boot doesn't show splash

    Try adding this to the Boot Options:

    Code:
    edd=off
    Also, make sure that the vga=xxxxx is using a vesa framebuffer resolution that your video device supports. You can usually see that by doing (as root):

    Code:
    hwinfo --framebuffer
    But note that the EDID reported to the video device bios is not always correct.

    Also, this has nothing whatsoever to do with X server driver - at boot X has not yet started, the driver is not engaged. What is being used is "vesafb", which is cooked into the kernel.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •