Results 1 to 6 of 6

Thread: Compiling rkward with cmake : AUTOMOC error

  1. #1

    Default Compiling rkward with cmake : AUTOMOC error

    I am running OpenSUSE 11.1 on my thinkpad T61 with a KDE4 desktop.

    I installed R-2.8.1 from the repositories, but needed a GUI for it. I had installed rkward earlier on Ubuntu, so I decided to download the rkward 0.5.0 source from the rkward project page.

    I get the following error when I try to compile it with cmake :
    Code:
    CMake Error at dataeditor/CMakeLists.txt:19 (QT4_AUTOMOC):
      Unknown CMake command "QT4_AUTOMOC".
    
    
    -- Configuring incomplete, errors occurred!
    I have the qt4 headers installed and I do have the QT4_AUTOMOC macro in the /usr folder. I am pointing cmake to the correct folder with the source files including CMakeLists.txt. Also, rkward 0.5.0 is the only version which supports KDE4, so I dont really have a choice on it, plus, it was a very neat GUI, so it would be great if I could get it running.

    Ideas anyone?

  2. #2

    Default Re: Compiling rkward with cmake : AUTOMOC error

    <bump>
    Anyone?

  3. #3

    Default Re: Compiling rkward with cmake : AUTOMOC error

    Make sure you have libqt4-devel installed as well as both thje base R package and the Development R package. Also libkde4-devl and libkdecore4-devel.

  4. #4

    Default Re: Compiling rkward with cmake : AUTOMOC error

    Yup, I have all those installed. Still no luck.

  5. #5

    Default Re: Compiling rkward with cmake : AUTOMOC error

    I get the same exact error even though I have what I believe to be the necessary libraries and dependencies. Moreover, I looked in the datafiles directory and there is no CMakeLists.txt file there. The CMakesList.txt file in the rkward-0.5.0d directory does not contain the QT4-AUTOMOC command.

  6. #6
    roglon NNTP User

    Default Re: Compiling rkward with cmake : AUTOMOC error

    Hi,

    if somebody is still interested:

    I managed to compile rkward-0.5.0d with openSUSE 11.1 and KDE 4.2.96. Maybe this version of KDE4 is the reason why it worked for me out of the box?

    I upgraded my KDE4 according to So installieren Sie KDE 4.2 / Online-Artikel / Artikel / Internal / Home - LinuxCommunity and simply did cmake, make, make install in rkward folder and it seems to work fine.

    Greetings
    Roglon

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •