Results 1 to 4 of 4

Thread: python-setuptools broken in 11.1 x86-64?

  1. #1
    ryansturmer NNTP User

    Default python-setuptools broken in 11.1 x86-64?

    After installing setuptools and attempting to use easy_install to install a library, I get this error:

    /usr/lib64/python2.6/site-packages/setuptools/ DeprecationWarning: the md5 module is deprecated; use hashlib instead
    from md5 import md5
    error: can't create or remove files in install directory

    The following error occurred while trying to add or remove files in the
    installation directory:

    [Errno 2] No such file or directory: '/usr/local/lib64/python2.6/site-packages/test-easy-install-25679.pth'

    The installation directory you specified (via --install-dir, --prefix, or
    the distutils default setting) was:


    This directory does not currently exist. Please create it and try again, or
    choose a different installation directory (using the -d or --install-dir
    I can create symbolic links in /usr/local to just /usr, (which shouldnt' be necessary, but if I do that, I get an equally catastrophic, even more difficult to explain error as easy_install does its path processing.

    I'm using python 2.6 (which seemed to be what came on my install)

    Should I switch versions? What gives?



  2. #2
    nande NNTP User

    Default Re: python-setuptools broken in 11.1 x86-64?

    same here, i need it to work, ... and can't get it right...
    i've also tried the symlink but i only made a recursion error.
    also tried installing with but i got a similar error.
    anyone has a clue?
    btw, i'm using 11.1 x86

  3. #3
    donspaulding NNTP User

    Default Re: python-setuptools broken in 11.1 x86-64?

    The distutils default setting points to /usr/local in 11.1:

    $ cat /usr/lib64/python/distutils/distutils.cfg 
    This can be fixed by simply creating the directory as root:

    sudo mkdir -p /usr/local/lib64/python2.6/site-packages
    which worked for me.

  4. #4

    Default Re: python-setuptools broken in 11.1 x86-64?

    Thank you so much, this works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts