Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: KDE4.2 broken icons on panel

  1. #1

    Default KDE4.2 broken icons on panel

    Every time I reboot, or log in, KDE adds 11 broken icons to my panel. It leaves the proper icons alone, it just add 11 broken ones.

    I have read a great deal about similar behavior in other posts and tried many of the solutions (which seem to involve eliminating all or part of .kde4) with no luck. My plasmoids are otherwise fine, and nothing is duplicated or in the wrong place -- I just get these 11 broken icons.

    That and Konsole continually forgets my settings.

    But most important are the 11 icons. Anyone else experiencing this and/or have some kind of solution?

  2. #2
    gekkorama NNTP User

    Default Re: KDE4.2 broken icons on panel

    Quote Originally Posted by merovian View Post
    That and Konsole continually forgets my settings.
    Don't know how to solve the other problems but I've had the same problem with Konsole.

    I've created a new profile in Konsole, set the desired parameters and set the created profile as default.

    And by the way, here is a similar problem discussed in the mailinglist: [opensuse-kde] updated to KDE: 4.2.00 (KDE 4.2.0) "release 88.2" : all i

  3. #3

    Default Re: KDE4.2 broken icons on panel

    Thanks on the Konsole fix!

    Also, thanks for pointing me at the mailing list. I hadn't checked through thoroughly enough I guess.

    Still, if someone here has a solution on these miserable 11 icons that come back every time I log in -- even after deleting them in my previous session -- it would be fantastic.

  4. #4
    Join Date
    Feb 2009
    Location
    Canada
    Posts
    8

    Default Re: KDE4.2 broken icons on panel

    I have 2 dead (er, undead?) icons in KDE4.2. Mine are what's left of the Dolphin and Konqueror launchers from KDE4.13. I've also tried several ways to get rid of them. I succeeded once but then made ghosts out of the good ones I had. There must be someone around who knows how to identify them in the -rc files so they can be lifted out and dispensed with.
    noobus in perpetuum

  5. #5
    Join Date
    Jun 2008
    Location
    France
    Posts
    41

    Default Re: KDE4.2 broken icons on panel

    Should be some orphan lines in ~/.kde4/share/config/plasma-appletsrc and plasmarc like

    [Applets][1][Applets][38][Configuration]
    Url=
    OpenSuse 11.1 - KDE 4.2.0 "release 100" - 2.6.27.7-9-default - Intel Pentium 4 3 GHz - Asus P4P800 SE - 1Go DDR SDRAM - ATI Radeon 9600 SERIES - Creative EMU10K1SB Live Audio Processor - 802.11g PCI Wireless Network Adapter - Samsung Syncmaster 931BW

  6. #6
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: KDE4.2 broken icons on panel

    Quote Originally Posted by merovian View Post

    Still, if someone here has a solution on these miserable 11 icons that come back every time I log in -- even after deleting them in my previous session -- it would be fantastic.
    You can try this:

    When your desktop is the way you want it with no extra icons, open a terminal as normal user and type:

    kquitapp plasma; plasma

    This should restart plasma with no changes but the configuration should be written correctly. Log out/log in and see if it worked.

  7. #7
    Join Date
    Feb 2009
    Location
    Canada
    Posts
    8

    Default Re: KDE4.2 broken icons on panel

    I figured it out. The dead icons are referenced in ~/.kde4/share/config/plasma-appletsrc but are not used by ~/.kde4/share/config/plasmarc.

    To kill the dead icons, simply delete all the stanzas in the plasma-appletsrc file that aren't used in plasmarc. There are two stanzas for each icon, for example

    Code:
    [Containments][3][Applets][7]
    geometry=96,7,28,28
    immutability=1
    plugin=icon
    zvalue=0
    
    [Containments][3][Applets][7][Configuration]
    Url=file:///usr/share/applications kde4/konqbrowser.desktop
    Delete both of these stanzas. The applet number in this example is "7" so in this case there should be no applet 7 mentioned in plasmarc, otherwise you would keep it. (Hope I explained that well enough. Make sure you back up any file you edit, though.)
    noobus in perpetuum

  8. #8

    Thumbs up Re: KDE4.2 broken icons on panel

    eerok -- You got it!

    Totally fixed the problem. By removing -both- the orphan URL [Configuration] references and the parent [Containments][x][Applets][x] from plasma-appletrc, I no longer have those confounded dead icons!

    Thanks so much for your help everyone!

  9. #9

    Default Re: KDE4.2 broken icons on panel

    the answer is as stated, extra entries in the plasma-appletrc file. I did it another way, removing all the icons that were orphaned, setting the desktop up the way i wanted, then renamed the plasma-appletrc file and logged out. I expected to find no plasmoids and a blank desktop from a rebuilt default plasma-appletsrc. I was pleasantly surprised that the logout had saved the desktop to new "rc" files and i had just what i wanted and no orphaned icons.

    hope this helps and works for you.

  10. #10

    Default Re: KDE4.2 broken icons on panel

    Quote Originally Posted by j_xavier View Post
    the answer is as stated, extra entries in the plasma-appletrc file. I did it another way, removing all the icons that were orphaned, setting the desktop up the way i wanted, then renamed the plasma-appletrc file and logged out. I expected to find no plasmoids and a blank desktop from a rebuilt default plasma-appletsrc. I was pleasantly surprised that the logout had saved the desktop to new "rc" files and i had just what i wanted and no orphaned icons.
    hope this helps and works for you.
    Yes, that solution worked!Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •