With the latest update on KDE 4.2(90.1)came an annoying auto logout that would engage after about 15 minutes or so prompting me to log back in. I have a desktop & hence don't really need to save on batteries & personally I prefer to leave my pc running.
The way to change this is to:
1.Go to Kmenu>Configure Desktop
2.Click the advanced tab
3.Click Power Management
4.Under General Settings look for When AC Adaptor is plugged in the drop menu set it to Presentation,done!