Results 1 to 2 of 2

Thread: kdevelop don't work fine...

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    436

    Default kdevelop don't work fine...

    hi

    i use kde 4.2 and tried kdevelop.... it don't start

    Code:
    Application : KDevelop (kdevelop), signal SIGSEGV
    [?1034h[Thread debugging using libthread_db enabled]
    0x00007f4040ab2ce1 in nanosleep () from /lib64/libc.so.6
    [Current thread is 1 (Thread 0x7f404559d750 (LWP 29203))]
    
    Thread 2 (Thread 0x7f402dbb5950 (LWP 29204)):
    #0  0x00007f4042255fdd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
    #1  0x00007f40424c6f07 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
    #2  0x00007f403f6e91b8 in KDevelop::DUChainPrivate::CleanupThread::run() () from /usr/lib64/libkdevplatformlanguage.so.1
    #3  0x00007f40424c5f72 in ?? () from /usr/lib64/libQtCore.so.4
    #4  0x00007f4042252070 in start_thread () from /lib64/libpthread.so.0
    #5  0x00007f4040ae410d in clone () from /lib64/libc.so.6
    #6  0x0000000000000000 in ?? ()
    
    Thread 1 (Thread 0x7f404559d750 (LWP 29203)):
    [KCrash Handler]
    #5  0x00007f4044b374d0 in typeinfo name for CompletionSettings () from /usr/lib64/libkdevplatformshell.so.1
    #6  0x00007f402c99fe57 in regenerateColors () at /usr/src/debug/kdevelop-3.9.91/plugins/languages/cpp/cpphighlighting.cpp:141
    #7  0x00007f402c98dad1 in CppLanguageSupport (this=0xbcd110, parent=<value optimized out>) at /usr/src/debug/kdevelop-3.9.91/plugins/languages/cpp/cpplanguagesupport.cpp:159
    #8  0x00007f402c98f897 in KPluginFactory::createInstance<CppLanguageSupport, QObject> (parentWidget=<value optimized out>, parent=<value optimized out>, args=@0x7fff4d5d8e60)
        at /usr/include/kpluginfactory.h:461
    #9  0x00007f4045138c5d in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib64/libkdecore.so.5
    #10 0x00007f4044aff7f2 in KDevelop::IPlugin* KServiceTypeTrader::createInstanceFromQuery<KDevelop::IPlugin>(QString const&, QWidget*, QObject*, QString const&, QList<QVariant> const&, QString*) ()
       from /usr/lib64/libkdevplatformshell.so.1
    #11 0x00007f4044afb33b in KDevelop::PluginController::loadPluginInternal(QString const&) () from /usr/lib64/libkdevplatformshell.so.1
    #12 0x00007f4044afbe5d in KDevelop::PluginController::allPluginsForExtension(QString const&, QStringList const&) () from /usr/lib64/libkdevplatformshell.so.1
    #13 0x00007f4044b2a323 in KDevelop::SourceFormatterController::languageSupportForMimeType(QString const&) () from /usr/lib64/libkdevplatformshell.so.1
    #14 0x00007f4044b2ac1b in KDevelop::SourceFormatterController::languageNameFromLanguageSupport(QString const&) () from /usr/lib64/libkdevplatformshell.so.1
    #15 0x00007f4044b2b080 in KDevelop::SourceFormatterController::loadPlugins() () from /usr/lib64/libkdevplatformshell.so.1
    #16 0x00007f4044b2b34f in KDevelop::SourceFormatterController::initialize() () from /usr/lib64/libkdevplatformshell.so.1
    #17 0x00007f4044b00417 in KDevelop::CorePrivate::initialize(KDevelop::Core::Setup) () from /usr/lib64/libkdevplatformshell.so.1
    #18 0x0000000000407376 in main (argc=1, argv=0x7fff4d5da538) at /usr/src/debug/kdevelop-3.9.91/src/main.cpp:129
    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    436

    Default Re: kdevelop don't work fine...

    i updated to a new release of kdevplatform... that work fine...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •