Results 1 to 9 of 9

Thread: GNOME Keyring Bug? Need workaround. Default Keyring Setup

  1. #1
    Join Date
    Jan 2009
    Location
    Lancaster, PA, USA
    Posts
    6

    Question GNOME Keyring Bug? Need workaround. Default Keyring Setup

    Hello Experienced Gnome Penguinos-

    I have never configured any keyrings. I set up Evolution, and it's working, but sometimes Gnome wants me to allow it to access the default keyring to get the email password. It takes 3 cancel-deny tries to finally dismiss this dialog box, after which Evolution is working fine.

    I see that this is NOT an Evolution thing. Other users report the same thing in VINO, and on wireless access. The GNOME.org forum seems to think there is a bug when accessing severs, and has a bug and milestone. Some other distros have the same problem.

    ONE user says that they were able to DELETE the default keyring (which must have had an unknown default password) and then create a NEW default keyring with thier own password. This seems to have solved that user's problem. HOWEVER there were no instructions on how to do it.

    I think someone else was able to just stop the default keyring daemon. That would work too, although it's not as elegant. I'm now unable to find instructions.

    I'm somewhat of a newbie. Certainly to openSUSE, although I used Ubuntu casually for a while. And years ago A/UX, but that experience hardly applies. So please walk me through this step by step.

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,079
    Blog Entries
    15

    Default Re: GNOME Keyring Bug? Need workaround. Default Keyring Setup

    Quote Originally Posted by GoManVanGogh
    Hello Experienced Gnome Penguinos-

    I have never configured any keyrings. I set up Evolution, and it's
    working, but sometimes Gnome wants me to allow it to access the default
    keyring to get the email password. It takes 3 cancel-deny tries to
    finally dismiss this dialog box, after which Evolution is working fine.

    I see that this is NOT an Evolution thing. Other users report the same
    thing in VINO, and on wireless access. The GNOME.org forum seems to
    think there is a bug when accessing severs, and has a bug and milestone.
    Some other distros have the same problem.

    ONE user says that they were able to DELETE the default keyring (which
    must have had an unknown default password) and then create a NEW default
    keyring with thier own password. This seems to have solved that user's
    problem. HOWEVER there were no instructions on how to do it.

    I think someone else was able to just stop the default keyring daemon.
    That would work too, although it's not as elegant. I'm now unable to
    find instructions.

    I'm somewhat of a newbie. Certainly to openSUSE, although I used Ubuntu
    casually for a while. And years ago A/UX, but that experience hardly
    applies. So please walk me through this step by step.

    Thanks!
    Hi
    The default keyring lives down in ~/.gnome2/keyrings
    ~/ is your home directory and don't forget the period before the gnome2

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 1 day 13:01, 2 users, load average: 0.19, 0.19, 0.18
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27


  3. #3
    Join Date
    Jan 2009
    Location
    Lancaster, PA, USA
    Posts
    6

    Default Re: GNOME Keyring Bug? Need workaround. Default Keyring Setu

    Ok, I see the file. It's apparently not a text file - at any rate I couldn't open it to inspect it with gedit.

    What do you suggest I do with it to stop the unwanted behavior? I've been planning on making some changes to this box, but want to get the bad password behavior resolved before I go further.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,079
    Blog Entries
    15

    Default Re: GNOME Keyring Bug? Need workaround. Default Keyring Setup

    Quote Originally Posted by GoManVanGogh
    Ok, I see the file. It's apparently not a text file - at any rate I
    couldn't open it to inspect it with gedit.

    What do you suggest I do with it to stop the unwanted behavior? I've
    been planning on making some changes to this box, but want to get the
    bad password behavior resolved before I go further.
    Hi
    If you delete it, then the next time you login, if it pops up there
    should be a checkbox to ignore it in the future?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 0:16, 1 user, load average: 0.01, 0.09, 0.20
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27


  5. #5

    Default Re: GNOME Keyring Bug? Need workaround. Default Keyring Setu

    Hi,
    having the same strange behaviour and found no solution
    Please do not give up on this, more people may
    suffer like us.

    Will watch for what is going on.

    Thanks and good luck for all of us
    caraSUSE

  6. #6
    Join Date
    Jan 2009
    Location
    Lancaster, PA, USA
    Posts
    6

    Thumbs up Re: GNOME Keyring Bug? Need workaround. Default Keyring Setu

    Thanks! The ignore did not come up, but an option to create a default keyring WITH A NEW PASSWORD did. That's an even better solution, as I now have a properly working keyring.

    Sorry it took so long to get back to you, but I've been deep in work and have not had time to poke around the openSUSE box.

    I appreciate your help.

  7. #7
    Join Date
    Oct 2009
    Location
    follow the photons from that red dot on your chest to its source.
    Posts
    55

    Default Re: GNOME Keyring Bug? Need workaround. Default Keyring Setu

    There are 2 files in that folder. default and default.keyring.

    Which do you delete?

  8. #8
    Join Date
    Oct 2009
    Location
    follow the photons from that red dot on your chest to its source.
    Posts
    55

    Default Re: GNOME Keyring Bug? Need workaround. Default Keyring Setu

    Online help seems to work faster.

    ubuntu forums also seem to be more helpful.

    it's suggested that you back up the default.keyring and then delete default.keyring

    It will either give you a don't show again checkbox or you can put in a new password. if its the same as your root, then it wont ask again.

  9. #9

    Default Re: GNOME Keyring Bug? Need workaround. Default Keyring Setup

    I deleted the ~/.gnome/keyring/default.keyring and when prompted for a new password I made it blank. Then I could properly use VNC.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •