Results 1 to 2 of 2

Thread: IceWM: False desktop size - uses only part of the screen

  1. #1
    Anton_G NNTP User

    Default IceWM: False desktop size - uses only part of the screen

    Hi!

    I have OpenSUSE 11.0 installed on Asus Z99le notebook with KDE3.5.9-65.2 as my working environment.

    Right now I'm trying to set up an account using IceWM, and have some troubles with it.

    Native screen resolution for my laptop is 1280x800. When X starts, it sets normal resolution, but iceWM for some reason uses only 1024x768 in the top left corner of it. It looks quite odd: the whole screen area is actually usable, but iceWM toolbar is not at the bottom of the screen, but floating a little higher, and maximized windows leaving a free space at the bottom and right edges of the screen.

    Here is what I have done:
    1. Installed latest available icewm, icewm-default and iceWMCP using YaST2
    2. Created new user account named "al"
    3.
    Code:
    cp /home/al/.xinitrc.template /home/al/.xinitrc
    4. in the .xinitrc substituted the line
    Code:
    exec $WINDOWMANAGER
    with
    Code:
    exec icewm-session
    at this point when iceWM starts, it looks like I have described.

    5. I have compiled iceWM 1.2.37 from sources, but it changed nothing.


    I have tried to find something similar with google, but either I have used wrong keywords, or it's not the common problem.

    I have no idea what is the reason for this behavior. Any help is appreciated.

  2. #2
    Anton_G NNTP User

    Default Re: IceWM: False desktop size - uses only part of the screen

    Ok, I have solved this one by myself.

    I have discovered, that not only IceWM was affected, but fluxbox as well (and probably others). The problem remained with both kdm and xdm. However, when I have turned off desktop manager with "init 3" and started X server using "startx", everything went fine.

    The answer is in the /etc/sysconfig. If you have similar issue just open YaST, then /etc/sysconfig editor, and change the value of DISPLAYMANAGER_RANDR_MODE_auto in the Desktop-Displaymanager section to suit the resolution of your display. You can find valid values with "gtf".

    Good Luck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •