Results 1 to 4 of 4

Thread: Can't install any software

  1. #1
    Join Date
    Feb 2009
    Location
    Saarland in Germany
    Posts
    25

    Default Can't install any software

    Hello community!

    I installed openSUSE yesterday and all works fine so far.

    I've tried installing some software using YaST2 and this worked too until this morning: Neither packages I chose in YaST itself nor the security packages found by the kupdateapplet can be installed.

    For example: Yesterday I successfully installed csmash (a game). But since I didn't like it, I removed it. If I try to install it now, I get this in YaST:

    Subprocess failed. Error: RPM fehlgeschlagen: rpmdb: page 299: illegal page type or format
    rpmdb: PANIC: Invalid argument
    error: db4 error(-30977) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) getting "Bnormal-hip01.dat" records from Basenames index
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) getting "Bnormal-racket.affine" records from Basenames index
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) getting "Bnormal-racket01.dat" records from Basenames index
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) getting "Bpeck" records from Basenames index
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) getting "Bpeck-Larm.affine" records from Basenames index
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) getting "Bpeck-Larm01.dat" records from Basenames index
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) getting "Bpeck-Lelbow.affine" records from Basenames index
    rpmdb: PANIC: fatal region error detected; run recovery
    [The original message is much larger...]

    I hope this is a known problem?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Can't install any software

    open a terminal - go su then do

    sudo rpmdb --rebuilddb

    zypper ref

    zypper up

    After that try Yast
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Feb 2009
    Location
    Saarland in Germany
    Posts
    25

    Default Re: Can't install any software

    Thanks, seems to work.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Can't install any software

    Quote Originally Posted by codester View Post
    Thanks, seems to work.
    Lets hope so
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •