Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Compiz not working

Hybrid View

  1. #1

    Unhappy Compiz not working

    Hello friends...
    im new to Linux and Opensuse 11.1 is the first linux distribution i ever installed. This distro is gr8t. I really love this. Since installation, im trying to enable the *compiz* in KDE4 but failed. I have a Amd x2 3600+ and a Nvidia 9500GT graphics. I followed the guide listed in this website but no use. I installed the graphic card drivers succesfully. then followed this Compiz Fusion - openSUSE
    While trying the checklist, i always get the msg that composite is disabled no matter what i do. I dont have a net connection so i cannot use the one click install.

    i tried the instructions here and got a msg that composite is enabled.

    su -
    nvidia-xconfig --composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24

    and when i try running this as mentioned here Compiz Fusion - openSUSE
    i get msg that composite is disabled.

    grep Composite /var/log/Xorg.0.log


    Plz tell me how to enable this feature.....

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Compiz not working

    You do NOT need to install it they way have. Compiz is already installed and effects are enabled via the Config Desktop - Desktop - enable desktop effects
    all effects
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Exclamation Re: Compiz not working

    But i already did that previously and nothing is happening. Are there any shortcut keys for enbling that Cube effect? How should i trigger that? I enabled all effects and nothings happening actually.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Compiz not working

    Have you upgraded your kde to 4.2?

    Trouble is they keep moving all the settings and I'm not sure where it will be in 4.1.3
    But in all efects you need to check the cube effect

    Then look for desktop switching settings
    In 4.2 it's the opening section in Desktop effects
    there are 3 drop boxes

    window switching
    desktop switching
    animation speed
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Compiz not working

    Quote Originally Posted by caf4926 View Post
    Have you upgraded your kde to 4.2?

    Trouble is they keep moving all the settings and I'm not sure where it will be in 4.1.3
    But in all efects you need to check the cube effect

    Then look for desktop switching settings
    In 4.2 it's the opening section in Desktop effects
    there are 3 drop boxes

    window switching
    desktop switching
    animation speed
    I thought the problem is with KDE and i reinstalled Gnome again. Now i installed the drivers succesfully. In the control center, i selected DESKTOP Effects and when checking "Enable Desktop Effects" its saying that they are not supported under my current configuration. and after enabling everything and closing, it is automatically reverting back and unchecking the enable effects tab. What should i do?

  6. #6
    adrianmeneses NNTP User

    Default Compiz dont work for me too

    i have the same problems when i enable the effects nothing happen but i suppose that something is wrong with video card geforce 7300 because in the Desktop-System Settings saids that my system dont support compositing and that i need require X extensions XComposite and XDamage . I forget to say that i install opensuse 11.
    Some help would be -----

  7. #7

    Default Re: Compiz dont work for me too

    Please let me know if u figure out a way to get this Compiz working on ur system. Bye.

  8. #8
    adrianmeneses NNTP User

    Default Re: Compiz dont working

    i found the instructions in the nvidia web site just follow them

    Nvidia Installer HOWTO for SUSE LINUX users

    use the link to get there.

    good luck

    it really works for me

  9. #9

    Default Re: Compiz dont working

    Hi adrianmeneses..I tried these proprietary drivers from Nvidia previously. Are u able to install them without installing any additional packages from the dvd?Im getting a error msg whenever i try to install them.So i selected ALL the packages from YAST and installed them. Then the drivers are installed and it compiled some kernel on its own. Everything is finished but still im getting the msg "composite extensions disabled" whenever i check it. Also, the "Enable desktop effects" is reverting back to its previous state.. May be u used the "one click install" feature. That solves all the problems but im unable connect to internet via openSuse though i have a working connection in XP. Thanks for the suggestion.
    I will try reinstalling the OS again and will follow the instruction u provided.You gave me some hope. i will post u after trying once again. Bye.

  10. #10

    Default Re: Compiz not working

    Quote Originally Posted by harshavarma View Post
    But i already did that previously and nothing is happening. Are there any shortcut keys for enbling that Cube effect? How should i trigger that? I enabled all effects and nothings happening actually.
    What compositing type are you using It is under configure desktop effects-advance. Mine if I chose xrender effects works except for the cube zoom and rotate.Cube zoom and rotate works using opengl for me. I am using intel graphics right now but on another machine I have nvidia gforce7300gt that works the same as intel. Check it out it might be the missing link.
    People who do not break things first will never learn to create anything

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •