Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: OpenOffice 3 localization problem

  1. #1

    Angry OpenOffice 3 localization problem

    Hi,
    I've updated to OpenOffice 3.0.1 and now I have the following problem on startup:

    "Missing vcl resource. This indicates that files vital to localization are missing. You might have a corrupt installation."

    Installed packages are:
    rpm -qa|grep OpenOffice

    OpenOffice_org-icon-themes-3.0.1.2-4.1
    OpenOffice_org-pyuno-3.0.1.2-3.2
    OpenOffice_org-templates-presentation-layouts-3.0-2.1
    OpenOffice_org-impress-3.0.1.2-3.2
    OpenOffice_org-thesaurus-en-20060111-5.1
    OpenOffice_org-help-pt-3.0.1.2-5.1
    OpenOffice_org-calc-3.0.1.2-3.2
    OpenOffice_org-branding-upstream-3.0.1.2-3.2
    OpenOffice_org-templates-labels-letter-1.0-5.1
    OpenOffice_org-templates-en-3.0-2.1
    OpenOffice_org-openclipart-3-2.6
    OpenOffice_org-filters-3.0.1.2-3.2
    OpenOffice_org-base-3.0.1.2-3.2
    OpenOffice_org-l10n-en-US-3.0.1.2-5.1
    OpenOffice_org-draw-3.0.1.2-3.2
    OpenOffice_org-math-3.0.1.2-3.2
    OpenOffice_org-icon-themes-prebuilt-3.0.1.2-3.2
    OpenOffice_org-thesaurus-pt-20060817-5.1
    OpenOffice_org-3.0.1.2-3.2
    OpenOffice_org-mailmerge-3.0.1.2-3.2
    OpenOffice_org-help-en-US-3.0.1.2-5.1
    OpenOffice_org-Quickstarter-1.0-712.1
    OpenOffice_org-writer-3.0.1.2-3.2
    OpenOffice_org-templates-labels-a4-1.0-5.1
    OpenOffice_org-hyphen-20080929-38.1
    OpenOffice_org-kde-3.0.1.2-3.2

    I've even deleted ~/.ooo3 and tried a fresh startup.

    Any ideas?

  2. #2

    Default Re: OpenOffice 3 localization problem

    With the help of strace I found that OO is looking for a file called vclen.res which exists only on the 3.0.0 version.

    This file was installed by OpenOffice_org-libs-gui-3.0.0.10-1.6.i586 RPM


    I'm attaching the strace output with relevant messages.

    Any help on how to solve this?


    31141 writev(5, [{"8\2\4\0\2\0\0\6\4\0\0\0\350\2370C\0\5\0\1\0\0\6\2\0\0\6\16\0\346\0\234\1\7\0008\2\4\0\2\0\0\6\4\0\0\0\233D\4\0F\0\5\0\1\0\0\6\2\0\0\6\20\0\350\0\1\0\4\0", 72}], 1) = 72
    31141 read(5, 0x8053734, 4096) = -1 EAGAIN (Resource temporarily unavailable)
    31141 read(5, 0x8053734, 4096) = -1 EAGAIN (Resource temporarily unavailable)
    31141 poll([{fd=4, events=POLLIN}], 1, 50 <unfinished ...>
    31143 <... lstat64 resumed> {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    31143 lstat64("/usr/lib/ooo3/program/bootstraprc", {st_mode=S_IFREG|0444, st_size=191, ...}) = 0
    31143 access("/usr/lib/ooo3/program/bootstraprc", F_OK) = 0
    31143 lstat64("vclen.res", 0xbf88eff4) = -1 ENOENT (No such file or directory)
    31143 open("vclen.res", O_RDONLY) = -1 ENOENT (No such file or directory)

    31143 write(2, "Missing vcl resource. This indicates that files vital to localization are missing. You might have a corrupt installation.\n", 122) = 122
    31143 access("/usr/lib/ooo3/basis3.0/share/registry/data/org/openoffice/Office", F_OK) = 0
    31143 lstat64("/usr/lib/ooo3/basis3.0/share/registry/data/org/openoffice/Office", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    31143 open("/usr/lib/ooo3/basis3.0/share/registry/modules/org/openoffice/Office/Common", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY|O_CLOEXEC) = 17
    31143 fstat64(17, {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    31143 getdents64(17, /* 10 entries */, 4096) = 376
    31143 getdents64(17, /* 0 entries */, 4096) = 0
    31143 close(17) = 0

  3. #3
    Berend_Botje NNTP User

    Default Re: OpenOffice 3 localization problem

    Hello,

    First, I'm not so familiar with OpenSuse 11.1. and Yast2

    Background:
    All files were almost daily upgraded by
    URL: Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1
    resulted in the same error you mentioned.

    Solution for me:
    1) With Yast2, I searched "OpenOffice"
    2) In the tab "Versions": I downgraded all V-files to "x.x.x.x-x.x delivered from repo-oss" to the same version delivered by "x.x.x.x-x.x from OPENSUSE_11.1".
    3) After downgrading I did again:
    Package-> All Packages-> Update if newer version is available

    At this moment my installed packages are:
    rpm -qa|grep OpenOffice
    OpenOffice_org-base-3.0.1.2-3.2
    OpenOffice_org-math-3.0.1.2-3.2
    OpenOffice_org-LanguageTool-en-0.9.3-1.43
    OpenOffice_org-templates-en-3.0-2.1
    OpenOffice_org-LanguageTool-0.9.3-1.43
    OpenOffice_org-help-nl-3.0.1.2-5.1
    OpenOffice_org-templates-presentation-layouts-3.0-2.1
    OpenOffice_org-icon-themes-3.0.1.2-4.1
    OpenOffice_org-writer-3.0.1.2-3.2
    OpenOffice_org-impress-3.0.1.2-3.2
    OpenOffice_org-help-en-US-3.0.1.2-5.1
    OpenOffice_org-filters-3.0.1.2-3.2
    OpenOffice_org-templates-labels-letter-1.0-5.1
    OpenOffice_org-Quickstarter-1.0-712.1
    OpenOffice_org-branding-openSUSE-3.0-24.16
    OpenOffice_org-converter-3.0-1.24
    OpenOffice_org-calc-3.0.1.2-3.2
    OpenOffice_org-pyuno-3.0.1.2-3.2
    OpenOffice_org-draw-3.0.1.2-3.2
    OpenOffice_org-LanguageTool-nl-0.9.3-1.43
    OpenOffice_org-templates-labels-a4-1.0-5.1
    OpenOffice_org-3.0.1.2-3.2
    OpenOffice_org-l10n-nl-3.0.1.2-5.1
    OpenOffice_org-thesaurus-en-20060111-5.1
    OpenOffice_org-l10n-en-US-3.0.1.2-5.1
    OpenOffice_org-kde-3.0.1.2-3.2
    OpenOffice_org-mailmerge-3.0.1.2-3.2
    OpenOffice_org-hyphen-20080929-38.1

    I hope this will help you

  4. #4

    Default Re: OpenOffice 3 localization problem

    Hi,
    thanks for the reply.

    I'm downgrading to 3.0.0 from the OSS repository for the moment.

    I hope someone can confirm this but I think its some kind of problem with the packaging of 3.0.1.

    I would really like to use 3.0.1 since it corrects some problems I was having with opening filenames with Latin characters from a network source....

  5. #5

    Default Re: OpenOffice 3 localization problem

    The first 3.0.1 really had broken dependencies, see the bug https://bugzilla.novell.com/show_bug.cgi?id=471280. It should be fixed now.

    The missing VCL files might be also caused by the missing compat symlinks between /usr/lib/ooo3 and /usr/share/ooo3. They are created in post install scripts of the noarch packages. It is a bit error-prone solution but it should work well if the dependencies are correct. I hope that they are correct now. I hope that we will get rid of the compat symlinks in the future.

    If is still does not work for you, please report a bug at https://bugzilla.novell.com.

    I am sorry for all the troubles.

  6. #6

    Default Re: OpenOffice 3 localization problem

    Is the version in the repo's corrected? I'm on version 3.0.1.2-3.2-i586, I still am getting the missing VCL when I go to fire up a spreadsheet. Sorry for the confusion on my part.

    O.

  7. #7

    Default Re: OpenOffice 3 localization problem

    so any solutions for this?
    It seems kind of odd because its such a common app.

  8. #8

    Question Re: OpenOffice 3 localization problem

    Openoffice 3.0.1.2-3.2.x86_64

    Missing vcl resource problem not resolved

    just (2009/03/02) did : zypper in OpenOffice_org


    This is a real show stopper.
    Hope someone can fix this soon .


    Thanks

  9. #9
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: OpenOffice 3 localization problem

    I downloaded 3.0.1.2 recently and I haven't had any problems at all - localisation and spreadsheet work like 2.4 - but a lot faster.

  10. #10

    Default Re: OpenOffice 3 localization problem

    Quote Originally Posted by TaraIkeda View Post
    so any solutions for this?
    It seems kind of odd because its such a common app.
    Did you try doing a forced reinstall of all the openoffice.org-related packages? I tried that and it fixed it for me.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •