I've installed opensuse 11.1 on my Thinkpad X301, and now
I want to rebuild glibc (or at least the dns parts of it)
to get round some of the dns/internet problems that have
been biting many people.
The only source rpm availables are glibc-2.9-2.[89].src.rpm .
However, if I build either of these, I get a seg fault on
program start up (during the dynamic link phase) if I try
to use those libraries. I'd like to know why!
I note that the glibc on my system is actually installed from
glibc-2.9-2.3.i686.rpm, not from glibc-2.9-2.8.i586.rpm .
I still don't see why two releases of the same glibc shouldn't
work with one another; and I can't find anywhere the source
rpm for glibc-2.9-2.3.
Anybody able to help?