Results 1 to 3 of 3

Thread: suse on a ssd drive

  1. #1
    linuxguru707 NNTP User

    Default suse on a ssd drive

    hello,

    i recently purchased a ocz ssd drive and i have suse 11.1 on it. it install fine but upon reboot it will say error loading operating system. i have also tried installed a previous version it and i get the same result.

    i also tried installing windows xp on the ssd drive just to test it out and it works fine so i know its not my ssd drive is bad.

    can someone please help?

    thanks

    anthony

  2. #2
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    103

    Default Re: suse on a ssd drive

    The ssd drive is in what? laptop? cardreader? more info pls. Partition setup also.
    if it aint broken...dont let me near it

  3. #3

    Default Re: suse on a ssd drive

    Those drives are 2.5" notebook SATA devices, used as an alternative to old-fangled whirring disk platters. The 'Core' appear to be rather notorious and poor performers, with a newer version 2, released and fixing problems (enough to feature in Phoronix benchmarks).

    If the OP has a hard disk, I'd probably keep /, /var, /tmp, /home on that, and try copying /usr into ext2 format partition on the SSD, mounting that and seeing if it works.

    Presumably GRUB is loading the kernel and initrd in a way that the drive doesn't support. Unfortunately a lot of consumer hardware is only tested with Windows.

    Tejun Heo the developer responding in this thread Re: Another libata error related to OCZ SSD: msg#02141 linux-kernel works for SuSE so filing a Bugzilla may be worth while. I notice that in past folk have had trouble installing Ubuntu to. See this clue to http://forum.soft32.com/linux/LibATA...ict471750.html

    Disabling the pata_ driver to avoid libata, using broken_modules=pata_xx on the installer boot line may avoid issue if it's libata specific, by using the older IDE/ATA drivers. There's a way to stop all pata modules being probed to, but I forget the option.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •