Results 1 to 8 of 8

Thread: how to installing eclipse and QT integration ?

  1. #1
    DrDigital NNTP User

    Default how to installing eclipse and QT integration ?

    Hello every one ,
    I am New to Linux and want to install my development environment on it .

    I want to install Eclipse and QT library and integration

    i followed this tutorial here


    first i downloaded Linux source
    and when i am trying to run it , doesn't work ! , i don't know why

    it also asked me to download this (CDT)

    when clicking the link , no thing happened and it asked me to but the link in the update manager ?!

    can any one help me plz ?

  2. #2
    DrDigital NNTP User

    Default Re: how to installing eclipse and QT integration ?

    Thanks Guys I have installed it now and it is running .. but i need to find the compilation headers as i got the error unresolved inclusion for any line contain header file inclusion

  3. #3

    Default Re: how to installing eclipse and QT integration ?

    I downloaded eclipse ganymede from eclipse.org. and it runs without problems for java and c++ but when i try to create a Gui application with qt it crashes..
    here is the log file
    wildnux private pastebin - collaborative debugging tool

    next time when i open the same project, it opens but when i try to open the ui file, it crashes...

    has anyone successfully used qt-integration plugin in eclipse?

  4. #4
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: how to installing eclipse and QT integration ?

    Quote Originally Posted by wildnux View Post
    I downloaded eclipse ganymede from eclipse.org. and it runs without problems for java and c++ but when i try to create a Gui application with qt it crashes..
    here is the log file
    wildnux private pastebin - collaborative debugging tool

    next time when i open the same project, it opens but when i try to open the ui file, it crashes...

    has anyone successfully used qt-integration plugin in eclipse?
    Yes, I'm used it. There is the Eclipse plugin:
    Qt Eclipse Integration Downloads — Qt – A cross-platform application and UI framework.
    Here is the reference documentation:
    Qt Jambi Reference Documentation.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  5. #5

    Default Re: how to installing eclipse and QT integration ?

    hi ram88, do you use Qt jambi only or qt-integration c++? actually, I am trying use qt-integration c++ and it installs perfectly but when I try to create any gui project, or when i try to edit any .ui files, it crashes...as you can see in the log above.

    any suggestions?

  6. #6

    Default Re: how to installing eclipse and QT integration ?

    out put from the terminal when i try to open a .ui file:

    :~/data/All/IDE/eclipse> ./eclipse
    QObject::moveToThread: Current thread (0x8f63938) is not the object's thread (0x8f39c28).
    Cannot move to target thread (0x8f39c28)

    QApplication::qAppName: Please instantiate the QApplication object first
    QObject::setParent: Cannot set parent, new parent is in a different thread
    QObject::installEventFilter(): Cannot filter events for objects in a different thread.
    QPixmap: Must construct a QApplication before a QPaintDevice
    Aborted

  7. #7
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: how to installing eclipse and QT integration ?

    Quote Originally Posted by wildnux View Post
    hi ram88, do you use Qt jambi only or qt-integration c++? actually, I am trying use qt-integration c++ and it installs perfectly but when I try to create any gui project, or when i try to edit any .ui files, it crashes...as you can see in the log above.

    any suggestions?
    I'm sorry. I missunderstood it. I've never used the C++ integration, just Jambi.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  8. #8
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: how to installing eclipse and QT integration ?

    Quote Originally Posted by wildnux View Post
    out put from the terminal when i try to open a .ui file:

    :~/data/All/IDE/eclipse> ./eclipse
    QObject::moveToThread: Current thread (0x8f63938) is not the object's thread (0x8f39c28).
    Cannot move to target thread (0x8f39c28)

    QApplication::qAppName: Please instantiate the QApplication object first
    QObject::setParent: Cannot set parent, new parent is in a different thread
    QObject::installEventFilter(): Cannot filter events for objects in a different thread.
    QPixmap: Must construct a QApplication before a QPaintDevice
    Aborted
    It looks like a programming error. Have you tried to start the traditionl "Hello world" application?
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •