Results 1 to 6 of 6

Thread: Losing keyboard shortcut 'Application Launcher' in KDE4.1

  1. #1

    Exclamation Losing keyboard shortcut 'Application Launcher' in KDE4.1

    I installed KDE4.1 last week, made keyboard shortcuts for some programs, changed the default for Application Launcher (the green lizard/start button) from Alt+F1 to Ctrl+Esc, and have lost any keyboard shortcut for Application Launcher since then. Neither reassigning it, to default or otherwise, nor changing it manually in the text file /home/<me-myself-i>/.kde4/share/config/plasma-appletsrc while in init 3 have worked.

    What I would really like is 1-key access to that menu button; it seems impossible so far, as the configuration through Personal Settings while in KDE doesn't accept Meta (the Windows key) alone as a shortcut. But lacking that, how can I get a keyboard combination to stay?

  2. #2
    Join Date
    Sep 2008
    Bangalore, India

    Default Re: Losing keyboard shortcut 'Application Launcher' in KDE4.

    I've never been able to get a keyboard shortcut for Application Launcher on KDE 4

    Found this unsolved Kubuntu bug.

  3. #3

    Default Re: Losing keyboard shortcut 'Application Launcher' in KDE4.

    Thanks, freedguy. In that bug report, some reported regaining keyboard access only after deleting /home/$USER/.kde/share/config/ folder. This would be /home/$USER/.kde4/share/config/ on Suse 11.1, I suppose. I'll logout to console and try it. I notice that several files in that folder have modify times of the time I booted/logged in to KDE4:
    -rw-r--r-- 1 <me-myself-i> users 371 2009-02-04 18:16 startupconfigkeys
    -rw------- 1 <me-myself-i> users 26605 2009-02-04 18:16 kglobalshortcutsrc
    -rw------- 1 <me-myself-i> users 2665 2009-02-04 18:17 phonondevicesrc
    -rw------- 1 <me-myself-i> users 126 2009-02-04 18:17 kupdateappletrc
    -rw------- 1 <me-myself-i> users 354 2009-02-04 18:17 plasmarc
    -rw------- 1 <me-myself-i> users 2948 2009-02-04 18:17 plasma-appletsrc
    -rw------- 1 <me-myself-i> users 1337 2009-02-04 18:20 krunnerrc
    -rw------- 1 <me-myself-i> users 39 2009-02-04 18:21 knotifyrc
    -rw------- 1 <me-myself-i> users 1243 2009-02-04 18:21 dolphinrc
    -rw------- 1 <me-myself-i> users 438 2009-02-04 18:21 systemsettingsrc
    -rw------- 1 <me-myself-i> users 73 2009-02-04 18:21 kcmdisplayrc
    -rw-r--r-- 1 <me-myself-i> users 1508 2009-02-04 18:21 gtkrc-2.0
    -rw-r--r-- 1 <me-myself-i> users 1474 2009-02-04 18:21 gtkrc
    -rw-r--r-- 1 <me-myself-i> users 5473 2009-02-04 18:22 kdeglobals
    Why would they get modified everytime KDE4 starts? And why just the application launcher, because modifications to the panel remain, and other created keyboard shortcuts work fine?

  4. #4

    Default Re: Losing keyboard shortcut 'Application Launcher' in KDE4.

    Yeah, deleting the entire config folder restored all defaults. I'm not looking forward to reconfiguring everything, only to reset it again when a keyboard shortcut goes wandering.

  5. #5

    Unhappy Re: Losing keyboard shortcut 'Application Launcher' in KDE4.

    I'm having a similar problem with application shortcuts. I look for keyboard shortcuts and found the "Keyboard Shortcuts / KDE3" app. I configured the Command Shortcuts assigned Window key combinations for some of my most used applications. It works great within the same session, but as soon as I reboot, it's gone.

    I have to go back to the Command Shortcut section, change an assignment of one application and just press APPLY to re-enable th rest of the shortcuts I customized in my last session.

    How do I load them up automatically on startup? I can't find anything other than possibly khotkeys, but that didn't help either.

  6. #6
    Join Date
    Sep 2008
    St Louis, MO USA

    Default Re: Losing keyboard shortcut 'Application Launcher' in KDE4.

    Would you mind telling us if you are using KDE 3.5 or KDE 4?

    In KDE 4.2 the keyboard shortcuts issue seems solved
    Dell Inspiron 530 - C2Q@2.4Ghz; 6GB RAM; openSUSE 11.2 x86_64; KDE 4.4.1
    Dell Inspiron 1440 - C2D@2.2Ghz; 4GB RAM; openSUSE 11.2 x86; KDE 4.4.1
    Dell Latitude D531 - AMD Turion X2 64@2.0Ghz; 2GB RAM; Linux Mint 8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts