Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Upgrade to KDE 4.2 - Widget issues

  1. #1

    Default Upgrade to KDE 4.2 - Widget issues

    Hi Guys

    I upgraded to KDE 4.2 on my 11.1 64bit system after I saw the news posting.

    Everything installed OK (removed the dependency issues) and I even upgraded my Nvidia drivers to 180.22.

    3D effects are nice and smooth now which was not the case before so thats great.

    My problem is that all my original icons are broken. So I unlocked the widgets and cleared everything out and added some new weather widgets, etc.

    When I restarted the broken icons return.

    No matter what I do with adding or removing widgets the 'profile' seems 'stuck' and I get a bunch of broken icons and widgets with strange positioning.

    Is there a way to 'clear' my widgets or desktop?

    I tried removing the plasma* files in the ~/.kde4/share/config path but that only resets my theme and background (not widgets)

    Thanks for any help, I feel like I am close to getting it all working.

  2. #2
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Re: Upgrade to KDE 4.2 - Widget issues

    Got the same problem. I've updated last night, everything went well, everything worked nice, everything looked cool... until I rebooted.

    When I logged in, all plasmoids were a big mess, even though I locked them. Then I tried everything imaginable: locked, unlocked, removed, added again, desktop view, folder view, different themes - everything. But every time I log in, they get messed up again.

    Will be really happy to find out how to fix this. Thanks.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,215
    Blog Entries
    15

    Default Re: Upgrade to KDE 4.2 - Widget issues

    Quote Originally Posted by linuxoidoz
    Got the same problem. I've updated last night, everything went well,
    everything worked nice, everything looked cool... until I rebooted.

    When I logged in, all plasmoids were a big mess, even though I locked
    them. Then I tried everything imaginable: locked, unlocked, removed,
    added again, desktop view, folder view, different themes - everything.
    But every time I log in, they get messed up again.

    Will be really happy to find out how to fix this. Thanks.
    Hi
    Caveat, I'm a Gnome user, hence I have not tried this, user nnzlbob23
    posted in the General Chit Chat forum with a link on KDE 4.2. I see
    there is a command at the end of the article for resetting the desktop,
    maybe that is what you need to do??

    'Howto install KDE 4.2 on openSUSE The Blog is
    Hot' (http://tinyurl.com/are7hp)

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 9:42, 1 user, load average: 0.16, 0.05, 0.06
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22


  4. #4

    Default Re: Upgrade to KDE 4.2 - Widget issues

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Caveat, I'm a Gnome user, hence I have not tried this, user nnzlbob23
    posted in the General Chit Chat forum with a link on KDE 4.2. I see
    there is a command at the end of the article for resetting the desktop,
    maybe that is what you need to do??

    'Howto install KDE 4.2 on openSUSE The Blog is
    Hot' (Howto install KDE 4.2 on openSUSE The Blog is Hot)

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 9:42, 1 user, load average: 0.16, 0.05, 0.06
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22
    Unfortunately it only clears the plasma config files which will only reset your theme and background (as far as I can tell).

    Give it a try but it did not work for me

  5. #5
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Re: Upgrade to KDE 4.2 - Widget issues

    No, it didn't work for me either. All plasmoids are messed up on log in.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  6. #6
    Join Date
    Oct 2008
    Location
    Chicago
    Posts
    40

    Default Re: Upgrade to KDE 4.2 - Widget issues

    I had the same issue. I fixed it by removing

    /.kde4/share/config/plasma-appletsrc

    then relogging.

  7. #7
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Re: Upgrade to KDE 4.2 - Widget issues

    No, didn't work.

    But, if I leave widgets unlocked, they stay on their places on log in, if I leave them locked they get screwed up.

    And I also noticed when I remove widgets, there's a sand clock shown in that menu thing, when I log in, it shows the widget is added (- sign) but there's no widget on the desktop and the sand clock is still there. It happens with folder view, rssnow, notes and others.

    Looks like plasma in 4.2 is f... stuffed
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  8. #8
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Upgrade to KDE 4.2 - Widget issues

    Quote Originally Posted by heinrich773 View Post
    I had the same issue. I fixed it by removing

    /.kde4/share/config/plasma-appletsrc

    then relogging.
    Here isn't. If you delete with plasma* everything what beings with plasma will be deleted.
    Try to first clear all widgets, then relog (don't need to restart). After add the icons, relog again, etc.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  9. #9
    Join Date
    Oct 2008
    Location
    El Salvador
    Posts
    11

    Default Re: Upgrade to KDE 4.2 - Widget issues

    I had the same problem, what I did was, remove my .kde folders, close session, login to a KDE 4 session, not the previous session, and the defaults appeared, there where a couple of issues so I deleted the panel and chose new panel, added the plasmoids I wanted and done. The Aya theme was a little messed up so I downloaded a new one.
    The only way to avoid giving a mile is to refuse to give the first inch.

  10. #10
    Join Date
    Oct 2008
    Location
    Chicago
    Posts
    40

    Default Re: Upgrade to KDE 4.2 - Widget issues

    I should add that I have since noticed that two widgets keep re-appearing in the task bar (Quick Access and the Application Launcher) after I delete them. This behavior all started after the 84.1 release.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •