Results 1 to 6 of 6

Thread: Compiz and GNOME in openSUSE 11.1

  1. #1

    Default Compiz and GNOME in openSUSE 11.1

    I am working on setting up a new install of openSUSE 11.1 on a Lenovo s10e with Intel GMA950 graphics. I have installed compiz and emerald, and rolled them back to the versions without the NOMAD patch, from the alternate repo.
    TI have not installed any ATI, Nvidia, or XGL packages, but the compositing seems to be working fine.

    It has been a bit of trouble getting compiz to work properly.
    For some reason Compiz and emerald seem to work fine in KDE 4, but in GNOME (which I intend to use as my default desktop environment), I can launch compiz only from a terminal with superuser privilieges, but not in the ordinary way.

    If, after booting into GNOME, I issue

    compiz-manager --replace

    from a terminal with super-user privileges, it runs fine. It also works fine if I launch simple-ccsm from a super-user terminal and activate Compiz that way. But if I run simple-ccsm from the applications menu and activate compiz, emerald does not load, windows have no decorations, and the screen completely refireshes every couple of seconds. The terminal and all the windows disappear and flicker on and off, then the screen goes black, and the X session crashes after about 30 seconds. Booting back into GNOME, I find the same problem, the screen and the panel keep flashing, and the session crashes again.

    Is there some way that I can configure gnome from an xsessions .desktop file to load compiz instead of metacity at startup? This is the method i have used with other distros in the past, but it seems not to work here.

    Help! What is going on here?
    Last edited by adpads; 27-Jan-2009 at 10:29. Reason: typo in computer model number

  2. #2

    Default Re: Compiz and GNOME in openSUSE 11.1

    No takers? I am surprised that as a new openSuSE user I have had to face this with no help. Seems like a common enough thing I'm trying to achieve.

    An update on the above: I figured out that if the compiz settings were ok when I ran compiz-manager as root, then all I had to do was copy the compiz and emerald settings files from root's home directory to my home directory. I also figured out that I didn't have fusion-icon installed. Those two things made it work.

    However, I am now booting into compiz with the fusion-icon method, This is quiet ugly and slow: after my gnome desktop appears, a few screenlets appear, blink on and off, and are eventually relegated to the compiz widgets layer when that loads. I have a strong impulse that says this is not the best way of going about this, because it takes an extra 20-30 seconds and looks terrible.
    What's equally bad, in KDE (both 3 and 4) I believe compiz is loading as the default manager, and is then loading again with fusion-icon, which is set to boot in the sessions.

    I have tried editing an xsessions file to start up compiz that way; I can get compiz to load, but then I find that in gnome, my keyboard shortcuts don't work. I have configured these in the metacity section of gconf-editor and also in the compiz ccsm general settings, and I find that they appear just fine in both places but do not function.
    I am so close I can taste it. Help me out, please, someone!
    1) Perhaps there is a way in the "sessions" settings to set fusion-icon to load only under gnome?
    2) What is the magic command I need to put in an xsessions script to load the compiz-manager correctly?

    Thank you in advance for your help, to anyone!

  3. #3

    Default Re: Compiz and GNOME in openSUSE 11.1

    I hope you have solved your problem. I had almost the same problem 10 days ago when I did my computer upgrade. I'm also new here but not with linux.
    I had problem with the compiz and simple-ccsm that came with 11.1. I took those out and install compiz-fusion with fusion-icon.
    To load at startup on Gnome from the sessions. I just put "fusion-icon" in the command field.
    As far as I know, you only need to launch fusion-icon et you're ready to go.

    It's really too bad that I didn't see your post during my troubleshoot. I think it could have been easier for both of us. I found this post while searching for "screenlets". Btw, how do you make screenlets appeared in all desktop?
    Mine just showed in one desktop, the one from where I launch screenlets from the command line.

    Today, I rebooted my computer and no more compiz. I'm still searching why suddenly I can't launch fusion-icon anymore.

    Hope to hear from you.

  4. #4

    Default Re: Compiz and GNOME in openSUSE 11.1

    I re-install from scratch and follow the instruction from the Wiki.
    I needed to select the XGL repository and kept simple-ccsm.
    The emerald theme manager don't change the window frame and sometime need a force quit.

    About the sessions, I have conky, screelnet and cairo-dock and still get decent response time. I would say less than 10 sec.
    Maybe you should just put it in the session.


  5. #5

    Default Re: Compiz and GNOME in openSUSE 11.1

    How funny, just last night I sorted this out (I hope).

    For about a month I was loading compiz with a session entry for fusion-icon, which added about 30 seconds to my boot time and was also mighty ugly. In addition, KDE 4 would sometimes give me plasma segfaults at boot, and sometimes would hang with a black screen for about a minute when it loaded fusion-icon.

    I don't know if it affected things that I switched desktop managers, but last night I just switched to kdm, took fusion-icon out of the session, booted into gnome, ran simple-ccsm, switched on the desktop effects, and clicked yes to save changes. Ever since, compiz loads as the windows manager, even in KDE (though I have not turned on the desktop effects in the desktop settings). fusion-icon appears in my gnome panel, but not in my KDE panel.

    So far so good..

    By the way, to make screenlets appear on all desktops, there is a "stick to desktop" option in the properties for each screenlet.

  6. #6

    Default Re: Compiz and GNOME in openSUSE 11.1

    Nice to hear that you have a compiz running.

    How many sec. it takes to load in KDE? acceptable?
    Before using kdm, what was your display manager? gdm?
    Do you have any problem with emerald to change the window them?

    The first time I installed Screenlets and after I played with the config, I saw the screenlets on all my workspace. For some reasons, it stop displaying. I tried to relaunch the daemon. I see the process

    453 pts/1 S+ 0:00 grep screen
    32638 ? S 0:03 python -u /usr/share/screenlets/DigiClock/
    32702 ? S 0:00 python -u /usr/share/screenlets/ClearWeather/
    32716 ? S 0:00 python /usr/share/screenlets-manager/

    but nothing.
    Before reading your post, I disabled all entries of screenlets in my sessions except the daemon. It work. It's more stable then I tried with the sticky options and it work for all my workspace. Thanks alot.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts