Results 1 to 4 of 4

Thread: Screen-saver logs me out intermittently

  1. #1
    mikemrh9 NNTP User

    Default Screen-saver logs me out intermittently

    Hi.

    I'm running OpenSuSE 11.1 with KDE 4.1.3 and find that sometimes when I move the mouse to resume work after the screensaver has started, I get logged out and all my applications are shut down. This happens about 1 time in 10.

    Previously, I was running 11.0 with KDE 4.1.2 and had no issues at all.

    My Graphics card is an Intel 965GM. The following is an extract from from /var/log/messages, and includes the line,

    Feb 1 19:23:45 laptop kdm[2474]: X server for display :0 terminated unexpectedly:



    Feb 1 19:12:03 laptop syslog-ng[2085]: Log statistics; dropped='pipe(/dev/xconsole)=0', dropped='pipe(/dev/tty10)=0', processed='center(queued)=1907', processed='center(received)=1761', processed='destination(newsnotice)=0', processed='destination(acpid)=2', processed='destination(firewall)=1412', processed='destination(null)=4', processed='destination(mail)=2', processed='destination(mailinfo)=2', processed='destination(console)=47', processed='destination(newserr)=0', processed='destination(newscrit)=0', processed='destination(messages)=261', processed='destination(mailwarn)=0', processed='destination(localmessages)=0', processed='destination(netmgm)=80', processed='destination(mailerr)=0', processed='destination(xconsole)=47', processed='destination(warn)=50', processed='source(src)=1761'
    Feb 1 19:12:18 laptop smartd[3012]: Device: /dev/sda [SAT], SMART Usage Attribute: 194 Temperature_Celsius changed from 110 to 109
    Feb 1 19:19:52 laptop kernel: [drm:i915_getparam] *ERROR* Unknown parameter 5
    Feb 1 19:19:53 laptop kernel: [drm:i915_getparam] *ERROR* Unknown parameter 5
    Feb 1 19:23:45 laptop kdm[2474]: X server for display :0 terminated unexpectedly
    Feb 1 19:23:47 laptop kernel: [drm:i915_getparam] *ERROR* Unknown parameter 5
    Feb 1 19:23:48 laptop kernel: [drm:i915_getparam] *ERROR* Unknown parameter 5
    Feb 1 19:23:54 laptop kernel: CPU0 attaching NULL sched-domain.
    Feb 1 19:23:54 laptop kernel: CPU1 attaching NULL sched-domain.
    Feb 1 19:23:54 laptop kernel: CPU0 attaching sched-domain:
    Feb 1 19:23:54 laptop kernel: domain 0: span 0-1 level MC
    Feb 1 19:23:54 laptop kernel: groups: 0 1
    Feb 1 19:23:54 laptop kernel: domain 1: span 0-1 level NODE
    Feb 1 19:23:54 laptop kernel: groups: 0-1
    Feb 1 19:23:54 laptop kernel: CPU1 attaching sched-domain:
    Feb 1 19:23:54 laptop kernel: domain 0: span 0-1 level MC
    Feb 1 19:23:54 laptop kernel: groups: 1 0
    Feb 1 19:23:54 laptop kernel: domain 1: span 0-1 level NODE
    Feb 1 19:23:54 laptop kernel: groups: 0-1
    Feb 1 19:24:11 laptop python: hp-systray(init)[6186]: warning: No hp: or hpfax: devices found in any installed CUPS queue. Exiting.
    Feb 1 19:28:32 laptop dhclient: DHCPREQUEST on eth0 to 10.29.11.254 port 67



    With regard to the message,
    kernel: [drm:i915_getparam] *ERROR* Unknown parameter 5

    I found a thread which claims that:

    this message is emitted if you're using
    xf86-video-intel >= 2.5 on a kernel < 2.6.28, because the driver is
    poking for GEM support; the message is harmless, and can be safely
    ignored

    I'm using the standard released kernel 2.6.27.7-9-pae.

    Is this a known bug, or is there a software configuration change that I could make to improve the situation? I'm currently running the 'performance' power profile and have deselected the option under power management to allow powerdevil to manage screen powersaving. (It didn't make any difference!)

    I hope that this is resolvable, as I have lost work on 3 occasions now!

    Any suggestions gratefully appreciated.

    Mike.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Screen-saver logs me out intermittently

    try using a blank screensaver
    or disable it
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    mikemrh9 NNTP User

    Default Re: Screen-saver logs me out intermittently

    Thanks for the reply. However, rather than a workaround I was hoping to find either a solution, or confirmation that my issue is not an isolated case. If the latter, a bug report needs to be filed if one doesn't already exist.

  4. #4
    mikemrh9 NNTP User

    Default Re: Screen-saver logs me out intermittently

    Thanks for your help. However, I have now found a completely different solution, which has also increased performance and fixed a few other stability niggles that I had with SuSE 11.1.

    My solution is Arch Linux.

    Wow!

    Thanks for the last 5 years, SuSE, and goodbye...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •