Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Installed 11.1 and runing very slow after new install

  1. #1

    Default Installed 11.1 and runing very slow after new install

    I just installed 11.1. After the fresh install my pc it is running very slow. It takes a good amount of time to load web pages in the browser.

    When I run my mail client, Thunderbird, the display comes up clouded as if x-windows is having a problem painting the screen. When dragging a window you can see the display lag.

    The general performance is poor. I was running 10.2 on this same pc before the fresh install of 11.1, and it ran like a champ, very fast.

    I opened a root window an ran top and I am not seeing anything that jumps out as a problem.

    The PC is a P4 2.8ghz, 2gb memory, using the on board video card Intel 865g.

    Any help would be appreciated.

    Thanks

  2. #2
    Join Date
    Dec 2008
    Location
    Slovenia
    Posts
    63

    Default Re: Installed 11.1 and runing very slow after new install

    xgl-switch --enable-xgl

    maybe try this
    Stipi69

  3. #3

    Default Re: Installed 11.1 and runing very slow after new install

    Quote Originally Posted by stipi69 View Post
    xgl-switch --enable-xgl

    maybe try this
    what is the xgl switch command doing?

  4. #4
    Join Date
    Dec 2008
    Location
    Slovenia
    Posts
    63

    Default Re: Installed 11.1 and runing very slow after new install

    Xgl Versus AIGLX

    On openSUSE 11.0 it is no longer possible to enable or disable Xgl with a graphical tool (such as gnome-xgl-settings in the past). Only the command line tool xgl-switch is still left to do this job. Instead AIGLX is now always enabled on supported hardware. There are still some issues with AIGLX (e.g., Xvideo is usually slower, OpenGL applications are misplaced when you rotate compiz' cube), but the majority of our customers are requesting to have AIGLX enabled by default. If you prefer Xgl over AIGLX use the command line tool xgl-switch to enable it:
    xgl-switch --enable-xgl

    If there are problems after enabling it (Xserver crashes, etc.) disable it again by running
    xgl-switch --disable-xgl

    The proprietary NVIDIA driver needs neither AIGLX nor Xgl for running with compositing managers as it provides its own framework.

    To enable Compiz, use "Desktop Effects (simple-ccsm)" application from the application menu.

    found this in release notes, when i installed it... i have experienced with this a little and it performs great even when running desktop effects on full. maybe it should do the trick for this problem allso, i am not sure, that is why i wrote maybe you should try this
    Stipi69

  5. #5
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,392
    Blog Entries
    34

    Default Re: Installed 11.1 and runing very slow after new install

    Two other things can slow down your PC:
    a. ipv6 - try disabling that (I always disable it as part of the install);
    b. beagle - it could be indexing your hard drive, slowing things down. You could remove beagle (I always remove it).

  6. #6
    Join Date
    Dec 2008
    Location
    Slovenia
    Posts
    63

    Default Re: Installed 11.1 and runing very slow after new install

    hi old cpu!

    On my previous hardware i have disabled beagled allso, but now on aMILO XI2550 i have it running... is it still making problems with performance? maybe i should disable it now allso, thanx for remembering me

    Can jo be so nice, and tell me what ipv6 is?
    should i disable it, or can i expect to have some issues then elsewhere?
    Stipi69

  7. #7
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,392
    Blog Entries
    34

    Default Re: Installed 11.1 and runing very slow after new install

    Quote Originally Posted by stipi69 View Post
    Can jo be so nice, and tell me what ipv6 is?
    should i disable it, or can i expect to have some issues then elsewhere?
    Some ipv6 urls:
    SDB : Disabling IPv6 completely - openSUSE
    and
    Disable IPv6 for Firefox - openSUSE
    and
    IPv6 - Wikipedia, the free encyclopedia

  8. #8
    Join Date
    Dec 2008
    Location
    Slovenia
    Posts
    63

    Default Re: Installed 11.1 and runing very slow after new install

    Thank you, should study this trough right now.
    Stipi69

  9. #9

    Default Re: Installed 11.1 and runing very slow after new install

    Quote Originally Posted by oldcpu View Post
    Two other things can slow down your PC:
    a. ipv6 - try disabling that (I always disable it as part of the install);
    b. beagle - it could be indexing your hard drive, slowing things down. You could remove beagle (I always remove it).
    Oldcpu,

    I had already uninstalled beagle. first thing i dod after the install. I disabled the ivp6 and now it is running the way i expect it to.

    Thanks again.

  10. #10
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: Installed 11.1 and runing very slow after new install

    Sounds more like the display driver is wrong.
    Try running sax2 and reconfiguring X.
    You can also check what processes are hogging the system. For a gui type: Ctrl-Esc

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •