Results 1 to 5 of 5

Thread: Can't write files on NTFS partition

  1. #1
    MorgenLee NNTP User

    Default Can't write files on NTFS partition


    I mount a NTFS partition under /windows/I. I can create a new text file
    under this folder. However, each time I tried to save this file after
    modifying it, the system told me that I do not have the access to do
    that. Suspect that there is something wrong with my fstab. But I don't
    know what exactly goes wrong. anybody can help?

    Here is the content of the fstab.

    -/dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part14 /home
    ext3 acl,user_xattr 1 2
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part13 swap
    swap defaults 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part12 /
    ext3 acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part1 /windows/C
    ntfs-3g
    user,users,gid=users,umask=0002,fmask=133,dmask=002,locale=en_US.UTF-8 0
    0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part5 /windows/D
    vfat users,gid=users,umask=0002,utf8=true 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part6 /windows/E
    ntfs-3g
    user,users,gid=users,umask=0002,fmask=133,dmask=002,locale=en_US.UTF-8 0
    0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part7 /windows/F
    ntfs-3g
    user,users,gid=users,umask=0002,fmask=133,dmask=002,locale=en_US.UTF-8 0
    0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part8 /windows/G
    ntfs-3g
    user,users,gid=users,umask=0002,fmask=133,dmask=002,locale=en_US.UTF-8 0
    0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part9 /windows/H
    ntfs-3g
    user,users,gid=users,umask=0002,fmask=133,dmask=002,locale=en_US.UTF-8 0
    0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part10 /windows/I
    ntfs-3g
    user,users,gid=users,umask=0002,fmask=133,dmask=002,locale=en_US.UTF-8 0
    0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part11 /windows/J
    ntfs-3g
    user,users,gid=users,umask=0002,fmask=133,dmask=002,locale=en_US.UTF-8 0
    0
    proc /proc proc defaults
    0 0
    sysfs /sys sysfs noauto
    0 0
    debugfs /sys/kernel/debug debugfs noauto
    0 0
    usbfs /proc/bus/usb usbfs noauto
    0 0
    devpts /dev/pts devpts mode=0620,gid=5
    0 0-

    I am using Opensuse 11.0


    --
    MorgenLee
    ------------------------------------------------------------------------
    MorgenLee's Profile: http://forums.opensuse.org/member.php?userid=15462
    View this thread: http://forums.opensuse.org/showthread.php?t=406597


  2. #2
    oldcpu NNTP User

    Default Re: Can't write files on NTFS partition


    MorgenLee;1937081 Wrote:
    > I mount a NTFS partition under /windows/I. I can create a new text file
    > under this folder. However, each time I tried to save this file after
    > modifying it, the system told me that I do not have the access to do
    > that. Suspect that there is something wrong with my fstab. Indeed ... There is guidance here: 'NTFS - openSUSE'

    (http://en.opensuse.org/NTFS)
    You have both dmask and umask. I don't know this well enough to help
    you use both at the same time, but you do something simple like this
    (where I have changed fmask from 133 to fmask=113 and changed "dmask 0
    02" to "dmask=002" , and removed umask). You could try this, reboot and
    test.


    Code:
    --------------------

    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part14 /home ext3 acl,user_xattr 1 2
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part13 swap swap defaults 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part12 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part1 /windows/C ntfs-3g user,users,gid=users,fmask=113,dmask=002,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part5 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part6 /windows/E ntfs-3g user,users,gid=users,fmask=113,dmask=002,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part7 /windows/F ntfs-3g user,users,gid=users,fmask=113,dmask=002,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part8 /windows/G ntfs-3g user,users,gid=users,fmask=113,dmask=002,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part9 /windows/H ntfs-3g user,users,gid=users,fmask=113,dmask=002,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part10 /windows/I ntfs-3g user,users,gid=users,fmask=113,dmask=002,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_ST3320613AS_6SZ04WLN-part11 /windows/J ntfs-3g user,users,gid=users,fmask=113,dmask=002,locale=en_US.UTF-8 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    --------------------


    --
    oldcpu
    ------------------------------------------------------------------------
    oldcpu's Profile: http://forums.opensuse.org/member.php?userid=77
    View this thread: http://forums.opensuse.org/showthread.php?t=406597


  3. #3
    swerdna NNTP User

    Default Re: Can't write files on NTFS partition


    The options should simple be "defaults,locale=en_US.UTF-8"
    So you get like this:
    /dev/etcetcetc /windows/X ntfs-3g defaults,locale=en_US.UTF-8 0
    0
    reference: 'HowTo Mount NTFS Filesystem Partition Read Write Access in
    openSUSE 10, 11' (http://www.swerdna.net.au/linhowtontfs.html)


    --
    'Drop in and visit some time'
    (http://www.swerdna.net.au/linux.html).
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=406597


  4. #4
    MorgenLee NNTP User

    Default Re: Can't write files on NTFS partition


    oldcpu, thanks for your help. It works.

    swerdna, since oldcpu's solution works, did not try yours. Thanks all
    the same.


    --
    MorgenLee
    ------------------------------------------------------------------------
    MorgenLee's Profile: http://forums.opensuse.org/member.php?userid=15462
    View this thread: http://forums.opensuse.org/showthread.php?t=406597


  5. #5
    JopSway NNTP User

    Default Re: Can't write files on NTFS partition


    It works the same (although I'd use defaults and not mess with
    permissions if there's no need to)


    --
    -It is abhorrent the spiritual greed of those that knowing something, do
    not seek the transfer of such knowledge.-

    -Miguel de Unamuno - Writer (1864-1936)-
    ------------------------------------------------------------------------
    JopSway's Profile: http://forums.opensuse.org/member.php?userid=81
    View this thread: http://forums.opensuse.org/showthread.php?t=406597


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •