Results 1 to 4 of 4

Thread: KDE4 Repositories

  1. #1
    Join Date
    Jun 2008
    Location
    France
    Posts
    41

    Default KDE4 Repositories

    Hi,

    anyone could give me a good list of repos to have KDE4 correctly updated ? here's my zypper lr

    # | Alias | Nom | Activ | Rafrachir
    ---+------------------------------------+------------------------------------+--------+-----------
    1 | openSUSE-11.1-Updates | openSUSE-11.1-Updates | Oui | Oui
    2 | openSUSE_11.1-Extra-Apps | openSUSE_11.1-Extra-Apps | Oui | Oui
    3 | openSUSE_11.1-KDE4-Factory | openSUSE_11.1-KDE4-Factory | Oui | Oui
    4 | openSUSE_11.1_1 | openSUSE_11.1 | Oui | Oui
    5 | openSUSE_11.1_KDE4_Factory_Desktop | openSUSE_11.1_KDE4_Factory_Desktop | Oui | Oui
    6 | repo | openSUSE BuildService - Mozilla | Oui | Oui
    7 | repo-debug | openSUSE-11.1-Debug | Non | Oui
    8 | repo-non-oss | openSUSE-11.1-Non-Oss | Oui | Oui
    9 | repo-oss | openSUSE-11.1-Oss | Oui | Oui
    10 | repo-source | openSUSE-11.1-Source | Non | Oui
    11 | repo-update | openSUSE-11.1-Update | Oui | Oui
    12 | repo_1 | Packman Repository | Oui | Oui
    but not sure it is a secure one. For example, I would like to have extra-apps, and a complete Dolphin's file manager ; I see in YaST that several applications are available (kde4-amarok, kde4-kaffeine...) but first I don't understand why they are not purposed directly (I have to install them manually) and secondly when I try to install some of thoses application there's a conflict.

    Thanks for help
    OpenSuse 11.1 - KDE 4.2.0 "release 100" - 2.6.27.7-9-default - Intel Pentium 4 3 GHz - Asus P4P800 SE - 1Go DDR SDRAM - ATI Radeon 9600 SERIES - Creative EMU10K1SB Live Audio Processor - 802.11g PCI Wireless Network Adapter - Samsung Syncmaster 931BW

  2. #2
    Join Date
    Jun 2008
    Location
    France
    Posts
    41

    Default Re: KDE4 Repositories

    Sorry I've forgotten

    rpm -qa | egrep -i "(kde4|dolphin)"

    kde4-l10n-fr-4.2.0-14.11
    kde4-kupdateapplet-packagekit-0.8.38-4.4
    kde4-kmahjongg-4.2.0-41.3
    libkde4-4.2.0-83.1
    kde4-kgreeter-plugins-4.2.0-184.7
    kde4-kdm-4.2.0-184.7
    kde4-kupdateapplet-0.8.38-4.4
    kde4-krdc-4.2.0-55.3
    kde4-kreversi-4.2.0-41.3
    kde4-kdm-branding-openSUSE-11.1.1-68.1
    kde4-filesystem-4.2.0-36.1
    kde4-kwin-4.2.0-184.7
    kde4-plasma-addons-4.2.0-51.3
    kde4-gwenview-4.2.0-68.12
    kde4-kpat-4.2.0-41.3
    kde4-dolphin-4.2.0-67.3
    kde4-kio_sysinfo-branding-openSUSE-11.1.1-68.1
    kde4-konsole-4.2.0-67.3
    kde4-kfind-4.2.0-67.3
    kde4-kmines-4.2.0-41.3
    kde4-krfb-4.2.0-55.3
    kde4-ksudoku-4.2.0-41.3
    kde4-ark-4.2.0-45.3
    kde4-kio_sysinfo-11.1.1-68.1
    OpenSuse 11.1 - KDE 4.2.0 "release 100" - 2.6.27.7-9-default - Intel Pentium 4 3 GHz - Asus P4P800 SE - 1Go DDR SDRAM - ATI Radeon 9600 SERIES - Creative EMU10K1SB Live Audio Processor - 802.11g PCI Wireless Network Adapter - Samsung Syncmaster 931BW

  3. #3
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    924

    Default Re: KDE4 Repositories

    It looks like you're missing the Extra-Apps repo for factory:

    Code:
    zypper ar http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Extra-Apps KDE4 Factory Extra-Apps (or any name you want)
    In case you don't know, the factory apps are not the stable ones, so these can and do break things from time to time. But factory is where KDE 4.2 is (for now) and it's much better than 4.1.

  4. #4
    Join Date
    Jun 2008
    Location
    France
    Posts
    41

    Default Re: KDE4 Repositories

    Thanks but I can't add this repo, an error appear "impossible to create repo using URL http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Extra-Apps"

    I've tried before to complete this URL like that http://download.opensuse.org/reposit...ra-Apps/]Index of /repositories/KDE:/KDE4:/Factory:/Extra-Apps/openSUSE_11.1/

    but YaST/Software has been bloqued while refreshing repos and I had to reboot with magic sysreq keys.

    What is the good way ?
    OpenSuse 11.1 - KDE 4.2.0 "release 100" - 2.6.27.7-9-default - Intel Pentium 4 3 GHz - Asus P4P800 SE - 1Go DDR SDRAM - ATI Radeon 9600 SERIES - Creative EMU10K1SB Live Audio Processor - 802.11g PCI Wireless Network Adapter - Samsung Syncmaster 931BW

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •