To create a dvd from an avi-file with aspectratio 2.23:1, I use the following cmd:

mencoder -oac lavc -ovc lavc -of mpeg -mpegopts format=dvd:tsaf \
-vf scale=720:432,expand=720:576,harddup -srate 48000 -af lavcresample=48000 \
-lavcopts vcodec=mpeg2video:vrc_buf_size=1835:vrc_maxrate=9800:vbitrate=5000:keyint=15:vstrict=0:acodec=ac3:abitrate=192:aspect=16/9 \
-ofps 25 -sub my_subtitles.srt -subpos 93 -subfont-text-scale 3 -font /usr/share/fonts/truetype/times.ttf -ffactor 5 \
-o my_movie.mpg my_movie.avi

This creates black bars on top and bottom of the screen, to keep a circle a circle when playing back on a 16:9 tv.

This works all ok, except for the subtitles. It seems that the subtitles are beeing processed before the stretching,
so the subtitles will be stretched as well. Ofcourse I don't want to stretch the subtitles.

I tried experimenting with the options -ass and -vf-add ass without any luck.

Who has the solution?

I convert the resulting mpeg-file to vob-files with ManDVD. Then I use K3B to burn the dvd.