Results 1 to 4 of 4

Thread: Wine configuration w/ OpenSuse

  1. #1

    Question Wine configuration w/ OpenSuse

    Hello everyone, I had a problem and I was wondering if anyone could help. I recently installed OpenSuse 11.1 and am enjoying it. I was using Kubuntu and have found one snag with my transition to OpenSuse. I would like to get iTunes 8.02 running in OpenSuse like I had been running been in Kubuntu.

    The way I got it working in Kubuntu was by following the instructions on the wine page here WineHQ - iTunes 8.0.2

    I'm not so familliar with rpm based systems so if anyone would be willing to help me I would really apricate it.

    Thanks in advance.

    PS
    No I can't really use an alternative because I use an iPhone and need the ability to sync.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Wine configuration w/ OpenSuse

    It look like the only thing to worry about is the MSI

    If I were you I would get this repo:

    Index of /repositories/Education/openSUSE_11.1
    make sure wine is from this repo

    Possibly consider using this: winetricks - The Official Wine Wiki

    to download:
    wget http://www.kegel.com/wine/winetricks

    to install MSI
    sh winetricks msi2
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Wine configuration w/ OpenSuse

    Ok I:
    1 Uninstalled the yast placed wine
    2 Deleted my .wine directory
    3 Ran winecfg to recreate the .wine directory
    4 Downloaded the winetricks script
    5 Ran the MSI install script eg "sh winetricks msi2" with no errors
    6 Tried to run the itunes installer. What happened was a "Prepereing to install" window came up then suddenly disappeared.

    I don't know if this would help but this is the output I got

    user@linux-miqb:~> wine /home/user/Desktop/iTunesSetup.exe
    fixme:sfc:SFC_3 0
    err:ole:create_server class {000c101c-0000-0000-c000-000000000046} not registered
    err:ole:CoGetClassObject no class object {000c101c-0000-0000-c000-000000000046} could be created for context 0x4
    fixme:advapi:RegisterEventSourceA ((null),"MsiInstaller"): stub
    fixme:advapi:RegisterEventSourceW (L"",L"MsiInstaller"): stub
    fixme:advapi:ReportEventA (0xcafe4242,0x0002,0x0000,0x000003f7,(nil),0x0006,0x00000000,0x7e4936b8,(nil)): stub
    fixme:advapi:ReportEventW (0xcafe4242,0x0002,0x0000,0x000003f7,(nil),0x0006,0x00000000,0x12ff50,(nil)): stub
    fixme:advapi:DeregisterEventSource (0xcafe4242) stub

    Any Ideas?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Wine configuration w/ OpenSuse

    This is something you will just have to work on.

    A thought: Did you keep a copy of your .wine folder from kubuntu?

    I have done this in the past and just pasted it over to my new install. Everything just works.
    You would have re-make menu items though in kicker.

    The wine forums may offer better help. Try installing more of the features offered by winetricks
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •