Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Conflicts When Upgrading To KDE4.2

  1. #1

    Default Conflicts When Upgrading To KDE4.2

    After seeing the news about KDE4.2 being ready for Opensuse 11.1 I clicked the one-click install link. After clicking through the screens I got some conflicts, this is from the log file it generated:
    #### YaST2 conflicts list - generated 2009-01-31 09:16:19 ####

    kde4-ktnef-4.1.3-3.13.i586 requires kdepimlibs4 < 4.1.60, but this requirement cannot be provided

    [ ] Ignore some dependencies of kde4-ktnef

    [ ] deinstallation of kde4-ktnef-4.1.3-3.13.i586

    [ ] Following actions will be done:
    do not install kdepimlibs4-4.2.0-1.13.i586
    do not install kde4-kdepasswd-4.2.0-67.3.i586
    do not install kde4-kdialog-4.2.0-67.3.i586
    do not install kde4-kmix-4.2.0-41.3.i586
    do not install kde4-konqueror-4.2.0-67.3.i586
    do not install kde4-keditbookmarks-4.2.0-67.3.i586
    do not install kde4-kfind-4.2.0-67.3.i586
    do not install kde4-konsole-4.2.0-67.3.i586
    do not install kde4-kwrite-4.2.0-67.3.i586
    do not install kdebase4-4.2.0-67.3.i586
    do not install libkdepimlibs4-4.2.0-1.13.i586
    do not install libakonadi4-4.2.0-1.13.i586
    do not install kdebase4-session-4.2.0-32.1.i586


    kde4-knewsticker-4.1.3-4.13.i586 requires libplasma.so.2, but this requirement cannot be provided

    [ ] Ignore some dependencies of kde4-knewsticker

    [ ] Following actions will be done:
    do not install kdebase4-workspace-4.2.0-183.3.i586
    do not install kde4-kdepasswd-4.2.0-67.3.i586
    do not install kde4-kdialog-4.2.0-67.3.i586
    do not install kde4-kmix-4.2.0-41.3.i586
    do not install kde4-konqueror-4.2.0-67.3.i586
    do not install kde4-keditbookmarks-4.2.0-67.3.i586
    do not install kde4-kfind-4.2.0-67.3.i586
    do not install kde4-konsole-4.2.0-67.3.i586
    do not install kde4-kwrite-4.2.0-67.3.i586
    do not install kdebase4-4.2.0-67.3.i586
    do not install kdebase4-workspace-ksysguardd-4.2.0-183.3.i586
    do not install libkdepimlibs4-4.2.0-1.13.i586
    do not install libakonadi4-4.2.0-1.13.i586
    [ ] deinstallation of kde4-knewsticker-4.1.3-4.13.i586



    kde4-kio_sysinfo-11.1-66.4.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided

    [ ] Following actions will be done:
    do not install kde4-dolphin-4.2.0-67.3.i586
    do not install kde4-kdepasswd-4.2.0-67.3.i586
    do not install kde4-kdialog-4.2.0-67.3.i586
    do not install kde4-kmix-4.2.0-41.3.i586
    do not install kde4-konqueror-4.2.0-67.3.i586
    do not install kde4-keditbookmarks-4.2.0-67.3.i586
    do not install kde4-kfind-4.2.0-67.3.i586
    do not install kde4-konsole-4.2.0-67.3.i586
    do not install kde4-kwrite-4.2.0-67.3.i586
    do not install kdebase4-4.2.0-67.3.i586
    do not install kdebase4-session-4.2.0-32.1.i586
    [ ] downgrade of kde4-kio_sysinfo-11.1-66.4.i586 to kde4-kio_sysinfo-11.1-2.9.i586

    [ ] Ignore some dependencies of kde4-kio_sysinfo



    compiz-kde4-0.7.8-9.1.i586 requires libplasma.so.2, but this requirement cannot be provided

    [ ] Following actions will be done:
    do not install kde4-kwin-4.2.0-183.3.i586
    do not install kdebase4-workspace-ksysguardd-4.2.0-183.3.i586
    do not install kdebase4-session-4.2.0-32.1.i586
    do not install kde4-kdepasswd-4.2.0-67.3.i586
    do not install kde4-kdialog-4.2.0-67.3.i586
    do not install kde4-kmix-4.2.0-41.3.i586
    do not install kde4-konqueror-4.2.0-67.3.i586
    do not install kde4-keditbookmarks-4.2.0-67.3.i586
    do not install kde4-kfind-4.2.0-67.3.i586
    do not install kde4-konsole-4.2.0-67.3.i586
    do not install kde4-kwrite-4.2.0-67.3.i586
    do not install kdebase4-4.2.0-67.3.i586
    [ ] Ignore some dependencies of compiz-kde4

    [ ] deinstallation of compiz-kde4-0.7.8-9.1.i586




    #### YaST2 conflicts list END ###
    As I'm not an expert with Linux and don't want to just guess what to do (which would most likely end in a broken system), could anyone here tell me what I should do?

    Thank you very much for any help.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Conflicts When Upgrading To KDE4.2

    [ ] deinstallation of kde4-ktnef-4.1.3-3.13.i586

    [ ] deinstallation of kde4-knewsticker-4.1.3-4.13.i586


    [ ] downgrade of kde4-kio_sysinfo-11.1-66.4.i586 to kde4-kio_sysinfo-11.1-2.9.i586

    [ ] deinstallation of compiz-kde4-0.7.8-9.1.i586

    That should do it.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Conflicts When Upgrading To KDE4.2

    If you deinstall compiz-kde4-0.7.8-9.1.i586, how do you get compiz working again after the upgrade to 4.2? If you try to install compiz-kde4 in YaST after the fact it wants to downgrade 60 packages. I don't see compiz-kde4 in factory desktop. There are many versions on http://rpm.pbone.net/index.php3 though. Which one to use?
    Last edited by harryc56; 01-Feb-2009 at 07:20.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Conflicts When Upgrading To KDE4.2

    All I can say is that's what I did.

    I now have:
    compiz
    compiz-kde

    as the main components + one or two others

    It works- believe me!
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Conflicts When Upgrading To KDE4.2

    Please run the following command from a konsole and post the results here;

    harryc@linux-pybs:~> rpm -qa | grep compiz
    compiz-manager-0.0.1_git080201-52.2
    compiz-gnome-0.7.8-9.1
    compiz-0.7.8-9.1
    compiz-fusion-plugins-main-0.7.8-4.13
    libcompizconfig-0.7.8-1.44
    compiz-kde-0.7.8-9.1
    compiz-branding-openSUSE-0.7.8-9.1

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Conflicts When Upgrading To KDE4.2

    Code:
    compiz-fusion-plugins-main-0.7.8-4.16
    compiz-0.7.8-9.1
    compiz-manager-0.0.1_git080201-52.1
    compiz-branding-openSUSE-0.7.8-9.1
    compiz-kde-0.7.8-9.1
    libcompizconfig-0.7.8-1.49
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Conflicts When Upgrading To KDE4.2

    It's pretty close, but you have a couple of newer packages. Do you have an XGL repository enabled?

    What are your repos? Run this command please;

    Code:
    harryc@linux-pybs:~> zypper lr
    #  | Alias                             | Name                             | Enabled | Refresh
    ---+-----------------------------------+----------------------------------+---------+--------
    1  | Factory_KDE_4_Community_          | Factory KDE 4 Community          | Yes     | Yes
    2  | Factory_KDE_4_Core_Packages_      | Factory KDE 4 Core Packages      | Yes     | Yes
    3  | Factory_KDE_4_Extra_Applications_ | Factory KDE 4 Extra Applications | Yes     | Yes
    4  | Factory_KDE_4_Qt_Packages_        | Factory KDE 4 Qt Packages        | Yes     | Yes
    5  | repo                              | Packman Repository               | Yes     | Yes
    6  | repo-debug                        | openSUSE-11.1-Debug              | Yes     | Yes
    7  | repo-non-oss                      | openSUSE-11.1-Non-Oss            | Yes     | No
    8  | repo-oss                          | openSUSE-11.1-Oss                | Yes     | No
    9  | repo-source                       | openSUSE-11.1-Source             | Yes     | Yes
    10 | repo-update                       | openSUSE-11.1-Update             | Yes     | No
    11 | repo_1                            | VideoLan Repository              | No      | No

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Conflicts When Upgrading To KDE4.2

    Be careful - I have loads in there. But check which are enabled!! Remember I'm always testing, this is not a recommended list. Harry- I know you understand that. But OTHERS may not.

    Code:
    1  | KDE4_Community            | KDE4 Community            | No      | No
    2  | KDE4_Community_Factory    | KDE4 Community Factory    | Yes     | Yes
    3  | KDE4_Desktop              | KDE4 Desktop              | No      | No
    4  | KDE4_Desktop_Factory      | KDE4 Desktop Factory      | Yes     | Yes
    5  | KDE4_Extra                | KDE4 Extra                | No      | No
    6  | KDE4_Factory_Extra        | KDE4 Factory Extra        | Yes     | Yes
    7  | Kde4_Factory_Desktop+Qt45 | Kde4 Factory Desktop+Qt45 | No      | No
    8  | Mozilla                   | Mozilla                   | Yes     | Yes
    9  | Packman                   | Packman                   | Yes     | Yes
    10 | QT                        | QT                        | No      | No
    11 | QT44                      | QT44                      | Yes     | Yes
    12 | VBox                      | VBox                      | Yes     | Yes
    13 | VLC                       | VLC                       | No      | No
    14 | openSUSE 11.1-0           | openSUSE 11.1-0           | No      | No
    15 | repo-debug                | openSUSE-11.1-Debug       | No      | No
    16 | repo-non-oss              | openSUSE-11.1-Non-Oss     | Yes     | No
    17 | repo-oss                  | openSUSE-11.1-Oss         | Yes     | No
    18 | repo-source               | openSUSE-11.1-Source      | No      | No
    19 | repo-update               | openSUSE-11.1-Update      | Yes     | Yes
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Conflicts When Upgrading To KDE4.2

    Thanks, I'd assume that you picked up the newer versions from one of the community repos. Oh well, I appreciate your time. I'll have to go back to basics on getting compiz working on this laptop. It's a Thinkpad X61s with an Intel GPU. 3D is working, and the driver is 'Intel'.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Conflicts When Upgrading To KDE4.2

    As you see I'm R61e

    Code:
    Vendor:   Tungsten Graphics, Inc
      Model:   Mesa DRI Intel(R) 965GM 20080716 x86/MMX/SSE2
      Driver:   1.4 Mesa 7.2
    Working beautifully. So slick it is unbelievable!!
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •