Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: openSUSE x86_64 startup issues

  1. #1

    Question openSUSE x86_64 startup issues

    Hello suse-users,

    I've installed openSUSE 11.1 in my computer, everything sweet and clean, but I am having two issues at the startup.

    First of all, my computer is:

    HP Pavillion 6950la

    AMD Turion 64 X2 TL-62 (2.1 Ghz)
    4 GB RAM DDR2 667
    nVidia Geforce Go 7150M
    I installed openSUSE 11.1 in an extended partition.

    All I had to install after the installation was the nVidia drivers, the rest is all working nice and shinny.

    Still, the issues are the following:

    - First, when I pick openSUSE in grub, the loading screen shows but it won't work, it gets stuck there and the only way to make it progress is to push ESC and ENTER, ENTER, ENTER or any other key. I am not sure why this is happening, I tried disabling the wireless at startup, touchpad, everything, but nothing. I've also looked for people having this same problem but I found nothing.

    - Second, when I make openSUSE to load, a huge nVidia logo is displayed (Kinda sexy huh?) and after that, I am asked to log in as root, I do it, and 2 seconds after I log in, the screen goes black! I thought and I said: "Maybe it changed the screen to screen 2", so I pushed [FN] + F4 and voila! Video is back.. I tried the nVidia settings but nothing, I couldn't find anything to solve this. I even tried to look into the xorg file, to see if there is some errors, but nope.

    Apart of these issues, openSUSE is running perfect, but you know.. these are annoying so.. if I hear solutions, I'd be more than glad and motivated to start using this wonderful distro.

    Please, help? Any question about my system or anything, are welcome. I'd be tracking down this thread.

    Regards.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: openSUSE x86_64 startup issues

    First and most important, you should not be logging in as root!

    You could check in /var/log
    for boot messages

    Try booting failsafe. You will probably have to login at CLI and then startx
    see if it behaves differently during boot though.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: openSUSE x86_64 startup issues

    Hey, thanks for your reply.

    And yes, you are right, I should not be logging in as root, but aparantly I am not because if the system keeps asking me permssion to do certain things or if I have to use sudo everytime I use the console..

    anyway, I'll try what you said and be back here with the test results.

  4. #4

    Default Re: openSUSE x86_64 startup issues

    Hello,

    I tryed booting failsafe mode, and everything worked perfectly, I didn't have to push any key to make suse load, and the right screen was selected. But.. the video driver didn't seem to be installed. No compiz, no big reso.

    I feel like we're in the same situation here, no progress.

    What else can I do to fix this?

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: openSUSE x86_64 startup issues

    It is likely a boot argument used in Failsafe.

    At boot, when you move to select between one or the other, just notice the text lower down - and the difference between the two.

    Failsafe will have all the kernel arguments for a failsafe boot, to avoid hardware issues.

    Most likely is the option: acpi=off

    To try it alone, simply type that in the boot line when selecting the Normal boot.

    However, there is nothing particularly wrong in using the failsafe boot for the time being.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: openSUSE x86_64 startup issues

    Hey, you were right about the boot command: apci=off. this indeed solve my loading problem at startup but I wanna know why? why setting acpi to 'off' will let suse load good?

    But this is just the start.. cause yaeh, it loaded super fast, then when I got to the desktop I had to face with my second problem, I log in and then this silly nVidia changes the Screen X to the next one, BUUUT, for some reason, even if I try pushing [FN] + F4 to enable the screen again, it won't work.. Maybe setting acpi=off affected the shortcut fn keys?

    :-/

    thanks for your replies, caf4926.

  7. #7

    Default Re: openSUSE x86_64 startup issues

    The reason will be that the BIOS ACPI code has something in it that the ACPI interpreter in the kernel can't parse, perhaps an MS extension created by their tool chain, that only Windows knows about because it's not in the ACPI standard (or something has been interpreted differently, as the standard is not 100% unambiguous). Things are not getting set up in a way the kernel can use them.

    There may be a BIOS update which solves the problem. In past some ppl have gone to such lengths as disassemble the ACPI code in BIOS, hack it, then re-flash. Not something for the faint hearted!

  8. #8

    Default Re: openSUSE x86_64 startup issues

    Hello robopensuse,

    Thanks for your explaination, but the fact [fn] shortcuts keys are not working is an effect by setting acpi=off?

    I think there's something wrong in the xorg.conf file, that's why my screen becomes black right after I log in, like the video adapter changes to video output to the Screen 2. So to fix this, I just use the {fn} + f4, which swap the video output between the external video output and the laptop's screen. but this time, when I set acpi=off, {fn} + f4 did not work.

    I installed the nVidia drivers with the 1-click install.. perhaps If i try again..?

    Thanks for your reply.

  9. #9
    ab@novell.com NNTP User

    Default Re: openSUSE x86_64 startup issues

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    As a note my wife's dv6000 also have this same
    press-enter-a-dozen-times-to-boot issue, and often to shutdown. Seems
    to happen first regularly (if not consistently) when loading USB
    components. I'll have her try the acpi=off bit.

    Good luck.







    mirux wrote:
    > Hello robopensuse,
    >
    > Thanks for your explaination, but the fact [fn] shortcuts keys are not
    > working is an effect by setting acpi=off?
    >
    > I think there's something wrong in the xorg.conf file, that's why my
    > screen becomes black right after I log in, like the video adapter
    > changes to video output to the Screen 2. So to fix this, I just use the
    > {fn} + f4, which swap the video output between the external video output
    > and the laptop's screen. but this time, when I set acpi=off, {fn} + f4
    > did not work.
    >
    > I installed the nVidia drivers with the 1-click install.. perhaps If i
    > try again..?
    >
    > Thanks for your reply.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFJhHbs3s42bA80+9kRAnFYAJ45lAJbtkRIbv0n4uhlJ6fQ7tk+WgCgi0UV
    CgqLux/8CHXIja4orjYh6IM=
    =PVB2
    -----END PGP SIGNATURE-----

  10. #10

    Default Re: openSUSE x86_64 startup issues

    BINGO!

    I finally fixed my second issue, with the blackout after the signingn in.

    It was compiz, I disabled compiz on startup, and rebooted to see if the blackout happens! but no, everything perfect so now I am gonna find out what is causing the balckout then I post back with the final solution to this.

    And yeah, acpi=off seems to be the solution, I'll do some more research on what features I may lose if I disable acpi tho.

    Regards.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •