Results 1 to 2 of 2

Thread: ATI Mobility Radeon HD 3650: crash on X startup

  1. #1

    Question ATI Mobility Radeon HD 3650: crash on X startup

    I am trying to use the proprietary catalyst driver with my ATI Mobility Radeon HD 3650 chipset on an HP Elitebook 8530p on a newly installed openSUSE 11.1.

    Version 8.11 of the driver installs fine, X starts up fine, but it is running quite unstable (frequent crashes when playing video, switching consoles,...).

    But when installing a newer driver (8.12 or 9.1) the maching crashes on the startup of X (under Gnome and KDE 4.x, under GDM and KDM), leaving a blank screen and an unresponsive maching. I used the same procedure to install 8.11 and 8.12/9.1: Download driver, run, ati-config --initial (I tried with and without sax2 -r -m 0=fglrx).

    In the Xorg.0.log file I find (for 8.12) the following lines:

    Code:
    Backtrace:
    0: /usr/bin/X(xf86SigHandler+0x79) [0x80c0c19]
    1: [0xffffe400]
    
    Fatal server error:
    Caught signal 11.  Server aborting
    Full Xorg.0.log files:
    (8.12): http://pastebin.com/f3a672c79
    (9.1): http://pastebin.com/d6ed2784f

    Does somebody have any idea, on what I am doing wrong? Or did I find a bug in the driver itself?
    Last edited by dgrafenhofer; 30-Jan-2009 at 01:24. Reason: Added links to Xorg.0.log files

  2. #2

    Default Re: ATI Mobility Radeon HD 3650: crash on X startup

    Correct link for 9.1 log file:

    pastebin - collaborative debugging tool

    Sorry.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •