I updated today to KDE 4.2 from KDE 3.5.10 on openSUSE 11.1. Tried to install Amarok for KDE 4, but ran into some problems.

Can anyone explain to me why I receive the error message below, and what I should do about it? What does "deleted providers" and "uninstallable providers" mean?

Cheers,

homoludens

Code:
kdebase4-workspace-4.2.0-184.8.i586 requires kdebase4-runtime >= 4.2.0, but this requirement cannot be provided
deleted providers: kdebase4-runtime-4.2.0-75.3.i586[@System]
uninstallable providers: kdebase4-runtime-4.2.0-76.1.i586[KDE:KDE4:Factory:Desktop]
    [ ] Ignore some dependencies of kdebase4-workspace

    [ ] Following actions will be done:
downgrade of kdebase4-workspace-4.2.0-184.8.i586 to kdebase4-workspace-4.1.3-10.1.i586
downgrade of kde4-kwin-4.2.0-184.8.i586 to kde4-kwin-4.1.3-10.1.i586
downgrade of kde4-kgreeter-plugins-4.2.0-184.8.i586 to kde4-kgreeter-plugins-4.1.3-10.1.i586
downgrade of kde4-kdm-4.2.0-184.8.i586 to kde4-kdm-4.1.3-10.1.i586
downgrade of kdebase4-runtime-4.2.0-75.3.i586 to kdebase4-runtime-4.1.3-4.1.i586
downgrade of ktorrent-3.1.99+3.2beta1-20.17.i586 to ktorrent-3.1.5-0.pm.2.i586
install ktorrent-3.1.5-0.pm.2.i586 (with vendor change)
  openSUSE Build Service
(+ 76 other packages ... )
    [ ] do not install kde4-amarok-2.0.1.1-2.1.1.i586