Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Desktop effects KDE4.2

  1. #1
    Join Date
    Jan 2009
    Posts
    23

    Default Desktop effects KDE4.2

    Hi!

    I started to try KDE4.2 and everything is good, exept desktop effects don't work.
    Once I tried 4.1, and then desktop effects worked fine.

    I don't think that this is an harware, driver or xorg.conf related problem, since 3D works otherwise good. Glxgears run smoothly.
    (well, compiz has never been too good on this machine, but kwin-effects have worked)

    Graphics card is ATI Radeon IGP 320M and I run KDE4.2 on Suse 11.0
    card is using radeon driver (I don't think it would run on any other)
    and I have tried virtually anything I could find, related to my problem.

    I would be grateful of any help you can give.

  2. #2
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Desktop effects KDE4.2

    If you installed fglrx properly and confogured it with sax2, then all you need to do is go to configure desktop from main menu, desktop, enable effects and choose which one you are going to use on "all effects" tab.

    There is nothing more to it.

    If it does not work, try doing in konsole, as root,
    sax2 -r -m 0=fglrx, reboot and start over

  3. #3
    Join Date
    Jan 2009
    Posts
    23

    Default Re: Desktop effects KDE4.2

    Quote Originally Posted by beli0135 View Post
    If you installed fglrx properly and confogured it with sax2, then all you need to do is go to configure desktop from main menu, desktop, enable effects and choose which one you are going to use on "all effects" tab.

    There is nothing more to it.

    If it does not work, try doing in konsole, as root,
    sax2 -r -m 0=fglrx, reboot and start over
    Well, I'm using free radeon driver, not ATI poprietary driver. I think that this card doesn't even work on fglrx.


    Previosly I got this error message, when I tried to enable desktop effects:
    "Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values. Check your X configuration. You may also consider changing advanced options, especially changing the compositing type."

    I tried to enable effects, but minimum settings. It "worked" Desktop effects are enabled, if you believe what you see on settings or kwinrc. But none of the enabled effects are truely working.

  4. #4
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Desktop effects KDE4.2

    Quote Originally Posted by ayni View Post
    Well, I'm using free radeon driver, not ATI poprietary driver. I think that this card doesn't even work on fglrx.


    Previosly I got this error message, when I tried to enable desktop effects:
    "Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values. Check your X configuration. You may also consider changing advanced options, especially changing the compositing type."

    I tried to enable effects, but minimum settings. It "worked" Desktop effects are enabled, if you believe what you see on settings or kwinrc. But none of the enabled effects are truely working.
    Is this part included in your xorg.conf?
    Code:
    Section "Extensions"
     Option "Composite" "Enable"
    EndSection
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  5. #5
    Join Date
    Jan 2009
    Posts
    23

    Default Re: Desktop effects KDE4.2

    Quote Originally Posted by ram88 View Post
    Is this part included in your xorg.conf?
    Code:
    Section "Extensions"
     Option "Composite" "Enable"
    EndSection
    Mine was:
    Code:
    Section "Extensions"
     Option "Composite" "true"
    EndSection
    But changing had no effect.

  6. #6
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Desktop effects KDE4.2

    As I know, open driver is not capable of good 3D. But, I am not sure about that.
    There is no cost to try proprietary driver and give it a test run.

  7. #7
    Join Date
    Jan 2009
    Posts
    23

    Default Re: Desktop effects KDE4.2

    Quote Originally Posted by beli0135 View Post
    As I know, open driver is not capable of good 3D. But, I am not sure about that.
    i think you're right. But I don't want anything fancy. I just would like to have some simple eye candy, that have worked before.
    This KDE4.2 is otherwise quite good, and this is not critical, only something that would be nice.

    Quote Originally Posted by beli0135 View Post
    There is no cost to try proprietary driver and give it a test run.
    Code:
    sax2 -r -m 0=fglrx
    Stopped at:
    Code:
            Fatal server error:
            no screens found
    and

    Code:
    aticonfig --initial
    stopped at segmentation fault.

    So no luck.

  8. #8
    Join Date
    Sep 2008
    Location
    Bulgaria
    Posts
    56

    Default Re: Desktop effects KDE4.2

    I have exactly the same card on my trusty old laptop, and assure you desktop effects do run. Not as smoothly as on a brand new C2D machine, but still well enough. As far as I know, this card is only supported by the open source radeon driver, so no use in trying out fglrx.

    In fact, effects performance on KDE 4.2 is the best for me since the beginning of KDE 4. Some of the effects are still lagging, but shadows, wobbly windows, the magic lamp, the desktop cube, screen dimming to name just a few that come to mind work well. Perhaps you should look for the option that says disable functionality checks, and tick it. Otherwise, it would not work.

    Another thing that comes to mind is to enable AIGLX in your xorg.conf, and disable XGL. I can give you more details as soon as I get home to my laptop, which shoud be in a few hours.

    Lastly, you may check in System Settings, Default Application, Window Manager (may not recall it correctly), the last option is the default window manager, make sure it says KWin.

    In 11.0 I used compiz as it was much smoother than kwin then, but in 11.1 compiz was somewhat problematic, and never gave me that kind of performance. So I removed it completely. However, I must say the wobbly and magic lamp on compiz worked better that the corresponding effects in kwin.

    Perhaps someone could post more detailed info about manual configuration to tweak their performance?

    Don't get desparate, it does work!

  9. #9
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Desktop effects KDE4.2

    My way, that never failed so far is this:

    1. download driver from ATI site
    2. unpack, give +x permissions and start with ./ and follow the instructions (accept default/recommended settings).
    3. reboot, place "init 3" in grub menu just to boot with no graphics, and log as root (text mode)
    4. sax2 -r -m 0=fglrx
    5. reboot

  10. #10
    Join Date
    Jan 2009
    Posts
    23

    Default Re: Desktop effects KDE4.2

    Quote Originally Posted by hermesrules View Post
    I have exactly the same card on my trusty old laptop, and assure you desktop effects do run. Not as smoothly as on a brand new C2D machine, but still well enough. As far as I know, this card is only supported by the open source radeon driver, so no use in trying out fglrx.
    I had that feeling too, buttried anyway. To be shure.

    Quote Originally Posted by hermesrules View Post
    Perhaps you should look for the option that says disable functionality checks, and tick it. Otherwise, it would not work.
    Gui disn't let me, so I did it manually to kwinrc. Resulting first all white then all balck screen with only my mouse pointer.

    Quote Originally Posted by hermesrules View Post
    Another thing that comes to mind is to enable AIGLX in your xorg.conf, and disable XGL.
    done. didn't make difference.

    Quote Originally Posted by hermesrules View Post
    Lastly, you may check in System Settings, Default Application, Window Manager (may not recall it correctly), the last option is the default window manager, make sure it says KWin.
    For my finnish system it's first option , but anyways it has always been KWin.

    Quote Originally Posted by hermesrules View Post
    Don't get desparate, it does work!
    I'll get over it even if it doesn't.
    Compiz slowed things too much when I tired it (over a year ago). So I don't have any 3d effects on my 3.5 desktop, and I shurely can live without them with 4.2.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •