Results 1 to 10 of 10

Thread: Upgrade to 11.1 broke VirtualBox

  1. #1

    Default Upgrade to 11.1 broke VirtualBox

    Hi All,

    I upgraded from 11.0 to 11.1, uninstalled VirtualBox 2.1.2.41885 from the rpm and reinstalled with VirtualBox-2.1.2_41885_openSUSE111-1.i586.rpm. I then started getting permission denied errors. I followed instructions from another post on the problem to chmod 755 and now I'm getting this error.
    //////////////////////////////////////////////////////////////
    /usr/bin/VirtualBox
    VirtualBox: Error -10 in SUPR3HardenedMain!
    VirtualBox: Effective UID is not root (euid=1000 egid=100 uid=1000 gid=100)

    VirtualBox: Tip! It may help to reinstall VirtualBox.
    //////////////////////////////////////////////////////////////
    Reinstalling VirtualBox doesn't fix it. I can run VB as root but not as my regular user. My user is a member of the vboxusers group.

    What can I try?

  2. #2
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Upgrade to 11.1 broke VirtualBox

    sgharp

    My 11.1 was a clean install from the dvd iso, but I had a permissions problem when I installed that same version of VirtualBox today, and could only run as root. I had overlooked installing kernel-source and kernel-syms packages (probably not the problem), so i installed those. Then I got this error: Failed to Create the VirtualBox COM Object

    The VirtualBox FAQ suggested reinstalling - so I did, but could still only run as root. Running in Konsole as normal user, it failed with an error that pointed me at the executable /usr/lib/virtualbox/VirtualBox, and on inspection it didn't have permissions for non-root user (i.e. Others). As root, I gave read and execute permissions to Others. It still failed to run from command line as normal user, this time with the error: Wrong owner (0) of '/tmp/.vbox-username-ipc'. This file was probably left there when I ran VirtualBox as root.

    So, I went to /tmp as root and deleted the hidden vbox file (its name will include your user name). I made sure there was nothing else left there to do with VirtualBox. Then it worked! Maybe not exactly the same as your problem - but worth a look.

  3. #3
    BasilPugfury NNTP User

    Default Re: Upgrade to 11.1 broke VirtualBox

    My VirtualBox non-OSE will not run either. I'm a member of vboxusers and I've removed the files from /tmp as su.

    This is the command line output I get when I run VirtualBox:
    /usr/bin/VirtualBox: line 72: /usr/lib/virtualbox/VirtualBox: Permission denied
    /usr/bin/VirtualBox: line 72: exec: /usr/lib/virtualbox/VirtualBox: cannot execute: Success

    I'm running openSUSE 11.1 with KDE 4.2

    Any help would be greatly apprecitated.
    Last edited by BasilPugfury; 16-Feb-2009 at 03:28. Reason: additional info

  4. #4
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Upgrade to 11.1 broke VirtualBox

    BasilPugfury

    From memory, that looks like the error (Permission denied) I experienced - my post above.

    I'm a member of vboxusers and I've removed the files from /tmp as su.
    Yes, but did you go to /usr/lib/virtualbox/VirtualBox and inspect its file permissions for Others i.e. non-root users? If it's not already set for "read" you must set it as that (you will need to be root to make the change).

  5. #5
    n-di NNTP User

    Default Re: Upgrade to 11.1 broke VirtualBox

    i have same problem and i found soulution there Sun’s VirtualBox on OpenSUSE 11.1 Bicolano Express by Ryan Yonzon
    sudo chmod +x /usr/lib/virtualbox/VirtualBox and remove /tmp/*vbox*
    it's work fine now )

  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Upgrade to 11.1 broke VirtualBox

    I had not seen that link, also useful for other potential VBox problems on 11.1. That is the neat solution, and effectively the same process as given in the above posts. I wanted the poster to do some inspection to understand the problem before fixing it.

  7. #7
    lpoch NNTP User

    Default Re: Upgrade to 11.1 broke VirtualBox

    Worked for me. Thanks!!!

  8. #8
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: Upgrade to 11.1 broke VirtualBox

    If I remember right this issue was fixed in VirtualBox 2.1.4!

  9. #9

    Default Re: Upgrade to 11.1 broke VirtualBox

    Also had the "Effective UID is not root" problem today after installing Virtual box 2 from openSUSE_BuildService_-_Virtualisation_(VirtualBox)

    So I uninstalled it, went to the VirtualBox web site and downloaded the suse 11.1 64-bit rpm.
    I installed it with rpm -ivh, it asked for a dependance: pam-devel. Installed pam-devel with yast then installed vbox3 with rpm -ivh and now everything's fine.

    I'm surprised Vbox3 retained all my preferences from vbox2 without a hitch!
    Office: 64-bit OpenSuse 12.1 KDE 4.7 nvidia with nouveau driver
    Home: 64-bit OpenSuse 12.1 KDE 4.7 ATI Audiophile2496

  10. #10
    Join Date
    Sep 2008
    Location
    Israel
    Posts
    34

    Default Re: Upgrade to 11.1 broke VirtualBox

    from Virutal Box user manual :
    The group vboxusers will be created during installation. Note that a user who is going to run VirtualBox must be member of that group. A user can be made member of the group vboxusers through the GUI user/group management or at the command line with

    sudo usermod -a -G vboxusers username

    Also note that adding an active user to that group will require that user to log out and back in again. This should be done manually after successful installation of the package.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •