Results 1 to 9 of 9

Thread: Skype fails to capture framerate (30), Unknown PCM cards

Hybrid View

  1. #1

    Default Skype fails to capture framerate (30), Unknown PCM cards

    Hi,

    Running OpenSuSe 11.1 32 bits (GNOME) new to opensuse and a newbie of 7 months in linux (previous experience with ubuntu 8.04 and 8.10).

    After installing skype and running it from the terminal I get the following messages:

    Skype V4L2: Failed to change capture framerate (30)
    ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi

    They don't seem to affect skype terribly, because I am able to use it without problems, so far.

    Anyone knows how to fix this one?

    Andres

  2. #2
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default Re: Skype fails to capture framerate (30), Unknown PCM cards

    Dou you have your sound cards configured correctly? Check yast->sound. Next try to get the latest drivers,libraries,utilities from alsa as oldcpu recomended in this thread Pulseaudio doesn't start - openSUSE Forums

  3. #3

    Default Re: Skype fails to capture framerate (30), Unknown PCM cards

    Thanks for your reply,

    This is my sound card:

    00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
    Subsystem: Hewlett-Packard Company Device 30a4
    Flags: bus master, 66MHz, slow devsel, latency 64, IRQ 17
    Memory at c0003400 (32-bit, non-prefetchable) [size=256]
    Capabilities: [40] Message Signalled Interrupts: Mask- 64bit- Count=1/1 Enable-
    Kernel driver in use: ATI IXP AC97 controller
    Kernel modules: snd-atiixp

    I checked where you told me and everything seems fine. I checked for updates to libasound2 and there was none (I currently have version 1.0.18-8.7).

    I went to Yast -> Sound -> then I enabled Pulseaudio but now I get this message when I run skype on the terminal:

    No protocol Specified

    I don't know what happened. I used skype flawlessly last night without problems (except for the output I mentioned last time).

    I'm so confused

    Andres

  4. #4
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default Re: Skype fails to capture framerate (30), Unknown PCM cards

    Well, it's better not to fix anything if things work If skype works ok despite strange warnings I wouldn't touch anything. But if I understood you correctly skype now doesn't even start?! What changes did you make before it stoped working? I would try to remove it and install it again. If you can find it in yast->software management you can reinstall from there, otherwise as root user in terminal do
    Code:
    rpm -e skype
    rpm -i skype.rpm
    where skype.rpm is the rpm installation file you downloaded.

  5. #5

    Default Re: Skype fails to capture framerate (30), Unknown PCM cards

    The only thing I did since it was working fine was to add the following line to ~/.profile

    export NSS_SHARED_DB=enabled

    This was to prevent firefox from saying that nss-shared was disabled. (I already disabled it again, to see if things got to normal).

    Then I went to Yast -> sound -> Other -> PulseAudio Configuration -> Enable

    I took this change back as well, but it still doesn't work!, it won't even open! it just says: No protocol specified

    I removed it and reinstalled it, but I got the same problem

  6. #6
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default Re: Skype fails to capture framerate (30), Unknown PCM cards

    Hm, I'm running out of ideas I would try to copy the ~/.Skype folder to some safe location and then delete it. After that reinstall skype. Maybe you can force it this way reinitialize settings. I'm not sure about this, but it's worth trying. But don't forget to backup the ~/.Skype directory.

  7. #7

    Default Re: Skype fails to capture framerate (30), Unknown PCM cards

    I reinstalled my whole OS. It works more smoothly now. I was having many problems before.

    Unfortunately skype doesn't work....I don't understand how can this be so erratic...now the problem is different: I try to make a call and I get: Problem with audio playback and I can't do anything about it. I'm getting the same message as before on the terminal:

    ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi

    I have everything installed: libasound2, I checked in Yast
    :-(

    Andres

  8. #8

    Default Re: Skype fails to capture framerate (30), Unknown PCM cards

    What a bizarre situation I have. Just after installation skype has the problem with audio playback (which I now believe it's due to pulse audio not properly managing my sound card).

    When I restart my computer and log back in, skype won't even start and on the terminal I will get:

    No protocol specified

    I've tried reinstalling even the OS, but nothing...

    Andres

  9. #9

    Default Re: Skype fails to capture framerate (30), Unknown PCM cards

    I was following instructions from: Skype HOWTO - openSUSE

    So I was using apparmor to "jail" skype. However, this was causing the: "No protocol specified" error. My skype is now working, though I still get the audio error message, but it doesn't affect its functionality as I'm using a sound device that does work.

    Andres

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •