Results 1 to 6 of 6

Thread: [B]*** nss-shared-helper warning on firefox[/B]

  1. #1

    Default [B]*** nss-shared-helper warning on firefox[/B]

    OpenSuSe 11.1 32 bits Gnome

    Hi,

    Everytime I run Firefox in the terminal I get the following message:

    *** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable)

    Should I enable this? how do I do that?

    Thanks

    Andres

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,488
    Blog Entries
    15

    Default Re: [B]*** nss-shared-helper warning on firefox[/B]

    Quote Originally Posted by acimmarusti
    OpenSuSe 11.1 32 bits Gnome

    Hi,

    Everytime I run Firefox in the terminal I get the following message:

    *** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB
    to enable)

    Should I enable this? how do I do that?

    Thanks

    Andres
    Hi
    Have no idea, do you wish to share a NSS crypto database?

    If you add the following to ~/.profile
    Code:
    export NSS_USE_SHARED_DB=enabled
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 11:53, 2 users, load average: 0.28, 0.31, 0.27
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22


  3. #3

    Default Re: [B]*** nss-shared-helper warning on firefox[/B]

    What are the pros and cons of enabling this?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,488
    Blog Entries
    15

    Default Re: [B]*** nss-shared-helper warning on firefox[/B]

    Quote Originally Posted by acimmarusti
    What are the pros and cons of enabling this?
    Hi
    Maybe a read help may help?
    Overview
    of NSS Open Source Crypto Libraries


    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 14:23, 1 user, load average: 0.31, 0.27, 0.20
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22


  5. #5

    Default Re: [B]*** nss-shared-helper warning on firefox[/B]

    I too started getting this error. I have changed nothing. I have only updated openSUSE 11.1. Enabling the environment variable does seem to fix it .. but I dont understand why I suddenly have to enable this to get thunderbird to start. (for me it wasnt just a warning but an actual fatal segmentation fault) Your link to the help text is all and good but it is over my head. One interesting thing - I set the env variable to get thunderbird to startup.. Now that it has started succesfully, I closed thunderbird, unset the env variable and it seems to start normally.... I dont get it...

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,488
    Blog Entries
    15

    Default Re: [B]*** nss-shared-helper warning on firefox[/B]

    Quote Originally Posted by mscroggi
    I too started getting this error. I have changed nothing. I have only
    updated openSUSE 11.1. Enabling the environment variable does seem to
    fix it .. but I dont understand why I suddenly have to enable this to
    get thunderbird to start. (for me it wasnt just a warning but an actual
    fatal segmentation fault) Your link to the help text is all and good but
    it is over my head. One interesting thing - I set the env variable to
    get thunderbird to startup.. Now that it has started succesfully, I
    closed thunderbird, unset the env variable and it seems to start
    normally.... I dont get it...
    Hi
    I have no idea as to why there is a requirement?? Maybe reporting it as
    a bug may help?

    Is the command your using to clear the variable clearing it?

    Use the command env to check. Else remove the command from .profile as
    a test, then open a console/konsole session and use the command export
    NSS_USE_SHARED_DB=enabled and start you application.

    Then exit your application and then close the console, open a new
    console session but don't export the variable and run your application,
    still working?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 2:25, 1 user, load average: 0.25, 0.15, 0.19
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •