I've searched and read many forum threads on the automount problems with KDE4. I must say I'm very disappointed that a mature Linux distro like SUSe still has problems with such a basic task as mounting a storage drive. Shame, shame SUSe developers.

I even installed the HAL update, hoping that would solve the problem. Noooooo.

My solution, until a real solution is found, is to disable haldaemon completely at startup with YaSt, and mount everything by hand from /etc/fstab.

Here's my /etc/fstab entries, for those that want to do the same.

/dev/sdb1 /mnt/usb vfat rw,users,uid=your_uid 0 0
/dev/fd0 /mnt/floppy vfat rw,users,uid=your_uid 0 0


From the command line in a terminal use "mount /mnt/usb".

Sometimes the old tried and true methods are the best. I'm not a fond of the dbus system. It has a lot of buggy habits. Hope this helps.