Results 1 to 3 of 3

Thread: Xen USB printer device problems with OpenSuse11.1 x64?

  1. #1
    plexs NNTP User

    Default Xen USB printer device problems with OpenSuse11.1 x64?

    Hi,

    I have some issue's getting my printer to work into Xen + Qemu environment.

    I have tryed the following tutorial but didn't worked:
    Adding USB Devices to a Xen HVM domainU Guest - Virtuatopia

    #My vm windows 2008 x64 usb part config:
    usb=1
    usbdevice='tablet'
    usbdevice='host:0000:0000'
    usbdevice='host:0000:0000'

    the adres aren't the real ones i have in my config. but i copy them from lsusb.

    it are 2 printer devices. And no detection in my windows

    Anyone have any idea where the problem is? or a way to get it fixed?

    Thanks!

    Best regards,
    plexs

  2. #2
    itwwhite NNTP User

    Default Re: Xen USB printer device problems with OpenSuse11.1 x64?

    Hi,

    I'm having the same issue did you ever get it resolved?

  3. #3
    plexs NNTP User

    Default Re: Xen USB printer device problems with OpenSuse11.1 x64?

    I think I known the issue now.
    But I'm not using OpenSuse any more

    If you got the problem with the printer.

    rmmod usblp (in your host OS)

    The problem is your host OS is using the usb printer device. So it won't work in your virtual machine from xen.

    Except when you remove the kernel module that uses it on your host os. And that's usblp

    Let me known if it works, I am not sure that it helps with this case. But I had same issue with Virtualbox and it did work there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •