Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: openSUSE updater won't install updates!

  1. #11

    Default Re: openSUSE updater won't install updates!

    Quote Originally Posted by ram88 View Post
    I've suggested which repositories to remove. Your updater problem has been answered before: openSUSE updater won't install updates! - openSUSE Forums by freedguy.
    Thanks, I misunderstood that.

    OK, when I do that I get a LOT of conflicts I need to "resolve". How do I know what choice to make on them? For example:

    Code:
    kde4-kcalc-4.1.96-43.1.i586 requires kdebase4-runtime >= 4.1.96, but this 
    requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.96-72.3.i586[OpenSUSE_KDE4]
        [ ] do not forbid installation of kdebase4-runtime-4.1.96-72.3.i586
        [ ] Ignore some dependencies of kde4-kcalc
        [ ] do not install kde4-kcalc-4.1.96-43.1.i586
    
    
    kde4-kget-4.1.96-53.8.i586 requires libplasma.so.3, but this requirement 
    cannot be provided
    uninstallable providers: libkde4-4.1.96-78.1.i586[OpenSUSE_KDE4]
        [ ] do not forbid installation of libkde4-4.1.96-78.1.i586
        [ ] do not install kde4-kget-4.1.96-53.8.i586
        [ ] Ignore some dependencies of kde4-kget
    
    
    kdebase4-session-4.1.96-29.2.i586 requires kdebase4-workspace = 4.1.96, 
    but this requirement cannot be provided
    uninstallable providers: kdebase4-workspace-4.1.96-179.1.i586[OpenSUSE_KDE4]
        [ ] do not forbid installation of kdebase4-workspace-4.1.96-179.1.i586
        [ ] do not install kdebase4-session-4.1.96-29.2.i586
        [ ] Ignore some dependencies of kdebase4-session
    
    
    kdepimlibs4-4.1.96-1.8.i586 requires kdelibs4 >= 4.1.96, but this 
    requirement cannot be provided
    uninstallable providers: kdelibs4-4.1.96-78.1.i586[OpenSUSE_KDE4]
        [ ] do not install kdepimlibs4-4.1.96-1.8.i586
        [ ] Ignore some dependencies of kdepimlibs4
        [ ] do not forbid installation of kdelibs4-4.1.96-78.1.i586
    How do I know what choice to make?

  2. #12
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: openSUSE updater won't install updates!

    Never check this:
    [ ] Ignore some dependencies of kde4-kcalc
    This:
    but this requirement cannot be provided
    means that you want to install a package what need some dependencies what cannot be provided - that can be avoided by adding some extra repositories. But be carefully!
    These packages need the KDE4.2beta repository - whatever it's working good or not, it's still unstable. So in this case (and if you don't want to upgrade to the unstable KDE) check the
    do not install kde4-kcalc-4.1.96-43.1.i586
    .
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #13

    Default Re: openSUSE updater won't install updates!

    Quote Originally Posted by ram88 View Post
    Never check this:

    This:

    means that you want to install a package what need some dependencies what cannot be provided - that can be avoided by adding some extra repositories. But be carefully!
    These packages need the KDE4.2beta repository - whatever it's working good or not, it's still unstable. So in this case (and if you don't want to upgrade to the unstable KDE) check the
    .
    Thank you VERY much for all your help.

    Now, what do I do about this one?

    Code:
    kdebase4-workspace-4.1.3-152.1.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    deleted providers: kdebase4-runtime-4.1.3-68.1.i586[@System]
    uninstallable providers: kdebase4-runtime-4.0.4-20.1.i586[openSUSE-11.0-Oss]
                       kdebase4-runtime-4.0.4-20.2.i586[openSUSE-11.0-Updates]
        [ ] Following actions will be done:
    do not install kdeartwork4-screensaver-4.1.96-24.8.i586
    deinstallation of kdebase4-openSUSE-11.0-81.43.i586
    deinstallation of powerdevil-lang-1.4.1-15.5.i586
    deinstallation of powerdevil-1.4.1-15.5.i586
    deinstallation of kdeartwork4-screensaver-4.1.3-17.33.i586
    deinstallation of compiz-kde4-0.7.4-31.2.i586    [ ] Ignore some dependencies of kdebase4-workspace
        [ ] do not forbid installation of kdebase4-workspace-ksysguardd-4.1.96-179.1.i586
    It says it will uninstall kdebase4-openSUSE-11.0-81.43.i586!! Doesn't that mean uninstalling my KDE/OpenSUSE?

  4. #14
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: openSUSE updater won't install updates!

    Maybe your repositories are a bit confused. Go to Konsole, and do what caf4926 suggested:
    Code:
    su
    zypper clean
    zypper refresh
    Now start the repository manager.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  5. #15

    Default Re: openSUSE updater won't install updates!

    Quote Originally Posted by ram88 View Post
    Maybe your repositories are a bit confused. Go to Konsole, and do what caf4926 suggested:
    Code:
    su
    zypper clean
    zypper refresh
    Now start the repository manager.
    Thanks again for your help, sorry for being such a newbie here...


    OK, one more. Now it's saying:

    Code:
    alsa-driver-kmp-default-1.0.16.20081010_2.6.25.5_1.1-2.1.i586 requires kernel(default:sound_i2c_other) = 46aadddff3ca786f, but this requirement cannot be provided
    uninstallable providers: kernel-default-2.6.25.5-1.1.i586[openSUSE-11.0-Oss]
                       kernel-default-2.6.25.9-0.2.i586[openSUSE-11.0-Updates]
                       kernel-default-2.6.25.11-0.1.i586[openSUSE-11.0-Updates]
                       kernel-default-2.6.25.16-0.1.i586[openSUSE-11.0-Updates]
        [ ] deinstallation of alsa-driver-kmp-default-1.0.16.20081010_2.6.25.5_1.1-2.1.i586
        [ ] do not install kernel-default-2.6.25.20-0.1.i586
        [ ] Ignore some dependencies of alsa-driver-kmp-default
    With most of the others I assume just choose "do not install" but here, don't I want the new kernel?

    I currently have: Linux 2.6.25.18-0.2-default i686. So wouldn't that be an upgrade? What should I choose?

  6. #16
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: openSUSE updater won't install updates!

    Quote Originally Posted by 6tr6tr View Post
    Thanks again for your help, sorry for being such a newbie here...


    OK, one more. Now it's saying:

    Code:
    alsa-driver-kmp-default-1.0.16.20081010_2.6.25.5_1.1-2.1.i586 requires kernel(default:sound_i2c_other) = 46aadddff3ca786f, but this requirement cannot be provided
    uninstallable providers: kernel-default-2.6.25.5-1.1.i586[openSUSE-11.0-Oss]
                       kernel-default-2.6.25.9-0.2.i586[openSUSE-11.0-Updates]
                       kernel-default-2.6.25.11-0.1.i586[openSUSE-11.0-Updates]
                       kernel-default-2.6.25.16-0.1.i586[openSUSE-11.0-Updates]
        [ ] deinstallation of alsa-driver-kmp-default-1.0.16.20081010_2.6.25.5_1.1-2.1.i586
        [ ] do not install kernel-default-2.6.25.20-0.1.i586
        [ ] Ignore some dependencies of alsa-driver-kmp-default
    With most of the others I assume just choose "do not install" but here, don't I want the new kernel?

    I currently have: Linux 2.6.25.18-0.2-default i686. So wouldn't that be an upgrade? What should I choose?
    You need to uninstall
    alsa-driver-kmp-default-1.0.16.20081010_2.6.25.5_1.1-2.1.i586
    if you can't provide matching version of this package for the new kernel. From which repository is the alsa-kmp and why are you installed, is it need for anything?

    ps.:
    sorry for being such a newbie here...
    please, do not sorry. You want to learn.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  7. #17

    Default Re: openSUSE updater won't install updates!

    Quote Originally Posted by ram88 View Post
    You need to uninstall

    if you can't provide matching version of this package for the new kernel. From which repository is the alsa-kmp and why are you installed, is it need for anything?
    How do I find out which repository alsa is from?

    The reason I need Alsa (not sure if I need that version) is because I was unable to get sound without it. I couldn't get sound on my USB headset otherwise.

    If I uninstall that, will it uninstall all Alsa programs in the OS or just that version?

  8. #18
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: openSUSE updater won't install updates!

    Quote Originally Posted by 6tr6tr View Post
    How do I find out which repository alsa is from?

    The reason I need Alsa (not sure if I need that version) is because I was unable to get sound without it. I couldn't get sound on my USB headset otherwise.

    If I uninstall that, will it uninstall all Alsa programs in the OS or just that version?
    Select the alsa-kmp package in YaST > Software Management and select the Versions tab.
    It'll show if any other package need to be deleted.
    Before the final installation you can do a last-time-check by selecting Installation Summary for filter. Here you can see what will be deleted (X), and what will be installed.
    If you delete the alsa-kmp package I think you'll stay without headphone sound.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  9. #19

    Default Re: openSUSE updater won't install updates!

    Quote Originally Posted by ram88 View Post
    Select the alsa-kmp package in YaST > Software Management and select the Versions tab.
    It'll show if any other package need to be deleted.
    Before the final installation you can do a last-time-check by selecting Installation Summary for filter. Here you can see what will be deleted (X), and what will be installed.
    If you delete the alsa-kmp package I think you'll stay without headphone sound.
    Thanks. What's the danger of choosing "ignore some dependencies"?

  10. #20
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: openSUSE updater won't install updates!

    Quote Originally Posted by 6tr6tr View Post
    Thanks. What's the danger of choosing "ignore some dependencies"?
    It leads to crashes / errors. The packages are constantly changing, some feature being removed others implemented, etc. etc. This is why the packages have dependencies - to determinate which other packages are compatible.
    Are you updated the kernel and solved the package conflicts?
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •