After help from the forum, specifically some-guy, I can now enable compiz with compiz-manager - -replace command issue in a terminal after the startup of my computer. Note that at the startup I get compiz as the session manager and on the main panel I have four desktop lined up and the terminal is neither movable nor resizable and therefore pretty difficult to work with. The compiz-mager - - replace command makes everything enjoyable. HOWEVER, I have this big problem.

The compiz-manager program works only 60% of the time. In the rest 40% cases the command makes the computer crash and I have to restart the computer. Sometimes, specially after a few successful starts with compiz-manager - - replace, the situation becomes so bad that I must re-start the computer in failsafe mode and stratx from there. I will greatly appreciate help about how to overcome this problem. Following are given to help in resolution of the problem.

Here is the output of compiz-manager replace.

Checking for Xgl: present.

Checking for nVidia: not present.

Checking for Xgl: present.

Enabling Xgl with nVidia drivers...

Enabling Xgl with fglrx ATi drivers...

/usr/bin/compiz: Trying '/usr/$LIB/libIndirectGL.so.1'

* Detected Session: kde

* Searching for installed applications...

* Non-mesa driver on Xgl detected

... no mesa libGL found for preloading, this may not work!

* Using the GTK Interface

A handler is already registered for the path starting with path[0] = "org"

A handler is already registered for the path starting with path[0] = "org"

A handler is already registered for the path starting with path[0] = "org"

A handler is already registered for the path starting with path[0] = "org"

Also, when the computer starts-up the system monitor shows that compiz process. After running compiz-manager replace, the system monitor shows that there are two instances of compiz-manager. This is confirmed by the following out put of ps ax | grep compiz
~ 1001: ps ax |grep compiz

4882 pts/0 S+ 0:00 /bin/sh /usr/bin/compiz-manager --replace

4893 pts/0 S+ 0:00 /bin/sh /usr/bin/compiz-manager --replace

4894 pts/0 S+ 0:03 /usr/bin/compiz --ignore-desktop-hints --replace ccp --no-libgl-fallback

5219 pts/1 S+ 0:00 grep compiz

~ 1002:

Here are other system details:

My computer system runs under SUSE 10.3 x86_64, the Linux kernel is Linux opteron 2.6.22.19-0.1-default #1 SMP 2008-10-14 22:17:43 +0200 x86_64 x86_64 x86_64 GNU/Linux. It uses Kde 3.5.7 "release 72.11". I have Nvidia GE Force 7600 Gb with 1920x1200 (XUXGA) . The diver was installed following the instruction given at OpenSUSE 10.3 website and just before compiz installation the driver was updated so that it has composite enabled. This was done because it was a must according the installation instructions on SUSE website. The kde session manager is set to use compiz and the /etc/sysconfig has Xorg. There is now no mention of glx in xorg.conf. The etc/sysconfig/displaymanger too has no mention of xgl excepting that there is lineDISPLAYMANAGER_XGL_OPTS="-accel xv:buffer"
rather than -accel glx:buffer. The DISPLAYMANAGER is also set to kdm rather than xgl.

The rpm search shows that I have these compiz and fusion related packages installed. It has the newer Mesa libs also installed (Mesa-devel-7.0.1-18
; Mesa-7.0.1-18
; Mesa-32bit-7.0.1-18 as revealed by rpm -qa |grep Mesa).
LIST OF compiz & fusion related installs is as follows:
rpm -qa |grep compiz
compiz-emerald-themes-0.5.2-6
compiz-0.7.6-25.1
compizconfig-settings-manager-0.7.6-2.1
libcompizconfig-0.7.6-2.1
compiz-fusion-plugins-main-0.7.6-3.1
compiz-kde-0.7.6-25.1
python-compizconfig-0.7.6-2.1
compiz-emerald-0.7.6-2.1
compiz-gnome-0.7.6-25.1
compiz-manager-0.0.1_git080201-24.1
~ 1005: rpm -qa |grep fusion
compiz-fusion-plugins-main-0.7.6-3.1
fusion-icon-0.0.1_080201-3.1