Results 1 to 4 of 4

Thread: problems with video players

  1. #1
    Join Date
    Jan 2009
    Location
    vijayawada, India
    Posts
    24

    Question problems with video players

    hello, i am using SUSE 11.0, KDE 4.0 ,i had installed "Totem movie player, vlc media player,real player"
    totem and VLC are able to play .avi format movies.
    when i click on *.avi files, they are opening, immediately the window of player vanishes(i.e. they are closing without playing ). Same *.avi files are playing well in windows XP.

  2. #2

    Default Re: problems with video players

    Here are my suggestions:
    1. Make sure you don't have vlc repository enabled.
    2. If you have any packages installed from vlc repository, replace them with the ones from packman repository.
    3. Make sure you have w32codec-all package installed
    4. If none of the above given suggestions fixes the issue, try installing smplayer or mplayer and see if the video plays in them.

    All the suggestions listed above can be achieved from YaST->"Software Management"

    good luck!

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: problems with video players

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: problems with video players

    Well, I tell you how:

    1)
    As general rule, install -always- pm versions, it means packmann, even if the version is lower.
    Now:
    - keep the vlc repo open, that is a great player. From there add also libdvdcss, necessary to play DVDs
    - Install also Xine and Xine ui in packman version, perhaps you will need some changes in your packages to satisfy the dependencies. From there install also w32codec-all, mplayer and smplayer, a great front-end for mplayer. Note: Xine, MPlayer and VCL are separate players each one with own and separate codecs.

    2)
    Depending from your system, software, running compiz or not and so on, you will need to configure your video output, because linux has at this subject many different interfaces. Here an easy and fast way: open smplayer and select a movie, it doesn't matter if you don't see anything, the movie must be just running. Select options-preferences and from there Video. Under "Output driver" are listed all valuables interfaces. Keeping the movie running, select each time a different driver, push the button apply and without closing the window check if behind you see the movie. I get the best quality by X11(slow), but is really slow, what means that I get dropped frames by scenes with fast movement or much audio. You can adjust that in options- performances- cache. Try just 4 times the given value and 4000 for DVD. It should work.

    3) Apply the same adjustment or another one witch you now as working by the other players. The nomenclature is always different, so, buffer instead cache or amount of kept frames, but now that is easy to guess.

    Let me know and have fun!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •