Results 1 to 9 of 9

Thread: Vbox kernel driver....

  1. #1
    Join Date
    Jun 2008
    Location
    Miami, FL
    Posts
    68

    Default Vbox kernel driver....

    I ran
    Code:
    /etc/init.d/vboxdrv setup
    and the vbox kernel driver compiled and runs fine. Until I reboot and then I get this.



    It seems to have forgotten the settings or something. I have to recompile the driver after every reboot... any ideas?


    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Vbox kernel driver....

    Quote Originally Posted by mejason69 View Post
    I ran
    Code:
    /etc/init.d/vboxdrv setup
    and the vbox kernel driver compiled and runs fine. Until I reboot and then I get this.



    It seems to have forgotten the settings or something. I have to recompile the driver after every reboot... any ideas?


    thanks
    Is your user added to the vboxusers group?
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3
    Join Date
    Jun 2008
    Location
    Miami, FL
    Posts
    68

    Default Re: Vbox kernel driver....

    Yes, like I said it runs fine after the kernel recompile.

    If the user wasn't added then it wouldn't start at all.

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Vbox kernel driver....

    Probably the vboxdrv module isn't set to load at boot. Do this:

    Code:
    chkconfig vboxdrv
    If it says off, then it's not set to load on boot. So do this:

    Code:
    chkconfig --set vboxdrv on
    This should also be possible from YaST > System Services

  5. #5
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Vbox kernel driver....

    Quote Originally Posted by mejason69 View Post
    Yes, like I said it runs fine after the kernel recompile.

    If the user wasn't added then it wouldn't start at all.
    Sorry, the error messages said that there is a permission problem. This is why i thought you are not in the vboxusers group.
    Is your vboxdrv module set to start in runlevel 5? Check in YaST.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  6. #6
    Join Date
    Jun 2008
    Location
    Miami, FL
    Posts
    68

    Default Re: Vbox kernel driver....

    Please see screenshot


    chkconfig vboxdrv already set to ON.

    set to start in runlevel 5


    Any other ideas, If I restart the service it works fine. I don't have to recompile. Thats some progress at least.

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Vbox kernel driver....

    Only thing I can think of is to watch the console when booting up to see why vboxdrv fails to start. You may have to switch to VT1 with Ctrl-Alt-F1 when KDE kicks in. Also the boot log is in /var/log/boot.msg.

  8. #8
    Join Date
    Jun 2008
    Location
    Miami, FL
    Posts
    68

    Default Re: Vbox kernel driver....

    Yeah I few items that should start with run level 5 do not start

    vboxdrv,sbm,smbfs,cups and a few others.....


    no clue why they don't... frustrating!

    Below make sense to anyone??


    Code:
    NIT: Entering runlevel: 5
    
    
    
    Boot logging started on /dev/tty1(/dev/console) at Tue Jan 20 22:08:29 2009
    
    Master Resource Control: previous runlevel: N, switching to runlevel: 5
    <notice>startproc: execve (/sbin/acpid) [ /sbin/acpid ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 SHELL=/bin/sh TERM=linux ROOTFS_FSCK=0 LC_ALL=POSIX INIT_VERSION=sysvinit-2.86 REDIRECT=/dev/tty1 COLUMNS=156 PATH=/bin:/sbin:/usr/bin:/usr/sbin vga=0x31a DO_CONFIRM= RUNLEVEL=5 PWD=/ SPLASHCFG=/etc/bootsplash/themes/openSUSE/config/bootsplash-1280x1024.cfg PREVLEVEL=N LINES=60 HOME=/ SHLVL=2 splash=silent SPLASH=yes ROOTFS_BLKDEV=/dev/disk/by-id/ata-Maxtor_6H500F0_H805FN0H-part6 _=/sbin/startproc DAEMON=/sbin/acpid ]
    acpid: starting up
    
    
    Starting acpid done
    Initializing random number generatordone
    acpid: 2 rules loaded
    
    
    <notice>startproc: execve (/sbin/syslog-ng) [ /sbin/syslog-ng ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 TERM=linux SHELL=/bin/sh ROOTFS_FSCK=0 LC_ALL=POSIX INIT_VERSION=sysvinit-2.86 REDIRECT=/dev/tty1 COLUMNS=156 PATH=/bin:/sbin:/usr/bin:/usr/sbin DO_CONFIRM= vga=0x31a RUNLEVEL=5 SPLASHCFG=/etc/bootsplash/themes/openSUSE/config/bootsplash-1280x1024.cfg PWD=/ PREVLEVEL=N LINES=60 SHLVL=2 HOME=/ SPLASH=yes splash=silent ROOTFS_BLKDEV=/dev/disk/by-id/ata-Maxtor_6H500F0_H805FN0H-part6 _=/sbin/startproc DAEMON=/sbin/syslog-ng ]
    <notice>startproc: execve (/sbin/klogd) [ /sbin/klogd -c 1 -x ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 TERM=linux SHELL=/bin/sh ROOTFS_FSCK=0 LC_ALL=POSIX INIT_VERSION=sysvinit-2.86 REDIRECT=/dev/tty1 COLUMNS=156 PATH=/bin:/sbin:/usr/bin:/usr/sbin DO_CONFIRM= vga=0x31a RUNLEVEL=5 SPLASHCFG=/etc/bootsplash/themes/openSUSE/config/bootsplash-1280x1024.cfg PWD=/ PREVLEVEL=N LINES=60 SHLVL=2 HOME=/ SPLASH=yes splash=silent ROOTFS_BLKDEV=/dev/disk/by-id/ata-Maxtor_6H500F0_H805FN0H-part6 _=/sbin/startproc DAEMON=/sbin/klogd ]
    Starting syslog servicesdone
    Checking/updating CPU microcode done
    Starting D-Bus daemondone
    Starting Firewall Initialization (phase 1 of 2) done
    Loading CPUFreq modules (CPUFreq not supported)
    Starting HAL daemondone
    <notice>killproc: kill(2141,20)
    <notice>killproc: kill(2158,1)
    <notice>killproc: kill(2141,18)
    <notice>killproc: kill(2141,12)
    Setting up (localfs) network interfaces:
        lo        
        lo        IP address: 127.0.0.1/8   
                  IP address: 127.0.0.2/8   
    done    eth0      device: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
        eth0      Starting DHCP4 client.  
        eth0      IP address: 192.168.1.100/24 (Jason-PC)
    doneSetting up service (localfs) network  .  .  .  .  .  .  .  .  .  .done
    <notice>startproc: execve (/usr/bin/kdm) [ /usr/bin/kdm ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 TERM=linux SHELL=/bin/sh ROOTFS_FSCK=0 INIT_VERSION=sysvinit-2.86 KDEROOTHOME=/root/.kdm REDIRECT=/dev/tty1 COLUMNS=156 PATH=/bin:/sbin:/usr/bin:/usr/sbin DO_CONFIRM= vga=0x31a RUNLEVEL=5 SPLASHCFG=/etc/bootsplash/themes/openSUSE/config/bootsplash-1280x1024.cfg PWD=/ LANG=en_US.UTF-8 PREVLEVEL=N LINES=60 QT_SYSTEM_DIR=/usr/share/desktop-data SHLVL=2 HOME=/ XCURSOR_THEME=DMZ WINDOWMANAGER=/usr/bin/startkde SPLASH=yes splash=silent ROOTFS_BLKDEV=/dev/disk/by-id/ata-Maxtor_6H500F0_H805FN0H-part6 _=/sbin/startproc DAEMON=/usr/bin/kdm ]
    Starting service kdmdone
    <notice>startproc: execve (/usr/sbin/nmbd) [ /usr/sbin/nmbd -D -s /etc/samba/smb.conf ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 SHELL=/bin/sh TERM=linux ROOTFS_FSCK=0 LC_ALL=POSIX INIT_VERSION=sysvinit-2.86 REDIRECT=/dev/tty1 COLUMNS=156 PATH=/bin:/sbin:/usr/bin:/usr/sbin vga=0x31a DO_CONFIRM= RUNLEVEL=5 PWD=/ SPLASHCFG=/etc/bootsplash/themes/openSUSE/config/bootsplash-1280x1024.cfg PREVLEVEL=N LINES=60 HOME=/ SHLVL=2 splash=silent SPLASH=yes ROOTFS_BLKDEV=/dev/disk/by-id/ata-Maxtor_6H500F0_H805FN0H-part6 _=/sbin/startproc DAEMON=/usr/sbin/nmbd ]
    Starting Samba NMB daemon done
    <notice>startproc: execve (/sbin/rpcbind) [ /sbin/rpcbind ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 SHELL=/bin/sh TERM=linux ROOTFS_FSCK=0 LC_ALL=POSIX INIT_VERSION=sysvinit-2.86 REDIRECT=/dev/tty1 COLUMNS=156 PATH=/bin:/sbin:/usr/bin:/usr/sbin vga=0x31a DO_CONFIRM= RUNLEVEL=5 PWD=/ SPLASHCFG=/etc/bootsplash/themes/openSUSE/config/bootsplash-1280x1024.cfg PREVLEVEL=N LINES=60 HOME=/ SHLVL=2 splash=silent SPLASH=yes ROOTFS_BLKDEV=/dev/disk/by-id/ata-Maxtor_6H500F0_H805FN0H-part6 _=/sbin/startproc DAEMON=/sbin/rpcbind ]
    Starting rpcbind done
    Not starting NFS client services - no NFS found in /etc/fstab:unused
    Mount CIFS File Systems unused
    Starting jexec services<notice>checkproc: /usr/sbin/nmbd 3232
    <notice>checkproc: /usr/sbin/nmbd 3232
    <notice>killproc: kill(3232,15)
    <notice>startproc: execve (/usr/sbin/nmbd) [ /usr/sbin/nmbd -D -s /etc/samba/smb.conf ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 TERM=linux SHELL=/bin/sh ROOTFS_FSCK=0 LC_ALL=POSIX new_netbios_scope= INIT_VERSION=sysvinit-2.86 reason=RENEW SAMBA_DHCP_CONF_INFO_FILE=/var/adm/fillup-templates/samba-client-dhcp.conf DONT_USE_SYSLOG=no REDIRECT=/dev/tty1 INTERFACETYPE=eth COLUMNS=156 PATH=/sbin:/usr/sbin:/bin/:/usr/bin DO_CONFIRM= vga=0x31a old_netbios_scope= RUNLEVEL=5 SPLASHCFG=/etc/bootsplash/themes/openSUSE/config/bootsplash-1280x1024.cfg PWD=/etc/sysconfig/network LANG=POSIX new_netbios_name_servers=   PREVLEVEL=N LINES=60 SHLVL=11 HOME=/ SPLASH=yes splash=silent ROOTFS_BLKDEV=/dev/disk/by-id/ata-Maxtor_6H500F0_H805FN0H-part6 _=/sbin/startproc DAEMON=/usr/sbin/nmbd ]
    <notice>checkproc: /usr/sbin/nmbd 3262
    <notice>checkproc: /usr/bin/kdm 3073
    <notice>checkproc: /sbin/acpid 2110
    <notice>checkproc: /bin/dbus-daemon 2169
    <notice>checkproc: /sbin/klogd 2141
    <notice>checkproc: /sbin/syslog-ng 2158
    <notice>checkproc: /usr/bin/kdm 3073
    <notice>checkproc: /usr/sbin/hald 2447
    <notice>checkproc: /sbin/rpcbind 3214
    <notice>checkproc: /usr/sbin/nmbd 3262
    <notice>checkproc: /sbin/udevd 674
    <notice>checkproc: /sbin/rpcbind 3214
    <notice>checkproc: /sbin/klogd 2141
    <notice>checkproc: /sbin/syslog-ng 2158
    <notice>checkproc: /usr/bin/kdm 3073
    <notice>checkproc: /sbin/acpid 2110
    <notice>checkproc: /bin/dbus-daemon 2169
    <notice>checkproc: /sbin/klogd 2141
    <notice>checkproc: /sbin/syslog-ng 2158
    <notice>checkproc: /usr/bin/kdm 3073
    <notice>checkproc: /usr/sbin/hald 2447
    <notice>checkproc: /sbin/rpcbind 3214
    <notice>checkproc: /usr/sbin/nmbd 3262
    <notice>checkproc: /sbin/rpcbind 3214
    <notice>checkproc: /sbin/klogd 2141
    <notice>checkproc: /sbin/syslog-ng 2158
    <notice>checkproc: /usr/bin/kdm 3073
    <notice>checkproc: /sbin/udevd 674

  9. #9
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Vbox kernel driver....

    That's not good. vboxdrv depends on syslog. Is syslog or syslog-ng enabled and running? Is syslog started early in the order?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •