Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Postfix Helo Error

  1. #1

    Question Postfix Helo Error

    Hi I was hoping someone could help me sent up a Postfix email server on Opensuse 10.3. I have been trying to send emails (receiving emails is fine), but they just stay in the queue. I looked at /var/log/mail and found this error:

    status=deferred (lost connection with "receving server" while performing the HELO handshake)

    Does anyone know what that means? The server was working fine a few days ago. Please let me know if you can help, thanks.

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Postfix Helo Error

    On 01/19/2009 wraith 86 wrote:
    > lost connection with "receving server" while performing the HELO
    > handshake


    Wild guess: Your IP is blacklisted.
    Other than that, you should really give us more information: Does it happen for all sending attempts toall domains? Post more logfile content, please.

    Uwe

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Postfix Helo Error

    Are you on a dynamic IP address provided by your ISP? Lots of recipients refuse to accept direct connections from dynamic addresses because they are usually home PCs infected wiht spambots. The dynamic address range your connection is in could have been blacklisted recently. The right way to do it is to relay through your ISP's SMTP server.

  4. #4

    Default Re: Postfix Helo Error

    It's only when I am attempting to send emails to one specific server, other servers like Gmail and Hotmail receive the emails fine. That was the only piece of information I could find concerning the problem. I went through all the mail logs in /var/log/mail and that was the only error msg I could find. I did notice that when I did send emails to Gmail and Hotmail they ended up in the spam folder. Not sure if that helps.

    Also it's a static IP connection through my router

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Postfix Helo Error

    If you have a non-business broadband connection, even a static IP address could be in the blacklisted range.

  6. #6
    Join Date
    Oct 2008
    Location
    Birmingham. AL
    Posts
    851

    Default Re: Postfix Helo Error

    Don't overlook the possibility that the receiver is down or having problems, either (especially if it's a small ISP or a private server). Have you contacted them?

    When my Scalix server gets really busy -- typically on a Monday morning when everyone wants to check the mail at the same time -- it will time out, break connections, or even outright refuse them.

  7. #7
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Postfix Helo Error

    * wraith 86

    on the postfix box, try sending a mail to that domain via telnet. You should see errors.
    http://evolvedcode.net/content/doc_a...t/index_p5.asp

    Uwe

  8. #8

    Default Re: Postfix Helo Error

    When I tried to send an email through telnet I received this error: 550 RBL rejection: http://www.spamhaus.org/query/bl?ip=###.###.##.## (My routers IP). Could this be because my MX record in my DNS is setup incorrectly?

  9. #9
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Postfix Helo Error

    No, they just don't like your IP address for the reasons already mentioned.

  10. #10

    Default Re: Postfix Helo Error

    That is pretty strange, because last week it was working fine. If they had blacklisted my IP address I thought that I wouldn't be able to telnet to the server either?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •