Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Wuala file system integration

  1. #1
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    137

    Default Wuala file system integration

    Hi,

    I'm trying to get the FIS from wuala going on my Opensuse 11.1 system. It ran fine on 11.0...
    It seems as if the nfs integration wouldn't work...
    Code:
    reg@desktop-reg:~> sudo /etc/init.d/nfs start
    Not starting NFS client services - no NFS found in /etc/fstab: unused
    but remember my fstab says:
    "localhost:/wuala /home/reg/wuala/direct nfs defaults,users,noauto,rsize=8192,wsize=8192,timeo=14,intr,nolock,soft"
    Any clue(s) what could be happening here? In my fstab I got this:localhost:/wuala /home/reg/wuala/direct nfs defaults,users,noauto,rsize=8192,wsize=8192,timeo=14,intr,nolock,soft

    I have portmap installed too.... there's been a discussion going on in the Wuala forum and people there don't seem to be able to help me, the link is: Could not upload file

    I would really appreciate if anyone was able to help me!

    Thank you tons,
    Ron

  2. #2
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    137

    Default Re: Wuala file system integration

    Hm, anyone?

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Wuala file system integration

    The lines that test whether your fstab has a nfs mount are these:

    Code:
    while read  what where type options rest  ; do
        case "$what" in
            \#*|"")     continue ;;
        esac
        case ",$options," in
            *,noauto,*) continue ;;
        esac
        case "$type" in
            nfs|nfs4)   ;;
            *)          continue ;;
        esac
        nfs=yes
        if test "$1" = status ; then
            grep -qE "^$what[[:blank:]]+$where[[:blank:]]+nfs" /proc/mounts && continue
            state=3
            continue
        fi
        case "$where" in
            /usr*)
                usr="${usr:+$usr }$where"
                NEED_LDCONFIG=yes
                ;;
            /opt*)
                opt="${opt:+$opt }$where"
                NEED_LDCONFIG=yes
                ;;
            *)
                mnt="${mnt:+$mnt }$where"
                test "$NEED_LDCONFIG" = yes        && continue
                grep -qE "^$where" /etc/ld.so.conf || continue
                NEED_LDCONFIG=yes
                ;;
        esac
    done < /etc/fstab
    I don't see anything wrong with your fstab, but somehow nfs still remains at "no" after the loop, so the case start-no was run, which prints that message. Two things you could try. One is to run the init script with -vx to show you the statements executed. Like this:

    Code:
    # sh -vx /etc/init.d/nfs start
    That will tell you if the line was correctly read. Is there a possibility it contains some junk characters or isn't properly terminated with a newline?

    The other is to try to mount the nfs from the command like with:

    Code:
    # mount -a -t nfs
    That will tell you if mount is seeing that nfs line.

  4. #4
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    137

    Default Re: Wuala file system integration

    Quote Originally Posted by ken_yap View Post
    The lines that test whether your fstab has a nfs mount are these:

    *snip*

    I don't see anything wrong with your fstab, but somehow nfs still remains at "no" after the loop, so the case start-no was run, which prints that message. Two things you could try. One is to run the init script with -vx to show you the statements executed. Like this:

    Code:
    # sh -vx /etc/init.d/nfs start
    That will tell you if the line was correctly read. Is there a possibility it contains some junk characters or isn't properly terminated with a newline?

    The other is to try to mount the nfs from the command like with:

    Code:
    # mount -a -t nfs
    That will tell you if mount is seeing that nfs line.
    I don't quite get what I should read from
    Code:
    # sh -vx /etc/init.d/nfs start
    the last few lines printed look like this:
    Code:
    + case "$1-$nfs" in                                                                 
    + /usr/sbin/sm-notify                                                               
    + echo -n 'Not starting NFS client services - no NFS found in /etc/fstab:'          
    Not starting NFS client services - no NFS found in /etc/fstab:+ rc_status -u        
    + rc_check                                                                          
    + _rc_status_ret=0
    + test 0 -eq 0
    + test 0 -eq 0
    + return 0
    + test 0 -gt 7
    + _rc_status_ret=0
    + case "$_rc_todo" in
    + local i
    + for i in '"$@"'
    + case "$i" in
    + echo -e '                                                                                                          unused'
                                                                                                                         unused
    + rc_failed 6
    + rc_reset
    + _rc_status=0
    + _rc_status_all=0
    + rc_check
    + _rc_status_ret=0
    + test 0 -eq 0
    + test 0 -eq 0
    + return 0
    + return 0
    + case "$1" in
    + _rc_status=6
    + rc_check
    + _rc_status_ret=0
    + test 0 -eq 0
    + test 6 -eq 0
    + _rc_status_all=6
    + return 0
    + return 6
    + return 0
    rc_exit
    + rc_exit
    + exit 6
    This doesn't say anything tio me...does it to you?
    There shouldn't be any chunck in my fstab nfs line as i just completely retyped it manually - just to be sure...
    I got no clue what's going wrong....I'd appreciate your continuing help! Thank you!
    Ron

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Wuala file system integration

    No, much earlier, in the loop where it reads the lines from fstab and then checks the type field of each line. You should see it doing:

    nfs=no

    and then when it gets to your line it should detect the nfs type and do

    nfs=yes

    My guess is for one reason or another, that line isn't recognised, so nfs stays at no.

    Another reason might be some stray spaces. There should be no space between localhost: and /, also the path should contain no spaces.

  6. #6
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    137

    Default Re: Wuala file system integration

    The fstab line looks like this:
    localhost:/wuala /home/reg/wuala/direct nfs defaults,users,noauto,rsize=8192,wsize=8192,timeo=14,intr,nolock,soft
    and all i see in the output is:

    nfs=no
    + nfs=no

    here's the whole output of the command:
    sh -vx /etc/init.d/nfs start


    Thanks again for your help!
    Ron

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Wuala file system integration

    For some reason the nfs line is not recognised. Please post /etc/fstab. Preferably don't paste it, but wrap it in a zip or tar archive so that I can check for any illegal characters.

    Or if you prefer to debug this yourself, edit /etc/init.d/nfs and add this bolded line after the read around line 43:

    Code:
    while read  what where type options rest  ; do
      echo "$what|$where|$type|$options|$rest"
      case "$what" in
    Then run /etc/init.d/nfs start. Forget about the sh -vx this time, nothing more to be discovered from that. Post the outputs of that echo statement.

  8. #8
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    137

    Default Re: Wuala file system integration

    Quote Originally Posted by ken_yap View Post
    For some reason the nfs line is not recognised. Please post /etc/fstab. Preferably don't paste it, but wrap it in a zip or tar archive so that I can check for any illegal characters.

    Or if you prefer to debug this yourself, edit /etc/init.d/nfs and add this bolded line after the read around line 43:

    Code:
    while read  what where type options rest  ; do
      echo "$what|$where|$type|$options|$rest"
      case "$what" in
    Then run /etc/init.d/nfs start. Forget about the sh -vx this time, nothing more to be discovered from that. Post the outputs of that echo statement.
    My fstab is right here.

    Thanks dude for looking into this for me!

    Ron

  9. #9
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Wuala file system integration

    Ahhhhh...

    The reason is simple. See these lines in the script?

    Code:
       case ",$options," in
            *,noauto,*) continue ;;
       esac
    That says: if noauto is in the options, then disregard this fstab line. Since you have specified that your nfs mount is not to be mounted automatically, it was ignored. Take out the noauto and it should mount at boot.

  10. #10
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    137

    Default Re: Wuala file system integration

    k, noauto removed and now i get this:
    Code:
    desktop-reg:/home/reg # mount -a
    mount.nfs: mount to NFS server 'localhost:/wuala' failed: RPC Error: Program not registered
    What the heck does this mean?

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •