Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Setting up vsftpd?

  1. #1

    Default Setting up vsftpd?

    Hi, I want to share some files on the LAN with a windows user, so I thought ftp would be easiest.

    I downloaded vsftpd and system-config-vsftpd, so that I could set it up in an UI.

    But how do I start it?

    Getting this error.

    linux-vu9d:/home/lasse # system-config-vsftpd
    /usr/lib/python2.6/site-packages/gtk-2.0/gtk/__init__.py:72: GtkWarning: could not open display
    warnings.warn(str(e), _gtk.Warning)
    /usr/share/system-config-vsftpd/main.py:69: GtkWarning: cannot open display:
    gnome.init("system-config-vsftpd", "1.0")

  2. #2
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: Setting up vsftpd?

    Have a read here

    /Geoff
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  3. #3

    Default Re: Setting up vsftpd?

    That is commandline, I really wanted to go graphical...

    I get into trouble with the guide there when I have to edit vsftpd.conf, I can't get the rights to edit it.

    /etc/vsftpd.conf

    How do I open it? I tried via terminal.

    Code:
    linux-vu9d:/home/lasse # kdesu kwrite /etc/vsftpd.conf
    kdesu: cannot connect to X server

  4. #4

    Default Re: Setting up vsftpd?

    Went over to proftpd as I have used that before, however, I get the same message there when I try to edit a file.

  5. #5
    Join Date
    Jan 2009
    Location
    Toronto, Ontario
    Posts
    188

    Default Re: Setting up vsftpd?

    I know this may be a dumb question but can we confirm that X up and running on the machine?

    The reason I ask is that I've run into this type of message before but usually only when either I'm at run level 3 (i.e., no X running) or when I'm ssh'ed into another machine and forgot to pass the -X flag to ssh when I connected. The -X tells ssh to forward X connections to my local machine.

  6. #6

    Default Re: Setting up vsftpd?

    lasse@linux-vu9d:/etc> startx
    xauth: creating new authority file /home/lasse/.serverauth.19479


    Fatal server error:
    Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.

  7. #7

    Default Re: Setting up vsftpd?

    Used kdesu kwrite instead. No issues at the moment

  8. #8
    Join Date
    Jan 2009
    Location
    Toronto, Ontario
    Posts
    188

    Default Re: Setting up vsftpd?

    Humm, any thing interesting (errors, warnings?) in /var/log/Xorg.0.log?

  9. #9

    Default Re: Setting up vsftpd?


  10. #10

    Default Re: Setting up vsftpd?

    Getting it again now :S

    linux-vu9d:/home/lasse # kdesu kwrite /etc/shells
    kdesu: cannot connect to X server

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •