Results 1 to 7 of 7

Thread: OpenSuse 11.1+Tekram 310U PCI scsi + scaner - only root can

  1. #1
    clintgengar NNTP User

    Default OpenSuse 11.1+Tekram 310U PCI scsi + scaner - only root can

    Hi,

    I'd like to welcome everyone because I'm beginner here. As going straight to the point my problem is with film scanner CanoScan FS4000US + scsi controller Tekram 310U and Suse 11.1 64bit.

    Controller is perfectly recognise and every modules for it are loaded.
    lsmod output after "modprobe sg" says:
    Code:
    Module                  Size  Used by
    joydev                 12112  0 
    st                     38892  0 
    ide_disk               14872  0 
    ide_cd_mod             33984  0 
    sym53c8xx              77696  0 
    ip6t_LOG                7180  9 
    xt_tcpudp               3608  14 
    xt_pkttype              2152  3 
    ipt_LOG                 6812  10 
    xt_limit                3180  19 
    binfmt_misc            10260  1 
    snd_pcm_oss            48896  0 
    snd_mixer_oss          16808  1 snd_pcm_oss
    snd_seq                61968  0 
    snd_seq_device          8604  1 snd_seq
    ip6t_REJECT             6024  3 
    nf_conntrack_ipv6      24840  4 
    ip6table_raw            2456  1 
    xt_NOTRACK              2152  4 
    ipt_REJECT              3480  3 
    xt_state                2568  8 
    iptable_raw             2760  1 
    iptable_filter          3400  1 
    ip6table_mangle         3128  0 
    nf_conntrack_netbios_ns     2840  0 
    nf_conntrack_ipv4      12792  4 
    nf_conntrack           80480  5 nf_conntrack_ipv6,xt_NOTRACK,xt_state,nf_conntrack_netbios_ns,nf_conntrack_ipv4
    ip_tables              19464  2 iptable_raw,iptable_filter
    cpufreq_conservative     8272  0 
    cpufreq_userspace       4204  0 
    ip6table_filter         3240  1 
    cpufreq_powersave       2248  0 
    ip6_tables             21048  4 ip6t_LOG,ip6table_raw,ip6table_mangle,ip6table_filter
    x_tables               23376  11 ip6t_LOG,xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,xt_NOTRACK,ipt_REJECT,xt_state,ip_tables,ip6_tables
    acpi_cpufreq            8968  0 
    ipv6                  293608  33 ip6t_REJECT,nf_conntrack_ipv6,ip6table_mangle
    microcode              25912  0 
    fuse                   61088  1 
    ext3                  141912  1 
    jbd                    68824  1 ext3
    mbcache                10412  1 ext3
    loop                   17924  0 
    dm_mod                 73952  0 
    snd_hda_intel         545508  5 
    snd_pcm                95440  3 snd_pcm_oss,snd_hda_intel
    8139too                27564  0 
    usbhid                 52896  0 
    snd_timer              26664  3 snd_seq,snd_pcm
    hid                    41568  1 usbhid
    ohci1394               31380  0 
    8139cp                 22552  0 
    rtc_cmos               13960  0 
    ieee1394               98880  1 ohci1394
    rtc_core               22420  1 rtc_cmos
    button                  8328  0 
    snd_page_alloc          9816  2 snd_hda_intel,snd_pcm
    i2c_i801               12836  0 
    sr_mod                 16196  0 
    mii                     6024  2 8139too,8139cp
    ff_memless              8912  1 usbhid
    rtc_lib                 3560  1 rtc_core
    snd_hwdep               9072  1 snd_hda_intel
    pcspkr                  3064  0 
    iTCO_wdt               13040  0 
    snd                    74632  16 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
    iTCO_vendor_support     4268  1 iTCO_wdt
    intel_agp              29936  0 
    i2c_core               35280  1 i2c_i801
    cdrom                  36200  2 ide_cd_mod,sr_mod
    fglrx                2233048  29 
    soundcore               8816  1 snd
    floppy                 63240  0 
    sd_mod                 35064  11 
    crc_t10dif              2152  1 sd_mod
    ehci_hcd               55348  0 
    uhci_hcd               27928  0 
    usbcore               198656  4 usbhid,ehci_hcd,uhci_hcd
    edd                    10272  0 
    reiserfs              241392  8 
    fan                     6016  0 
    ide_pci_generic         4652  0 
    ide_core              118012  3 ide_disk,ide_cd_mod,ide_pci_generic
    ata_generic             6044  0 
    ata_piix               21628  0 
    thermal                24232  0 
    processor              49904  2 acpi_cpufreq,thermal
    thermal_sys            14336  3 fan,thermal,processor
    hwmon                   4040  1 thermal_sys
    scsi_transport_spi     26904  1 sym53c8xx
    pata_jmicron            4104  10 
    ahci                   34628  0 
    libata                183376  4 ata_generic,ata_piix,pata_jmicron,ahci
    scsi_mod              179144  6 st,sym53c8xx,sr_mod,sd_mod,scsi_transport_spi,libata
    dock                   14564  1 libata
    lsscsi output says:
    Code:
    [2:0:0:0]    disk    ATA      Hitachi HDS72168 P21O  /dev/sda
    [5:0:0:0]    cd/dvd  PIONEER  DVD-RW  DVR-212  1.28  /dev/sr0
    [9:0:2:0]    scanner CANON    IX-40015G        1.07  -

    Problem is that scanners program Vuescan ver. 8.5 do not recognise scanner as a normal user and only root. Vuescan programmer Ed Hammrick said that problem is "sg" device permission but in catalogue /dev I have devices -sg0, -sg1, -sg3 but not -sg. I changed their permission and nothing works. I add additionally group "disk" (devices name) to me as a user and still doesn't work .... I changed permission /usr/bin/@sg soft link and in addition removed sticky bit ... still no progress. Please inform me where is usually "-sg" device because in /dev it doesn't exist !!!

    I'm new to linux and scsi support in this system is a big problem for me

    Bye
    Tom

  2. #2

    Default Re: OpenSuse 11.1+Tekram 310U PCI scsi + scaner - only root

    Hi; welcome to the OpenSuse forums;

    sounds like a very nice and capable scanner that you are keen to get running
    Canon Canoscan FS4000US - photo.net

    this review
    Steves Digicams - Canon Canoscan FS4000 US - User Review
    says it has two built-in interfaces, USB and SCSI

    sounds like you have opted for SCSI;

    we have always used the USB connections, and we have used much simpler desktop scanners;

    my recollections, and they are only that, of reading the sane documentation

    SANE - Documentation

    is that SCSI is perhaps trickier, but you can see;

    for those running either SCSI or USB, the sane project lists the scanners it knows about

    SANE: Supported Devices

    and your scanner is not listed there.

    if you read this link on the sane documentation

    Sane Frequently Asked Questions

    it talks of the issue you describe, root owns the scanner, and not a user

    they suggest you run the command (I would do it as substitute user, (su) also called root)

    # scanimage -L
    In my dev directory, I have sgd files; they cannot be read by me as ordinary user; permissions not granted, but presumably editable as root;

    the above link


    Sane Frequently Asked Questions

    talks of trying to work out from the scanimage command above, which sgd your SCSI is allocated to, and then editing the file to change permissions, so ordinary user has access

    is any of this of help to you?

  3. #3
    clintgengar NNTP User

    Default Re: OpenSuse 11.1+Tekram 310U PCI scsi + scaner - only root

    Hi,

    Thanks for your help but to be honest it wasn't helpful .... a bit CanoScan FS4000US is not supported by sane .... I know this fact. In addition to this CanoScan with scsi works with my hardware (4GB ram, CoreDuo 6400) much faster then usb which means only scsi support is welcomed. On the other hand only linux scanning program is (as I mentioned) ... Vuescan.

    Problem was permission to "sg*" devices. I found this post :
    OpenSuSE 11.1 - an overview opinion - openSUSE Forums (the last reply) and according to that scanner now works under normal user in my Suse 11.1 Thanks for your help and advise. I use sane for many years with my old Plustek U16B and even made small participation in testing backend for this model.

    Bye
    Tom
    Ps.
    As a few years of user Slackware and NetBSD distros (still on my first machine and laptop) I'd like to say that according to posts from this forum Suse is a very buggy distro with problems that not exist in others systems at all. It's a very astonishing as it is Novell company system ........ but I should stress that in comparison to many ...... quite nice to operate just "out of box" ))

  4. #4

    Default Re: OpenSuse 11.1+Tekram 310U PCI scsi + scaner - only root

    thanks; I guess you are going to follow the advice of rudihauser in post #6 where he said:

    The SCSI scanner problem can be solved by adding an udv rule, which sets the correct permission for /dev/sg*:
    I added following line at /etc/udev/rules.d/10-udev.rules:
    KERNEL=="sg*",NAME="%k",GROUP="users",MODE="664"
    Reply With Quote
    can you let the forum know if that works? that would be very helpful for everyone;

    I saw on further reading after I had replied that Vuescan

    VueScan Scanning Software

    ... communicates with the hardware directly rather than through the standard TWAIN interface; this often improves scanning speed.
    so no need of the sane interface that runs twain

    Wikipedia gives a good review of Vuescan, which I see is like turboprint, a proprietary programme; Vuescan seems to have very good reviews for the high-end work that it is intended for;

    VueScan - Wikipedia, the free encyclopedia

  5. #5
    clintgengar NNTP User

    Default Re: OpenSuse 11.1+Tekram 310U PCI scsi+scaner -only root can

    Hi,
    Yes, exactly it works according to "rudihauser" user:

    The SCSI scanner problem can be solved by adding an udv rule, which sets the correct permission for /dev/sg*:
    I added following line at /etc/udev/rules.d/10-udev.rules:
    KERNEL=="sg*",NAME="%k",GROUP="users",MODE="664"
    .......................
    but first have to checked from root account what gives you
    Code:
    lsmod
    command. If controller sym53c8xx module (Tekram 310U - Symbios chipset) exist, now (still from root) unload it
    Code:
    sym53c8xx
    by
    Code:
    rmmod sym53c8xx
    after that
    Code:
    modprobe sg
    and now
    Code:
    modprobe sym53c8xx
    . Command
    Code:
    lsscsi
    or
    Code:
    cat /proc/scsi/scsi
    give you right output. Both modules exist Scanner is seen by system and active (scanner have to be plugged and run). Loading controller + scanner modules you can do by hand from root account or editing startup scrips manually or using Yast which is basic tool for Suse distro.

    Setting right permission for udev means to put additional script in /et/udev/rules.d or put
    Code:
    KERNEL=="sg*",NAME="%k",GROUP="users",MODE="664"
    line to one exist eg. at the bottom .

    On other hand Vuescan for linux (binary runtime version) is a very a powerful scanning program which doesn't much cost (recommend professional version) and the best thing .... you don't need any additional drivers to your scanner - every model is directly "init" or "operate" by Vuescan. You don't need sane.

    Bye
    Tom

  6. #6
    clintgengar NNTP User

    Default Re: OpenSuse 11.1+Tekram 310U PCI scsi + scaner - only root

    Ps.

    Don't be mislead .... all SATA hardware like hard disk or DVD recorders are seen by linux as a scsi devices however they are not "really" scsi ....

  7. #7

    Default Re: OpenSuse 11.1+Tekram 310U PCI scsi + scaner - only root

    great; thanks very much for all this; it will be very valuable and useful to others in the forum; many thanks again, and for bringing Vuescan to folks' attention; looks like a very good product

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •