I have just done a fresh install of openSUSE 11.0 x86_64 and have run into a zypper/openSUSE updater problem. There are three packages which are claimed to be required to be updated from openSUSE-11.0-Updates but neither zypper nor openSUSE updater does anything when I authorize the update. For example, as root using zypper, this is what I get:

xxx:/home/xxx # zypper lu
Reading installed packages...
Patches

Repository | Name | Version | Category | Status
----------------------+----------------------+---------+-------------+-------
openSUSE-11.0-Updates | fileshareset | 124 | recommended | Needed
openSUSE-11.0-Updates | mozilla-xulrunner181 | 329 | security | Needed
openSUSE-11.0-Updates | mozilla-xulrunner181 | 383 | security | Needed
xxx:/home/xxx # zypper up
Reading installed packages...

The following NEW patches are going to be installed:
mozilla-xulrunner181 fileshareset

No additional space will be used or freed after the operation.
Continue? [YES/no]: YES
xxx:/home/xxx # zypper lu
Reading installed packages...
Patches

Repository | Name | Version | Category | Status
----------------------+----------------------+---------+-------------+-------
openSUSE-11.0-Updates | fileshareset | 124 | recommended | Needed
openSUSE-11.0-Updates | mozilla-xulrunner181 | 329 | security | Needed
openSUSE-11.0-Updates | mozilla-xulrunner181 | 383 | security | Needed

I have looked at the 11.0 update repository and there are two delta rpms for these packages and I have downloaded these packages and tried to install them but YaST tells me they are already installed. I have also updated these packages through YaST so I am pretty sure I have the latest versions installed. Aside from these packages the updater seems to be working, for example, the latest fixes to cups were installed without problem.

Does anyone have any suggestions to clear the zypper/openSUSE updater listings? Thanks.