Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Input Problem in KDE especially Konqueror

  1. #1

    Angry Input Problem in KDE especially Konqueror

    Everything works fine in Konqueror(text input, browsing, etc.), but all of a sudden,I am unable to input any text into any of the fields, and sometimes YaST also suffers from the same problem.

    Has anyone else ever encountered that annoying input problem in KDE in openSUSE?

    I am using openSUSE 11.1.

  2. #2
    STS301 NNTP User

    Default Re: Input Problem in KDE especially Konqueror

    does this problem appear for example in openOffice or somewhere else too?

    see if your keyboard is set in correctly.

  3. #3

    Exclamation Re: Input Problem in KDE especially Konqueror

    STS301, This problem does not occur in Firefox, but it most frequently occurs in Konqueror. It occasionally occurs in OpenOffice and in Opera. How do I know if my keyboard is set properly?
    By the way, can you explain the picture in your avatar? Thank you for responding to my predicament.

  4. #4
    STS301 NNTP User

    Default Re: Input Problem in KDE especially Konqueror

    I mean if it is set in correctly in your computer (the cable)

    This is a handball with a tux combination (from tux factory)

  5. #5

    Default Re: Input Problem in KDE especially Konqueror

    STS301, I am utilizing a laptop computer, but it this problem occurred on my desktop installation as well.

    Similar to a problem on Ubuntu, I also have SCIM installed, but this problem has occurred before I even knew about SCIM. It sometimes occurs in YaST, but it always occurs in KDE applications. The most annoying thing is that I have to restart the application to regain input.

  6. #6
    STS301 NNTP User

    Default Re: Input Problem in KDE especially Konqueror

    try to go YaST --> Hardware --> Keyboard --> and see if the settings are right, but I think it is a software problem in openSuse.

    try to google and maybe you find there a solution.

  7. #7

    Red face Re: Input Problem in KDE especially Konqueror

    Thank you for responding STS301. I primarily think the problem rests with KDE, because when installing KUbuntu 2 years ago, the KDE Control Center application was unable to receive any keyboard input.

    I really do envy your avatar!

  8. #8

    Default Re: Input Problem in KDE especially Konqueror

    I've been laboring with this problem for a while (at least I think it's the same problem). On my system, the cause is a wrong setting for the standard text input method in KDE applications, caused by a conflict between X Windows and the SCIM/SKIM text input module. Are you running SCIM/SKIM on your computer? If so, the following might be of help for you:

    (1) For a quickfix, right-click within a text input field and choose "Select IM (=Input Method)". There should be a choice consisting of (at least) "XIM" (= X Windows Input Method) and "SCIM" / "SCIM-bridge". Activate the latter if XIM is selected (or play around with the values to find out what works for you).

    (2) To fix the root of the problem, check first the values for the following environmental variables:GTK_IM_MODULE, QT_IM_MODULE, XIM_PROGRAM, and XMODIFIERS, using the echo command (don't forget the dollar sign in front of the variables):

    # echo $XMODIFIERS
    (3) Most likely, you will want to change the default setting for the variables. You can do this by editing a file called /etc/sysconfig/language. Open if using KWrite, and look for the line that says INPUT_METHOD="", and enter the input method that worked for you in (1) between the quotation marks (for me, that was scim-bridge). Restart your system.

    Hope this works for you.



  9. #9

    Unhappy Re: Input Problem in KDE especially Konqueror

    The worst thing happened to me the other day. After I locked my computer, I came back to type in my password, but I was unable to do so, because the password input box refused to accept keyboard input.

    Do you mean right-click any input field, because I did and did not
    see an option for choosing an input method?

    Yes, I am running SKIM/SCIM on my computer, because I use it for inputting foreign characters.

    $GTK_IM_MODULE, $QT_IM_MODULE = "scim"
    $XIM_PROGRAM = ''

  10. #10

    Default Re: Input Problem in KDE especially Konqueror


    what kind of input methods are you using with SCIM?

    I'm not sure exactly what the cause of your input problem might be. However, if you are using Japanese or Chinese input there is a chance that that those IM were active when you tried to input your password, and since they use an intermediate step for inputing characters (the character conversion window), which isn't displayed on the log-in screen, your characters might have appeared only "off-screen", so to speak.

    The solution for this is to switch off Japanese/Chinese input when you enter your password. Which key is taking care of this depends on your setup; you can check by opening the SKIM settings (right click on the SCIM icon in your task bar and choose Configure), go to "General Scim", "General" tab, and check the entry for "Keyboard Shortcuts" > "Toggle On/Off" and/or "Turn off". (You can also re-define the keys here if you want.)

    It's true, you won't be able to right click in your text input box and chose the IM input mode there if you are in the log-in screen.

    Hope this helps!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts