Results 1 to 6 of 6

Thread: hplip-2.8.12 error on make

  1. #1

    Thumbs down hplip-2.8.12 error on make

    I have a problem with hplips(version in title), it fails on the 'make' part:
    hplip-2.8.12.run
    Creating directory hplip-2.8.12
    Verifying archive integrity... All good.
    Uncompressing HPLIP 2.8.12 Self Extracting Archive.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

    HP Linux Imaging and Printing System (ver. 2.8.12)
    HPLIP Installer ver. 5.0

    Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.

    Installer log saved in: hplip-install_Wed-14-Jan-2009_16:06:55.log

    /home/rory/hplip-2.8.12/installer/core_install.py:32: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
    import sha # TODO: Replace with hashlib (sha is deprecated in Python 3.0)
    \
    note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.


    INSTALLATION MODE
    -----------------
    Automatic mode will install the full HPLIP solution with the most common options.
    Custom mode allows you to chose installation options to fit specific requirements.

    Please choose the installation mode (a=automatic*, c=custom, q=quit) : c

    Initializing. Please wait...
    warning: Invalid ppd_dir value: None


    INSTALL TYPE
    ------------
    For most users, it is recommended to install HPLIP with full support (scanning, faxing, toolbox, etc).
    For servers or minimal installations, you can also install print support only (HPIJS only).

    Install full hplip support (recommended) or print-only support (f=full hplip support*, p=printing only support, q=quit) ?f


    INTRODUCTION
    ------------
    This installer will install HPLIP version 2.8.12 on your computer.
    Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


    DISTRO/OS CONFIRMATION
    ----------------------
    Distro appears to be SUSE Linux 11.1.

    Is "SUSE Linux 11.1" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y


    SELECT HPLIP OPTIONS
    --------------------
    You can select which HPLIP options to enable. Some options require extra dependencies.

    Do you wish to enable 'Network/JetDirect I/O' (y=yes*, n=no, q=quit) ? y
    Do you wish to enable 'Graphical User Interfaces (GUIs)' (y=yes*, n=no, q=quit) ? y
    Do you wish to enable 'PC Send Fax support' (y=yes*, n=no, q=quit) ? y
    Do you wish to enable 'Scanning support' (y=yes*, n=no, q=quit) ? y
    Do you wish to enable 'Parallel I/O (LPT)' (y=yes*, n=no, q=quit) ? y
    Do you wish to enable 'HPLIP documentation (HTML)' (y=yes*, n=no, q=quit) ? y


    ENTER ROOT/SUPERUSER PASSWORD
    -----------------------------
    Please enter the root/superuser password:
    Password accepted


    RUNNING PRE-INSTALL COMMANDS
    ----------------------------


    INSTALL MISSING OPTIONAL DEPENDENCIES
    -------------------------------------
    warning: There are 1 missing OPTIONAL dependencies.
    note: Installation of dependencies requires an active internet connection.
    warning: Missing REQUIRED dependency for option 'parallel': ppdev (ppdev - Parallel port support kernel module.)
    warning: This installer cannot install 'ppdev' for your distro/OS and/or version.
    warning: Option 'parallel' has been turned off.


    READY TO BUILD AND INSTALL
    --------------------------
    Ready to perform build and install. Press <enter> to continue or 'q' to quit:


    PRE-BUILD COMMANDS
    ------------------


    BUILD AND INSTALL
    -----------------
    Running './configure --prefix=/usr --disable-qt4 --enable-foomatic-ppd-install --enable-doc-build --enable-qt3 --enable-gui-build --disable-foomatic-drv-install --disable-pp-build --enable-network-build --enable-dbus-build --disable-hpijs-only-build --enable-scan-build --enable-fax-build'
    Please wait, this may take several minutes...
    Command completed successfully.

    Running 'make clean'
    Please wait, this may take several minutes...
    Command completed successfully.

    Running 'make'
    Please wait, this may take several minutes...
    error: 'make' command failed with status code 2
    It has an error as you can see. This does not happen straight away, it runs make for about 30 seconds showing a twisting bar(|,/,- and \) I have googled about this and i have seen that it can work when running it from the /home directory. This didn't help.
    I am running openSUSE 11.1 KDE4, i had hplip installed and working perfectly on my previous version (11.0). I have make installed.

    Thanks for any help

  2. #2
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    253

    Default Re: hplip-2.8.12 error on make

    When it asks for the parallel port support say no. Or you can install ppdev packages.

    Also check to see if you have the Kernel-sources installed. Along with gcc

    I would also find out why this:

    Code:
    /home/rory/hplip-2.8.12/installer/core_install.py:32: DeprecationWarning: the sha module is deprecated; use the hashlib module instead 
     import sha # TODO: Replace with hashlib (sha is deprecated in Python 3.0)
    Shows up.
    Did you check the logs? there is bound to be more information about the error 2 in there.
    Code:
    Installer log saved in: hplip-install_Wed-14-Jan-2009_16:06:55.log
    OpenSUSE Leap 15, KDE5 (plasma 5.13, frameworks 5.49, QT 5.11)

  3. #3

    Default Re: hplip-2.8.12 error on make

    hplip-install[25406]: info: :[01mINSTALL MISSING REQUIRED DEPENDENCIES[0m
    hplip-install[25406]: info: :[01m-------------------------------------[0m
    warning: There are 7 missing REQUIRED dependencies.
    note: Installation of dependencies requires an active internet connection.
    warning: Missing REQUIRED dependency: gcc (gcc - GNU Project C and C++ Compiler)
    warning: This installer cannot install 'gcc' for your distro/OS and/or version.
    error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.
    thats at the end of the log. But i have gcc installed.
    help!
    thanks

  4. #4

    Default Re: hplip-2.8.12 error on make

    Aha, I fixed it;
    i searched gcc and installed everything that had c++ and fortran in the name. i then ran it and it needed a library libg something. i ran it again and it successfully worked.
    thanks

  5. #5

    Default Re: hplip-2.8.12 error on make

    I have done the downloading for GCC c++ and fortran but still mine does not work. hangs up at the same spot.


    any ideas?

  6. #6

    Default Re: hplip-2.8.12 error on make

    I use the All-in-one Photosmart c309m. The default hplip from openSuse 11.2 saw the printer (manually installed via jetdirect on fixed ip), but not the scanner.
    Installing hplip 3.9.12 from the commandline went wrong on the same point as above. Log file showed that libgphoto did not exist. Added via yast libgphoto2-devel and libgphoto2-lang. After this, everything worked.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •