Results 1 to 7 of 7

Thread: How to disable update for a package

  1. #1

    Default How to disable update for a package

    Hello,

    I have an application here that has some incompatibilities with java 1.6.0_11 and for this reason I must use java 1.6.0_7.

    The problem is that everyday the update applet shows me a message telling to update this package.

    Is there a way to disable the update of this package without removing OpenSUSE Update Repository?

    Thanks in advance,

    Tulio Magno

  2. #2

    Default Re: How to disable update for a package

    Goto yast > oline update > right click the update in question and select " protect " from the menu.

  3. #3

    Default Re: How to disable update for a package

    Hello BoloMarkIII,

    Thanks for your help.

    I tried this, but I'm still getting these messages...

    Best regards,

    Tulio Magno

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,098
    Blog Entries
    15

    Default Re: How to disable update for a package

    Quote Originally Posted by tuliom
    Hello BoloMarkIII,

    Thanks for your help.

    I tried this, but I'm still getting these messages...

    Best regards,

    Tulio Magno
    Hi
    Have a read of this post user lornix has a fix;
    How
    to lock a package permanently?


    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-pae
    up 8:23, 1 user, load average: 0.32, 0.29, 0.21
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22


  5. #5

    Default Re: How to disable update for a package

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Have a read of this post user lornix has a fix;
    How
    to lock a package permanently?
    Hi malcolmlewis,

    Thanks for your help.
    I tried that. Firstly I changed the backend to zypper (I think the default in OpenSUSE 11.1 is PackageKit) to show that special tab.

    But I'm still receiving these messages from kupdateapplet.

    I think it's really necessary to create an easy option in kupdateapplet to block some updates.

  6. #6

    Default Re: How to disable update for a package

    In openSUSE 11.3, the update applet still tries to update locked packages (i.
    e. installed packages that are marked as protected in Yast Software Management)
    but marking patches as taboo in Yast Online Update works (patches marked as
    taboo are not shown in the update applet). See
    https://bugzilla.novell.com/show_bug.cgi?id=544466

  7. #7

    Default Re: How to disable update for a package

    It works!
    Thank you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •